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Artikel-ID: 151789 - Geändert am: Samstag, 28. Oktober 2006 - Version: 4.4

 

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Problembeschreibung

Symptome jede JET Datenbank-Operation, die in einem-1018-(JET_errReadVerifyFailure) und/oder alle Windows NT-Ereignisanzeige Anwendung Protokollfehler gemeldet, die den Fehlercode-1018-im zugehörigen Beschreibung, wie z. B. die folgenden enthalten:
Ereignis-ID: 23
Quelle: EDB
Typ: Fehler
Kategorie: Datenbank-Seitencache
Beschreibung: MSExchangeIS ((455)) Direct lesen gefunden beschädigte Seite Fehler-1018 ((1:251563) (0-2295758) 251563 379225672 381322824). Stellen Sie bitte die Datenbank aus einer früheren Sicherung wieder her.

Ursache

Wenn Sie eine Transaktion mit der Jet-Datenbank ausführen, schreibt der Informationsspeicher oder das Verzeichnis zum Speichern die Transaktion in einer Transaktionsprotokolldatei (in Mdbdata oder Dsadata Edb*.log). Die Transaktion wird dann per Commit in der Jet-Datenbank übernommen. Während dieses Vorgangs berechnet die Jet-Engine Prüfsummenwert für die Seite geschrieben werden, zeichnet es in die Kopfzeile der Seite, und dann fordert, dass das Dateisystem die 4 KB-Seite mit Daten in die Datenbank auf Festplatte geschrieben. Kurz gesagt, das Dateisystem dauert dieser Aufruf und Windows NT-System-Dienste verwendet, um diese Anforderung an die entsprechenden Hardwaregerätetreiber tatsächlich den Schreibvorgang durchführen weiterzuleiten. Der Hardware-Gerätetreiber gibt diese Informationen an das Dateisystem, das dann an die Jet-Engine zurückgibt zurück. Wenn der Aufruf erfolgreich ist, weiterhin Jet.

Fehlerhafte Hardware oder Hardwaregerätetreiber möglicherweise erfolgreich für Anrufe an diese, bevor Sie tatsächlich die physische Operation durchführen zurück. Wenn der tatsächliche physische Vorgang stattfindet, jedoch ein Fehler auftritt und die Daten nicht wie erwartet erfolgreich geschrieben.

In bestimmten Datenbank Operationen wie z. B., aber nicht beschränkt auf Online Backup, Sicherung Routine führt einen Aufruf an das Betriebssystem eine 4-KB-Seite mit Daten aus der Datenbank auf dem Datenträger gelesen und auf Band geschrieben. Bevor vom Betriebssystem Aufruf auf dem Band übertragen der Daten zurückgegeben werden, vergleicht der Onlinesicherung den Prüfsummenwert im Seitenkopf (aufgezeichnet, wann diese Seite geschrieben wurde auf dem Datenträger), die zurückgegeben werden aus der READ aufrufen. Wenn die Prüfsummenwerte nicht übereinstimmen, das JET-Datenbankmodul erkennt dies und gibt-1018-(JET_errReadVerifyFailure).

Lösung

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.

Aus einer Sicherung wiederherstellen

Wenn den Fehler auftritt, ist die empfohlene und zuverlässigste Möglichkeit zum Wiederherstellen der Datenbank aus der letzten bekannten guten Sicherung wiederherstellen.

NOTES :

Selbst nachdem Sie von einer einwandfreien Sicherungskopie wiederhergestellt haben, können jedoch der-1018-Fehler erneut angezeigt, sofern die Ursachen von der physischen Daten Schreibvorgang Probleme behoben werden.

Windows NT-System-Protokoll sollte für Fehler durch die Festplatten und Festplatten-Controller sowie an das NT Fault Tolerant Festplatten-Teilsystem (FTDISK) überprüft werden. Insbesondere können hardwarebezogene Fehler z. B. SCSI-Zeitüberschreitungen, Speicherfehler oder Laufwerk beschädigt-Fehler angezeigt. Dieser Fehler sollte behandelt und aufgelöst, bevor die Datenbank auf diesem Server wiederhergestellt wird.

Auch wenn keine hardwarebezogene Fehler in Windows NT-System-Protokoll angezeigt werden, besteht möglicherweise ein Hardwareproblem auf Ihrem Computer.

Microsoft-Recommendeds, dass Sie Ihren Hardwarehersteller nach weiteren Updates bezüglich Ihrer Hardware wenden.

Verwendung Edbutil.exe oder Eseutil.exe

Eine alternative Methode zum Reparieren der defekten Seite Daten ist die Verwendung Edbutil.exe für Exchange Server 4.0 und 5.0 oder Eseutil.exe für Exchange Server 5.5.

wichtig : Stellen Sie eine vollständige Offlinedatei Sicherung der Datenbank- und Protokolldateien Dateien vor dem Ausführen dieser Prozess. Dies umfasst auf Dateiebene Sicherungen von den Ordnern Exchsrvr\Dsadata und Exchsrvr\Mdbdata. Stellt dies sicher, dass eine Möglichkeit, gehen Sie zurück, wenn Edbutil-Eseutil fehlschlägt.

Edbutil.exe (und "Eseutil.exe") ist ein Dienstprogramm der Jet-Datenbank auf niedriger Ebene, das defragmentiert und überprüft die Konsistenz der Datenbank. Es gibt auch eine Reparaturoption (Edbutil/d/r <dbname>, Eseutil/p <dbname>), die versucht, fehlerhafte Seiten reparieren und entfernen Sie, wenn die Reparatur fehlgeschlagen ist. Wenn eine Seite mit der Option reparieren entfernt wird, wird Datenverlust auftreten. Eine Seite in einer Datenbank kann Nachrichten, Ordner, Tabellen, master Indizes usw. enthalten. Es gibt keine Möglichkeit mitteilen, welche Edbutil oder Eseutil entfernt wurde, da Jet er als unformatierte Daten sieht. Nachdem Reparatur auf der Jet-Datenbank beendet wurde, führen Sie eine offline-Defragmentierung (Edbutil/d <dbname> oder Eseutil/p <dbname>), Space Trees zu reparieren. Unmittelbar nach der Defragmentierung führen Sie Isinteg.exe im Reparaturmodus auf dieselbe Datenbank, die "edbutil" oder "Eseutil" ausgeführt wurde. Isinteg bereinigt alle Inkonsistenzen zwischen den Zeigern aus dem Informationsspeicher auf den eigentlichen Daten in der Jet-Datenbank. Wenn Isinteg unmittelbar folgenden reparieren nicht ausgeführt wird, kann Beschädigungen in Benutzerpostfächern auftreten. Benutzer müssen Nachrichten, die nicht geöffnet werden kann, falsch gelesen/ungelesen zählt und So weiter. Nachdem "edbutil" oder "Eseutil" ausgeführt haben, erstellen Sie eine VOLLSTÄNDIGE Sicherungskopie der Datenbank, die repariert wurde.

Finden Sie ausführliche Informationen über die Verwendung von Edbutil.exe und Isinteg.exe der Microsoft Exchange Server Administrator's Guide .

Das Problem beheben

Wenn Sie nicht das Problem durch die Wiederherstellung aus einer Sicherung oder mit Edbutil.exe oder Eseutil.exe beheben, gehen Sie folgendermaßen, um das Problem zu beheben. Überprüfen Sie nach jeder Schritt durchführen, wenn das Problem behoben ist.
  1. Starten Sie den Computer neu. Wenn Sie nicht, den Computer zu diesem Zeitpunkt neu zu starten möchten, beenden, und stattdessen starten neu die Informationen speichern und Verzeichnisdienste. Gehen Sie dazu folgendermaßen vor:
    1. Doppelklicken Sie in der Systemsteuerung auf Dienste .
    2. Klicken Sie auf Microsoft Exchange-Verzeichnis , und klicken Sie dann auf Beenden . Wenn ein Dialogfeld angezeigt, die besagt, dass zusätzliche Dienste beendet werden soll, Beachten Sie die Dienste, die beendet werden, und klicken Sie dann auf OK . Der Informationsspeicher-Dienst sollte in der Liste der Dienste enthalten sein, die beendet werden.
    3. Klicken Sie auf Microsoft Exchange-Verzeichnis , und klicken Sie dann auf Starten .
    4. Starten Sie alle zusätzlichen Dienste, die beendet wurden, in Schritt b, einschließlich der Informationsspeicher-Dienst.
  2. Verwenden Sie das CHKDSK.exe-Dienstprogramm, um die Integrität Ihrer Festplatten zu überprüfen.
  3. Wenn der Ordner "Exchsrvr" auf einem komprimierten NTFS-Dateisystemlaufwerk befindet, Dekomprimieren des Laufwerks.
  4. Wenn Write-Back-caching auf einen SCSI-Festplattencontroller auf Ihrem Computer installierte aktiviert ist, stellen Sie sicher, dass der Cache nicht flüchtige ist. Nicht flüchtigen Cache werden durch eine Batterie, Flash-RAM oder eine andere Methode geschützt.
  5. Deaktivieren Sie alle Programme, die Dateien für einen längeren Zeitraum, z. B. Antivirenprogramme, Datei- und Datenträger-Verwaltungsdienstprogrammen oder Sicherungsprogramme geöffnet bleiben. Wenn ein Programm deaktivieren das Problem verhindert, sicher, dass das Programm vollständig kompatibel mit Exchange Server, ist bevor Sie erneut aktivieren.
  6. Leistungsoptimierung (Perfwiz.exe) auf dem Server ausgeführt.
  7. Stellen Sie sicher, dass die virtuellen Speichereinstellungen in Windows NT Server korrekt sind. Um die Einstellungen virtueller Speicher in der Systemsteuerung anzuzeigen, doppelklicken Sie auf System , klicken Sie auf die Registerkarte Leistung , und klicken Sie dann auf Ändern .
  8. Überprüfen Sie wenn Sie alle von Ihrem OEM (Original Equipment Manufacturer) erhalten Festplattendienstprogramme ausführen, ob Sie die aktuellste Version der Programme ausgeführt werden.
  9. Verwenden Sie die Systemmonitor-Leistungsindikatoren die folgenden Objekte zugeordnet, um potenzielle Probleme zu erkennen:
    • Cache
    • Datenbank
    • Logischer Datenträger
    • Speicher
    • MSExchangeIS
    • Auslagerungsdatei
    • Physikalischer Datenträger
    • Prozess
    • Serverwarteschlangen
    • Server
    • System
    • Thread

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Standard Edition
  • Microsoft Exchange Server 5.5 Standard Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 151789  (http://support.microsoft.com/kb/151789/en-us/ )
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