DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 222101 - Geändert am: Montag, 19. März 2007 - Version: 6.1

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
222101  (http://support.microsoft.com/kb/222101/EN-US/ ) How to find and use Office object model documentation
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Zusammenfassung

Dieser Artikel beschreibt die Dokumentation sowie die Ressourcen, die Ihnen zur Automatisierung von Microsoft Office-Anwendungen zur Verfügung stehen. Diese Informationen können unabhängig von der Programmiersprache angewendet werden, die Sie für die Automatisierung der jeweiligen Office-Anwendung ausgewählt haben. In diesem Artikel wird außerdem erläutert, wie Sie mit dem Erstellen von Automatisierungscode beginnen, und wie Sie in der Dokumentation die Informationen finden, die Sie zum Automatisieren bestimmter Aufgaben benötigen.

Weitere Informationen

Wo finde ich die Dokumentation zum Objektmodell?

Die Objektmodelle für die Office-Anwendungen sind in einer Sprachreferenz für beide Versionen von Office dokumentiert: Sprachreferenz für Microsoft Office 97 Visual Basic für Applikationen
ISBN 1-57231-339-0

Sprachreferenz für Microsoft Office 2000 Visual Basic für Applikationen
ISBN 1-57231-955-0.
Diese Sprachreferenzen sind auf der MSDN-Website und in der Onlinehilfe von Microsoft Office verfügbar. Sie können auch in Buchform erworben werden. Besuchen Sie die folgende Website, um Bestellinformationen zu erhalten:
http://mspress.microsoft.com
In der folgenden Tabelle sind die Hilfedateien der einzelnen Office-Anwendungen aufgelistet.

Tabelle minimierenTabelle vergrößern
AnwendungVersion 97 (oder 8.0)Version 2000 (oder 9.0)Version 2002 (oder 10)Version 2003 (oder 11)
OfficeVbaoff8.hlpVbaoff9.chmVbaof10.chmVbaof11.chm
AccessAcvba80.hlpAcmain9.chmAcmain10.chm, Vbaac10.chmACMAIN11.chm,VBAAC10.chm
ExcelVbaXl8.hlpVbaxl9.chmVbaxl10.chmVBAXL10.chm
MapPointNicht zutreffendMappoint.chm (ver.2001)Mappoint.chmMAPPOINT.chmn (Ver. 2004)
OutlookVbaoutl.hlpVbaoutl9.chmVbaol10.chmVBAOL11.chm
PowerPointVbappt.hlpVbappt9.chmVbapp10.chmVBAPP10.chm
WordVbawrd8.hlpVbawrd9.chmVbawd10.chmVBAWD10.chm
GraphVbagrp8.hlpVbagrp9.chmVbagr10.chmVBAGR10.chm
FrontPageNicht zutreffendVbafp4.chm, Vbafpom4.chmVbafpd10.chm, vbafpw10.chmVBAFPD10.chm, VBAFPW10.chm
SammelmappeVbabdr8.hlpVbabdr8.hlpNicht mehr verfügbar


Die Hilfedateien von Microsoft Office 97 werden standardmäßig im folgenden Pfad installiert:
C:\Programme\Microsoft Office\Office
Wenn Sie die benötigte Office 97-VBA-Hilfedatei nicht finden können, wurde die Datei beim ursprünglichen Office 97-Setup möglicherweise nicht installiert. Führen Sie zum Installieren der VBA-Hilfedatei das Office-Setupprogramm aus. Beachten Sie, dass die VBA-Hilfedatei für Outlook 97 nicht automatisch vom Office-Setupprogramm installiert wird. Weitere Informationen zum Installieren der VBA-Hilfedatei für Outlook 97 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
166738  (http://support.microsoft.com/kb/166738/DE/ ) OL97: wie Installieren von Visual Basic-Hilfe
Die Hilfedateien von Microsoft Office 2000 werden standardmäßig im folgenden Pfad installiert:
C:\Programme\Microsoft Office\Office\1033
Die Hilfedateien von Microsoft Office XP werden standardmäßig im folgenden Pfad installiert:
C:\Programme\Microsoft Office\Office10\1033
C:\Programme\Microsoft Office\Office11\1033
Hinweis: Die Setupprogramme von Microsoft Office 2000, Microsoft Office XP und Microsoft Office 2003 installieren die VBA-Hilfedateien bei der ersten Verwendung. Daher wird die Hilfedatei möglicherweise nicht in diesem Verzeichnis angezeigt, wenn Sie in der Office-Anwendung zuvor noch nicht auf die VBA-Hilfe zugegriffen haben.

Wie kann ich die Dokumentation zum Objektmodell verwenden?

Es gibt verschiedene Verfahren für die Suche nach Dokumentation zu einer bestimmten Klasse, Methode oder Eigenschaft:
  • Durchsuchen der VBA-Hilfedatei:

    Rufen Sie im Visual Basic-Editor der jeweiligen Office-Anwendung die Hilfe auf. Klicken Sie dazu im Menü ? auf Inhalt/Index. Wählen Sie auf der Registerkarte Inhalt die gewünschte Sprachreferenz aus, und klicken Sie auf Öffnen. Die VBA-Hilfe für die ausgewählte Sprachreferenz wird angezeigt. Sie können nun entweder auf der Registerkarte Index oder der Registerkarte Suchen nach Informationen zu einer bestimmten Klasse, Methode oder Eigenschaft suchen.
  • Verwenden der kontextabhängigen Hilfe in einem Modul oder im Direktfenster:

    Geben Sie im Codefenster eines Moduls oder im Direktfenster des Visual Basic-Editors für die Office-Anwendung die Klasse, Methode oder Eigenschaft ein, markieren Sie den Text, und drücken Sie die Taste [F1]. Das Hilfethema für das Element wird angezeigt.
  • Verwenden des Objektkatalogs:

    Drücken Sie im Visual Basic-Editor der Office-Anwendung die Taste [F2], um den Objektkatalog anzuzeigen. Der Objektkatalog listet alle Klassen der Anwendung sowie die Methoden und Eigenschaften auf, die mit den einzelnen Klassen verknüpft sind. Um die Hilfe zu einer bestimmten Klasse oder einem Klassenelement anzuzeigen, markieren Sie die jeweilige Klasse bzw. das Klassenelement im Objektkatalog, und drücken Sie die Taste [F1].

Wie erkenne ich, welche Klassen, Methoden und Eigenschaften ich verwenden soll?

Falls Sie das Objektmodell der zu automatisierenden Anwendung nicht genau kennen, verwenden Sie die Makroaufzeichnung der Anwendung, um eine generelle Vorstellung darüber zu erhalten. Beispiel: Sie möchten Microsoft Word automatisieren, um Text zu einem neuen Dokument hinzuzufügen und das Dokument anschließend zu speichern. Sie wissen jedoch nicht, welche Methoden und Eigenschaften hierfür erforderlich sind. Verwenden Sie in diesem Fall die Makroaufzeichnung:
  1. Starten Sie Microsoft Word.
  2. Klicken Sie im Menü Extras auf Makro, und klicken Sie anschließend auf Aufzeichnen. Geben Sie einen Namen für das neue Makro ein, und klicken Sie auf OK, um mit der Aufzeichnung zu beginnen.
  3. Starten Sie ein neues Dokument.
  4. Geben Sie one ein, und drücken Sie die [EINGABETASTE].
  5. Geben Sie two ein, und drücken Sie die [EINGABETASTE].
  6. Geben Sie three ein.
  7. Klicken Sie im Menü Datei auf Speichern, und speichern Sie das Dokument als "C:\doc1.doc".
  8. Klicken Sie auf die Schaltfläche Aufzeichnung beenden (oder klicken Sie im Menü Extras auf Makro, und klicken Sie anschließend auf Aufzeichnung beenden).
  9. Um den VBA-Code anzuzeigen, den die Makroaufzeichnung aus Ihren Aktionen erstellt hat, klicken Sie im Menü Extras auf Makro, und wählen Sie die Option Makros. Wählen Sie den Namen des neuen Makros in der Liste aus, und klicken Sie auf Bearbeiten. Der Visual Basic-Editor wird mit dem aufgezeichneten Makro angezeigt:
     Documents.Add
     Selection.TypeText Text:="one"
     Selection.TypeParagraph
     Selection.TypeText Text:="two"
     Selection.TypeParagraph
     Selection.TypeText Text:="three"
     ActiveDocument.SaveAs FileName:="Doc1.doc", FileFormat:=wdFormatDocument,_
       LockComments:=False, Password:="", AddToRecentFiles:=True, _ 
       WritePassword:="", ReadOnlyRecommended:=False, _
       EmbedTrueTypeFonts:=False, SaveNativePictureFormat:=False, _
       SaveFormsData:=False, SaveAsAOCELetter:= False
    					
Sie können hier gut erkennen, welche Klassen das Objektmodell enthält. Außerdem werden Beschreibungen sowie der Typ der einzelnen Parameter für die von Ihnen verwendeten Methoden und Eigenschaften angezeigt.

Sehen Sie sich zunächst die erste Zeile des aufgezeichneten Makros an: Documents.Add. Markieren Sie Documents im Code-Modul des aufgezeichneten Makros, und drücken Sie die Taste [F1]. Das Hilfethema zeigt die folgenden wichtigen Informationen an:
  • Die "Documents-Eigenschaft" gibt eine Documents-Auflistung zurück, die alle geöffneten Dokumente darstellt.
  • Die "Documents-Eigenschaft" bezieht sich auf das Application-Objekt.
Kehren Sie zum aufgezeichneten Makro zurück, markieren Sie Add im Code-Modul, und drücken Sie die Taste [F1]. Im angezeigten Hilfethema werden Sie darüber informiert, dass viele verschiedene Objekte über eine Add-Methode verfügen. Klicken Sie auf Documents, um die Hilfe für die Add-Methode der Documents-Auflistung anzuzeigen. Das Hilfethema zeigt die folgenden wichtigen Informationen an:
  • Die "Add-Methode" fügt ein neues, leeres Dokument zur Auflistung der geöffneten Dokumente hinzu.
  • Die "Add-Methode" kann zwei (optionale) Argumente haben.
Sehen Sie sich nun die nächste Zeile des aufgezeichneten Makros an: Selection.TypeText Text:="one". Markieren Sie Selection im Code-Modul, und drücken Sie die Taste [F1]:
  • Die "Selection-Eigenschaft" gibt das Selection-Objekt zurück, das einen markierten Bereich oder einen Einfügepunkt darstellt.
  • Die "Selection-Eigenschaft" bezieht sich auf das Application-Objekt.
Kehren Sie zum aufgezeichneten Makro zurück, markieren Sie TypeText im Code-Modul, und drücken Sie die Taste [F1].
  • Die "TypeText-Methode" fügt den angegebenen Text ein.
  • Die "TypeText-Methode" hat ein erforderliches Argument des Typs "String".
  • Die "TypeText-Methode" bezieht sich auf das Selection-Objekt.
Zeigen Sie anschließend das Hilfethema für TypeParagraph an:
  • Die "TypeParagraph-Methode" fügt einen neuen, leeren Absatz ein.
  • Die "TypeParagraph-Methode" bezieht sich auf das Selection-Objekt und hat keine Argumente.
Zeigen Sie die Hilfethemen für die ActiveDocument-Eigenschaft und die SaveAs-Methode an:
  • Die "ActiveDocument-Eigenschaft" gibt ein Document-Objekt zurück, welches das aktive Dokument (das Dokument im Vordergrund) darstellt. Die "ActiveDocument-Eigenschaft" bezieht sich auf das Application-Objekt.
  • Die "SaveAs-Methode" speichert das Dokument. Je nach der verwendeten Version von Word hat diese Methode 11 bis 16 Argumente. Es ist jedoch nur jeweils ein Argument erforderlich. Die "SaveAs-Methode" bezieht sich auf ein Document-Objekt.
Die Documents-, die Selection- und die ActiveDocument-Eigenschaft beziehen sich zwar auf das Application-Objekt, Sie haben jedoch eventuell festgestellt, dass im aufgezeichneten Makro nicht auf das "Application-Objekt" verwiesen wird. Das Application-Objekt ist das Standardobjekt für alle Eigenschaften und kann daher beim Erstellen von Code in einem VBA-Makro weggelassen werden. Beim Programmieren von Automatisierungscode ist dies jedoch nicht der Fall. Alle Eigenschaften und Methoden müssen im Automatisierungscode vollständig angegeben werden.

Beim Betrachten des aufgezeichneten Makros werden Sie sehen, dass die SaveAs-Methode ein Argument besitzt, das die integrierte Konstante wdFormatDocument übergibt. Je nach der für den Automatisierungscontroller gewählten Programmiersprache müssen Sie eventuell den numerischen Wert für die integrierten Konstanten übergeben. Das Hilfethema für die SaveAs-Methode macht hierüber keine Angaben, jedoch können Sie diese Informationen im Objektkatalog finden. Drücken Sie die Taste [F2], um den Objektkatalog anzuzeigen. Geben Sie

wdFormatDocument

im Suchfenster ein, und drücken Sie die [EINGABETASTE]. Im unteren Teilfenster des Objektkatalogs erscheint das numerische Äquivalent von wdFormatDocument(=0). Außerdem werden weitere Informationen zu der Konstante angezeigt.

Informationsquellen

Wo finde ich Beispiele für Automatisierungscode?

Die Informationen in diesem Artikel sind eine gute Grundlage für das Erstellen von Automatisierungscode. Die Microsoft Knowledge Base ist eine ausgezeichnete Quelle für Automatisierungscode-Beispiele in Visual Basic, Visual C++ und MFC. Hier nur einige Beispiele:

Für Visual Basic-Entwickler

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
220595  (http://support.microsoft.com/kb/220595/DE/ ) Automatisieren von Outlook mithilfe von Visual Basic
219151  (http://support.microsoft.com/kb/219151/DE/ ) Automatisieren von Microsoft Excel aus Visual Basic
147650  (http://support.microsoft.com/kb/147650/DE/ ) Wie Navigieren in Excel-Objekten in Visual Basic
142387  (http://support.microsoft.com/kb/142387/DE/ ) Erstellen eines W/OLE Excel Diagramm Automatisierung in Visual Basic
184974  (http://support.microsoft.com/kb/184974/DE/ ) OFF: wie Verwenden von Automatisierung (OLES) mit Word
220607  (http://support.microsoft.com/kb/220607/DE/ ) Kann Microsoft Word wie automatisieren, um Seriendruck in Visual Basic durchzuführen
222929  (http://support.microsoft.com/kb/222929/DE/ ) Wie Automatisieren von PowerPoint, indem Visual Basic in Office 2003, Office XP Developer und Office 2000 Developer verwendet

Visual C++-Entwickler (unter Verwendung von MFC)

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
178749  (http://support.microsoft.com/kb/178749/DE/ ) Erstellen eines Automatisierungsprojekts mit MFC und einer Typenbibliothek
179706  (http://support.microsoft.com/kb/179706/DE/ ) Wie Verwenden von MFC zu Automatisierung von Excel, dem Erstellen und dem Formatieren einer neuen Arbeitsmappe
186120  (http://support.microsoft.com/kb/186120/DE/ ) Wie Verwenden von MFC zu Automatisierung von Excel und Füllen eines Bereichs mit einem Arrays
186122  (http://support.microsoft.com/kb/186122/DE/ ) Wie Verwenden von MFC zu dem Automatisieren von Excel 2000 und Excel 2002 und dem Abrufen eines Array aus einem Bereich in Excel 2000 und Excel 2002
220911  (http://support.microsoft.com/kb/220911/DE/ ) Kann Microsoft Word wie automatisieren, um Seriendruck durchzuführen, der Visual C++ und MFC verwendet
222960  (http://support.microsoft.com/kb/222960/DE/ ) Wie Automatisieren von PowerPoint, indem Visual C++ 5.0 oder Visual C++ 6.0 mit The Microsoft Foundation Classes verwendet

C/C++-Entwickler (ohne MFC)

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
216686  (http://support.microsoft.com/kb/216686/DE/ ) Welche Verfahrensweise nach Automatisierungsexcel von C++ ohne Using MFC oder Import
181473  (http://support.microsoft.com/kb/181473/DE/ ) HOWTO: verwenden Sie Ole-Automatisierung aus einer C-anwendung lieber als einem C-C++

Visual J++-Entwickler

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
219430  (http://support.microsoft.com/kb/219430/DE/ ) Wie Create/Format einer Excel-Arbeitsmappe, die visuelle Automatisierung von J++ verwendet
215484  (http://support.microsoft.com/kb/215484/DE/ ) Wie Automatisieren von PowerPoint, indem Visual J++ 6.0 verwendet

Visual FoxPro-Entwickler

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
142193  (http://support.microsoft.com/kb/142193/DE/ ) Wie Verwenden von Ole-Automatisierung, um Daten Excel-Tabelle hinzuzufügen
180901  (http://support.microsoft.com/kb/180901/DE/ ) Wie Erstellen einer kategorisierten Tabelle in Word 97 oder Office Word 2003 aus Visual FoxPro for Windows 5.0 und höheren Versionen
181926  (http://support.microsoft.com/kb/181926/DE/ ) Kann Serie in Word wie automatisieren, das OLE und ODBC verwendet
194306  (http://support.microsoft.com/kb/194306/DE/ ) Wie Machen von Duplex drucken, indem Word auf Ole-Automatisierung von Visual FoxPro klickt
230154  (http://support.microsoft.com/kb/230154/DE/ ) Kann PowerPoint wie automatisieren, das Visual FoxPro verwendet
241942  (http://support.microsoft.com/kb/241942/DE/ ) Verhindern von Worddruckerfehler mit BackgroundPrintingStatus-Eigenschaft
Weitere Informationen sowie Beispielcode und Ressourcen zur Automatisierung von Microsoft Office finden Sie auf der folgenden Website von Microsoft:
http://support.microsoft.com/gp/ofd (http://support.microsoft.com/gp/ofd)

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office Standard Edition 2003
  • Microsoft Visual Basic 4.0 Professional Edition
  • Microsoft Visual Basic 5.0 Professional Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic 4.0 Enterprise Edition
  • Microsoft Visual Basic 5.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Enterprise Edition
  • Microsoft Visual C++ 4.0 Professional Edition
  • Microsoft Visual C++ 5.0 Professional Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2003 Professional Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Access 97 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft Outlook 97 Standard Edition
  • Microsoft Outlook 98 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Visual FoxPro 5.0a
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft MapPoint 2002 Standard Edition
  • Microsoft MapPoint 2001 Standard Edition
Keywords: 
_ik11561 _ik11593 kbautomation kbgrpdso kbhowto kbvba kbvbp400 kbvbp500 kbvbp600 KB222101
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store