DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 2328240 - Geändert am: Freitag, 31. Januar 2014 - Version: 3.0

Problembeschreibung

Auf einem Computer mit Windows 7 oder Windows Server 2008 R2 wird im Anwendungsprotokoll ein Fehler mit etwa folgendem Inhalt verzeichnet:
Protokollname: Anwendung
Quelle: Microsoft-Windows-CAPI2
Datum: Datum und Uhrzeit
Ereigniskennung: 4107
Taskkategorie: Keine
Stufe: Fehler
Stichwörter: Klassisch
Benutzer: -
Computer: Computername
Beschreibung:
Die Extrahierung der Drittanbieterstammlisten aus der automatischen Aktualisierungs-CAB-Datei bei <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab (http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab) > ist fehlgeschlagen mit dem Fehler: Ein erforderliches Zertifikat hat nicht über den Gültigkeitszeitraum verfügt, als dieses gegenüber der Systemzeit bzw. den Zeitstempel einer signierten Datei verifiziert wurde.
Auf einem Computer mit Windows Vista oder Windows Server 2008 wird im Anwendungsprotokoll ein Fehler mit etwa folgendem Inhalt verzeichnet:
Protokollname: Anwendung
Quelle: Microsoft-Windows-CAPI2
Datum: Datum und Uhrzeit
Ereigniskennung: 11
Taskkategorie: Keine
Stufe: Fehler
Stichwörter: Klassisch
Benutzer: -
Computer: Computername
Beschreibung:
Die Extrahierung der Drittanbieterstammlisten aus der automatischen Aktualisierungs-CAB-Datei bei <http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab (http://www.download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab) > ist fehlgeschlagen mit dem Fehler: Ein erforderliches Zertifikat befindet sich nicht im Gültigkeitszeitraum gemessen an der aktuellen Systemzeit oder dem Zeitstempel in der signierten Datei.

Ursache

Dieser Fehler tritt auf, weil das Zertifikat des Herausgebers der Microsoft-Zertifikatvertrauensliste abgelaufen ist. Im Ordner "CryptnetUrlCache" ist eine Kopie der Zertifikatvertrauensliste mit einem abgelaufenen Signierungszertifikat gespeichert.

Lösung

Wenn Sie das Problem automatisch beheben lassen möchten, lesen Sie den Abschnitt "Problem automatisch beheben". Wenn Sie das Problem lieber selbst beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Problem automatisch beheben


Bild minimierenBild vergrößern

Wenn Sie das Problem automatisch beheben lassen möchten, klicken Sie auf die Fix it-Schaltfläche oder den Link Problem beheben. Klicken Sie im Dialogfeld Dateidownload auf Ausführen, und befolgen Sie die Schritte im Fix it-Assistenten.

Windows 8, Windows8.1, Windows Server 2012, Windows Server 2012 R2
Bild minimierenBild vergrößern

Bild minimierenBild vergrößern
Problem beheben (http://go.microsoft.com/?linkid=9842951)
Microsoft Fix it 20125
Bild minimierenBild vergrößern

Bild minimierenBild vergrößern

Windows 7, Windows Vista, Windows XP, Windows Server 2008 oder Windows Server 2008 R2
Bild minimierenBild vergrößern

Bild minimierenBild vergrößern
Problem beheben (http://go.microsoft.com/?linkid=9746381)
Microsoft Fix it 50531
Bild minimierenBild vergrößern

Bild minimierenBild vergrößern

Hinweise
Bild minimierenBild vergrößern
  • Dieser Assistent ist möglicherweise nur in Englisch verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.
  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem USB-Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.
  • Ihr Feedback ist uns wichtig. Um uns Ihr Feedback zu übermitteln oder uns über Probleme mit dieser Lösung zu informieren, schreiben Sie einen Kommentar im "Fix it for me (http://blogs.technet.com/fixit4me/) "-Blog, oder senden Sie uns eine E-Mail (mailto:fixit4me@microsoft.com?Subject=KB) -Nachricht.
Bild minimierenBild vergrößern

Bild minimierenBild vergrößern



Problem manuell beheben

Bild minimierenBild vergrößern
Gehen Sie wie folgt vor, um das Problem zu beheben:
  1. Öffnen Sie eine Eingabeaufforderung. Klicken Sie dazu auf Start
    Bild minimierenBild vergrößern
    Schaltfläche 'Start'
    , klicken Sie auf Alle Programme, klicken Sie auf Zubehör, und klicken Sie anschließend auf Eingabeaufforderung.
  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie anschließend die EINGABETASTE:
    certutil -urlcache * delete
    Hinweis Der Befehl certutil muss für jeden Benutzer der Arbeitsstation ausgeführt werden. Jeder Benutzer muss sich anmelden, und die oben stehenden Schritte 1 und 2 ausführen.
  3. Wenn das abgelaufene Zertifikat in einem der lokalen Systemprofile zwischengespeichert ist, müssen Sie die Inhalte einiger Verzeichnisse unter Verwendung des Windows-Explorers löschen. Gehen Sie hierzu folgendermaßen vor:
    1. Starten Sie den Windows-Explorer. Klicken Sie auf Start, auf Alle Programme und auf Zubehör, und klicken Sie dann auf Windows-Explorer.

      Hinweis Die Anzeige von versteckten Ordnern muss aktiviert sein, damit die Verzeichnisse angezeigt werden, deren Inhalte Sie löschen müssen. Gehen Sie folgendermaßen vor, um die Anzeige von versteckten Dateien und Ordner zu aktivieren:
      1. Klicken Sie auf Organisieren und danach auf Ordner- und Suchoptionen.
      2. Klicken Sie auf die Registerkarte Ansicht.
      3. Aktivieren Sie das Kontrollkästchen Versteckte Dateien und Ordner anzeigen.
      4. Deaktivieren Sie das Kontrollkästchen Erweiterungen bei bekannten Dateitypen ausblenden.
      5. Deaktivieren Sie das Kontrollkästchen Geschützte Systemdateien ausblenden (empfohlen).
      6. Klicken Sie auf Ja, um die Warnung zu ignorieren, und klicken Sie dann auf OK, um die Änderungen zu übernehmen und das Dialogfeld zu schließen.
    2. Löschen Sie die Inhalte der unten aufgelisteten Verzeichnisse. ("%windir%" ist das Windows-Verzeichnis.)

      Hinweis Möglicherweise wird eine Fehlermeldung angezeigt, die angibt, dass Sie nicht berechtigt sind, auf den Ordner zuzugreifen. Wenn diese Meldung angezeigt wird, klicken Sie auf Weiter.

      LocalService:

      %windir%\ServiceProfiles\LocalService\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content
      %windir%\ServiceProfiles\LocalService\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

      NetworkService:
      %windir%\ServiceProfiles\NetworkService\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content
      %windir%\ServiceProfiles\NetworkService\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

      LocalSystem:
      %windir%\System32\config\systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content
      %windir%\System32\config\systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData
Bild minimierenBild vergrößern

Weitere Informationen

Zudem kann anstelle des Fehlers "Ein erforderliches Zertifikat befindet sich nicht im Gültigkeitszeitraum gemessen an der aktuellen Systemzeit oder dem Zeitstempel in der signierten Datei" die Ereignis-ID 4107 mit dem Fehler "Die Daten sind ungültig" protokolliert werden.

Der Fehler "Die Daten sind ungültig" gibt an, dass das vom Netzwerk zurückgegebene Objekt keine gültige CAB-Datei war und Windows die Datei daher nicht ordnungsgemäß analysieren konnte. Instanzen eines solchen Fehlers können auftreten, wenn beim Netzwerkabruf der CAB-Datei ein Proxy nicht erfolgreich durchlaufen wird. Wenn der Proxy bestimmte Daten oder Meldungen anstelle eines Standard-HTTP-Fehlercodes zurückgibt, versucht Windows, die vom Proxy empfangene Meldung zu analysieren, in der Annahme, dass es sich um die CAB-Datei handelt. Dieser Versuch endet mit dem Fehler "Die Daten sind ungültig".

Um dieses Problem in den Griff zu bekommen, müssen Sie den ungültigen Eintrag im Zwischenspeicher entfernen, indem Sie den Zwischenspeicher mit den im Abschnitt "Lösung" beschriebenen Schritten leeren.


Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen (http://go.microsoft.com/fwlink/?LinkId=151500) .

Die Informationen in diesem Artikel beziehen sich auf:
Keywords: 
kbfixme kbmsifixme KB2328240
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store