DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 2468316 - Geändert am: Donnerstag, 10. Februar 2011 - Version: 1.0

Hotfix-Download ist verfügbar
Hotfix-Downloads anzeigen und anfordern
 
 

Auf dieser Seite

Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie haben eine Lightweight Directory Access Protocol (LDAP)-Server oder Domänencontroller, auf denen Windows Server 2008 R2 ausgeführt wird.
  • Sie führen eine seitenweise LDAP-Abfrage für den Domänencontroller.
  • Verwenden Sie diecreateTimeStampodermodifyTimeStampDas Attribut in den Abfragefilter.
  • Das Ergebnis der Abfrage umfasst mehrere Seiten.
In diesem Szenario die seitenweise LDAP-Abfrage, die auf der zweiten Seite und die Seiten, die auf die zweite Seite schlägt fehl.

Der folgende Code ist ein Beispielszenario:
  • Durch das Bereitstellen von eines Domänencontrollers, auf der Windows Server 2008 R2 ausgeführt wird.
  • Bereitstellen von Microsoft Exchange Server 2007-Server auf einem Computer, und dann Microsoft Office Outlook Web Access aktivieren.
  • Konfigurieren Sie genügend Benutzerinformationen, um mehr als eine Seite mit Ergebnissen aus einer Durchsuchen der globalen Adressliste (GAL) zu aktivieren.
  • Sie geben Sie einen Suchbegriff, der mehr als eine Seite mit Ergebnissen zurückgibt.
  • Sie versuchen, einen Bildlauf durch mehrseitige GAL-Suchergebnisse zurück.
In diesem Szenario nicht zum Scrollen durch die Ergebnisse zurück, und erhalten Sie die folgenden Fehlermeldung:

Verzeichnisdienst-Server konnte keine Verbindung hergestellt werden. Wenn das Problem weiterhin besteht, wenden Sie sich an technischen Support für Ihre Organisation.

Ursache

Das Problem tritt auf, da einige Suchfilter im LDAP paged Abfragen falsch geändert werden.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix ist jedoch vorgesehen, um nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zu einem Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält wird.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

HinweisWenn weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://Support.Microsoft.com/contactus/?WS=Support (http://support.microsoft.com/contactus/?ws=support)
HinweisDas Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen:

Um diesen Hotfix anwenden zu können, müssen Sie das folgende Betriebssystem ausgeführt werden:

  • WindowsServer 2008 R2
  • Windows Server 2008 R2 Servicepack 1 (SP1)

Registrierungsinformationen

Um den Hotfix zu verwenden, müssen Sie keinen um die Registrierung zu ändern.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Die Datumsangaben und Uhrzeiten, zu dieser Dateien auf dem lokalen Computer werden in Ihrer Ortszeit zusammen mit Ihren aktuellen Zeitunterschied für die Sommerzeit (DST) angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
WichtigWindows 7-Updates und Windows Server 2008 R2-Updates sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Das Hotfix-Paket, das auf mindestens einer der beiden Betriebssysteme angewendet wird, aktivieren Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 r2" aufgeführt ist. Immer finden Sie im Abschnitt "Gilt für" im Artikel, um das aktuelle Betriebssystem zu bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien, die für ein bestimmtes Produkt SR_Level (RTM, SPn), und Servicebereiche (LDR, GDR) identifiziert werden kann, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereich
    6.1.7600.20xxxWindowsServer 2008 R2RTMLDR
    6.1.7601.21xxxWindowsServer 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind.separat aufgeführtim Abschnitt "Weitere Dateiinformationen für WindowsServer 2008 R2". MUM- und MANIFEST-Dateien sowie die zugeordneten (.cat) Sicherheitskatalogdateien, sind äußerst wichtig, den Status der aktualisierten Komponenten verwalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
NTDSA.MOFNicht zutreffend227,76510-Jun-200920: 34Nicht zutreffend
Ntdsai.dll6.1.7600.208612,723,32818-Dec-201006: 09X 64
NTDSA.MOFNicht zutreffend227,76505-Nov-201001: 54Nicht zutreffend
Ntdsai.dll6.1.7601.216242,723,32818-Dec-201008: 51X 64

Abhilfe

WichtigIn diesem Abschnitt, eine Methode oder eine Aufgabe enthält Hinweise zum Ändern der Registrierung. Jedoch können schwerwiegende Probleme auftreten, wenn falsche der Registrierung Bearbeitung. Stellen Sie daher sicher, dass Sie die folgenden Schritte sorgfältig ausführen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie es ändern. Anschließend können Sie die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
322756  (http://support.microsoft.com/kb/322756/ ) Zum Sichern und Wiederherstellen der Registrierung in Windows

Um das Problem zu umgehen, müssen Sie einen Registrierungsunterschlüssel auf dem LDAP-Server erstellen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie aufStart
    Bild minimierenBild vergrößern
    Schaltfläche "Start"
    , TypRegeditin derProgramme / Dateien durchsuchenein, und drücken Sie dann die EINGABETASTE.
    Bild minimierenBild vergrößern
    UAC
    Wenn Sie aufgefordert ein Administratorkennwort einzugeben werden, geben Sie das Kennwort ein. Wenn Sie zur Bestätigung aufgefordert werden, geben Sie zur Bestätigung.
  2. Suchen Sie, und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
  3. Auf derBearbeitenMenü, zeigen Sie aufNeue, und klicken Sie dann aufString-Wert.
  4. TypDSA-Heuristik, und drücken Sie dann die EINGABETASTE.
  5. Mit der rechten MaustasteDSA-Heuristik, und klicken Sie dann aufÄndern.
  6. In derWertdatenGeben Sie im Feld000000000001, und klicken Sie dann aufOK.
  7. Beenden Sie den Registrierungs-Editor.

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684  (http://support.microsoft.com/kb/824684/ ) Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_149ee8c9e20c2afd3347ba6c7b8f3a51_31bf3856ad364e35_6.1.7601.21624_none_e08641138148d4a0.Manifest
DateiversionNicht zutreffend
Dateigröße716
Datum ab (UTC)21-Dec-2010
Zeit (UTC)00: 14
PlattformNicht zutreffend
DateinameAmd64_ffed5210101de2b65fbc8adf4e82aac4_31bf3856ad364e35_6.1.7600.20861_none_bb751eb51b570fad.Manifest
DateiversionNicht zutreffend
Dateigröße716
Datum ab (UTC)21-Dec-2010
Zeit (UTC)00: 14
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-d...Toryservices-ntdsai_31bf3856ad364e35_6.1.7600.20861_none_4d5676a6ebe4c26e.manifest
DateiversionNicht zutreffend
Dateigröße3,531
Datum ab (UTC)18-Dec-2010
Zeit (UTC)06: 54
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-d...Toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21624_none_4f6b143ae8e80a9b.manifest
DateiversionNicht zutreffend
Dateigröße3,531
Datum ab (UTC)18-Dec-2010
Zeit (UTC)09: 27
PlattformNicht zutreffend

Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbmt KB2468316 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2468316  (http://support.microsoft.com/kb/2468316/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store