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Artikel-ID: 2470478 - Geändert am: Dienstag, 15. März 2011 - Version: 2.0

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Einführung

Speicher-Devices haben 512-Byte-Sektoren traditionell abhängig. Gerät Speicheranbieter haben vor kurzem die Umstellung auf Speicher-Devices mit einer Sektorgröße von 4.096 Byte (4 KB) begonnen. Diese werden als "Erweiterte Format Disk" oder "512e"-Geräte bezeichnet. Obwohl die Unterstützung für diese Speichergeräte, die verschiedenen Software- und Hardware-Komponenten eines Systems verbessert hat, kann Support inkonsistent bleiben. Die am häufigsten verwendete Inkonsistenz ist die Unterstützung für die korrekte Meldung des physischen Sektorgröße für diese Speichergeräte inkonsistent ist. Aus diesem Grund müssen Anwendungen verarbeiten Szenarien, in denen die gemeldete physischen Sektorgröße des Speichergeräts, auf der Sie ausgeführt werden, ändern kann.

Problembeschreibung

Es folgen einige Beispiele für Szenarien, in denen die physischen Sektorgröße auf Windows gemeldet potenziell ändern können:
  • Sie verschieben das Speichergerät an einen RAID-Controller von einem Direct-attached-Controller und umgekehrt. Gemeldete physischen Sektorgröße möglicherweise nicht ändern, da die RAID-Controller können nicht die physischen Sektorgröße des Speichergeräts meldet. Daher kann das System 4 KB pro Sitzung aber 512 Bytes in einer anderen Sitzung und umgekehrt sehen.
  • Sie aktualisieren Ihre primäre Speichergerät, das eine physischen Sektorgröße auf 512-Byte-Ebene mit einem Speichergerät verfügt, die einen physischen Sektorgröße von 4 KB oder umgekehrt wurde. Und Sie führen ein Block-Level-Sicherung und Wiederherstellung, z. B. mit Windows-Sicherung. Betrachten Sie das folgende Szenario:
    • Sie führen eine Blockebenen-Sicherung Ihres Systems, die auf einem Speichergerät ausgeführt wird, das eine physischen Sektorgröße von 512 Byte berichtet.
    • Ersetzen Sie diesem Speichergerät mit einem Speichergerät, das eine physischen Sektorgröße von 4 KB berichtet.
    • Führen Sie eine Wiederherstellung auf Blockebene Ihres Systems mit neuen Speicher-Device.
    In diesem Szenario wird die gemeldete physischen Sektorgröße geändert von 512 Byte auf 4 KB beim Systemstart.

    Hinweis
    In diesem Szenario kann auch storniert werden, in dem Sie ein Speichergerät ersetzen, die eine 4-KB-physischen Sektorgröße auf einem Speichergerät verwendet, die eine physischen Sektorgröße von 512 Byte verwendet.
  • Sie aktualisieren den Storage-Controller im System, in dem der aktuelle Storage-Controller bietet Unterstützung für die physischen Sektor der Nachrichtengröße und der neuen Speicher-Controller hat keine Unterstützung für physischen Sektor der Nachrichtengröße oder umgekehrt. Wenn sich der Storage-Controller ändert, müssen den entsprechenden Treiber zur Unterstützung des Storage-Controllers Windows geladen werden. Dieses Problem tritt am häufigsten auf, wenn beim Aktualisieren von Microsoft Posteingang ATA-Treiber (MSAHCI) auf einen Storport-basierte Fremdanbietertreiber oder umgekehrt.
  • Sie können den Modus der Storage-Controller im BIOS des Systems ändern. Dieses Problem kann auftreten, in allen Kombinationen aus Modi wie AHCI, Legacy, IDE, kompatibel, RAID und So weiter. Jeder Modus erfordert einen anderen Treiber von Windows geladen werden soll. In diesem Fall einige Treiber möglicherweise Unterstützung und andere Treiber möglicherweise keine Unterstützung.
Im folgenden sind Beispiele für Anwendungen, die auf ESENT (Extensible Storage Engine-API) erstellt werden:
  • Windows Update
  • Active Directory
  • Windows-Desktopsuche
  • Zertifizierungsstelle (CA)
  • Windows Internet Name Service (WINS)
  • Dynamic Host Configuration Protocol (DHCP)
  • Windows Live Mail

Als ein Beispiel dafür, wie dieses Problem selbst für Windows Update manifest kann erhalten Sie möglicherweise die folgenden Fehlermeldung:
Schwerwiegender Fehler: Fehler beim Initialisieren des Datastore, Fehler = 0xC8000222.

Außerdem wird im Ereignisprotokoll Anwendung ein Ereignis etwa folgender Art protokolliert:


Protokollname: Anwendung
Quelle: ESENT
Datum:<date &="" time=""></date>
Ereignis-ID: 412
Aufgabenkategorie: Protokollierung/Wiederherstellung
Ebene: Fehler
Schlüsselwörter: Klassisch
Benutzer: n/A
Computer:<computer name=""> </computer>
Beschreibung:
Wuaueng.dll (936) SUS20ClientDataStore: die Kopfzeile der Protokolldatei C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log konnte nicht gelesen. Fehler beim-546.

Hinweis:Dieses Problem tritt nur in Windows Vista und Windows Server 2008. Informationen zu diesem Problem unter Windows 7 und Windows Server 2008 R2 finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
982018  (http://support.microsoft.com/kb/982018/ ) Ein Update, das verbessert die Kompatibilität von Windows 7 und Windows Server 2008 R2 und erweiterte Formatieren von Datenträgern ist verfügbar

Ursache

Dieses Problem tritt auf, weil die physischen Sektorgröße von Speicher-Device-Änderungen gemeldet wird. Obwohl ESENT mit Unterstützung für 512-Byte- und 4-KB-physischen Sektorgrößen enthält während der Erstellung der Ausgangsdatenbank konzipiert ist, erwartet ESENT, dass die gemeldete physischen Sektorgröße sitzungsübergreifend konsistent bleibt. Bei die ESENT-Datenbank Agentensoftware, stellt er sicher, dass die physischen Sektorgröße, dass die Datenbank erstellt wurde und der aktuellen physischen Sektorgröße gemeldet sind identisch. Wenn die Sektorengröße unterschiedlich sind, meldet ESENT einen Fehler.

Abhilfe

Um dieses Problem zu umgehen, können Sie versuchen, das System zu einem Punkt vor einem der im Beispiel Szenarien beim Wiederherstellen. Beispielsweise können Sie versuchen, die vorherigen Treiber wiederherstellen.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Dieser Hotfix ist jedoch vorgesehen, um nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zusätzliche Tests angezeigt. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass Sie auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

HinweisFalls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://Support.Microsoft.com/contactus/?WS=Support (http://support.microsoft.com/contactus/?ws=support)
HinweisDas Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist es da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen

Um diesen Hotfix installieren zu können, muss eine der folgenden Betriebssysteme ausgeführt werden:
  • Windows Vista Servicepack 1 (SP1)
  • Windows Vista Servicepack 2 (SP2)
  • WindowsServer 2008
  • Windows Server 2008 Servicepack 2 (SP2)
Weitere Informationen dazu, wie Sie ein Windows Vista Servicepack zu erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
935791  (http://support.microsoft.com/kb/935791/ ) So erhalten Sie das neueste Servicepack für Windows Vista
Weitere Informationen dazu, wie Sie einen Windows Server 2008 Servicepack erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
968849  (http://support.microsoft.com/kb/968849/ ) So erhalten Sie das neueste Servicepack für Windows Server 2008

Registrierungsinformationen

Um den Hotfix in diesem Paket verwenden, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die englische (USA) Version dieses Hotfix installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datumsangaben und Uhrzeiten für diese Dateien auf Ihrem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Ihren aktuellen Daylight Saving Time (DST)-Bias angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Vista und Windows Server 2008
WichtigHotfixes für Windows Vista und Windows Server 2008-Hotfixes sind im selben Paket enthalten. Allerdings wird nur "Windows Vista" auf der Hotfix-Anforderungsseite aufgeführt. Um das Hotfix-Paket anzufordern, das auf einem oder beiden Betriebssystemen angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows Vista" aufgeführt ist. Bezieht sich immer auf den Abschnitt "Gilt für" in Artikel, um das eigentliche Betriebssystem zu bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien, die für ein bestimmtes Produkt SR_Level (RTM, SP geltenn), und Servicebereiche (LDR, GDR) kann identifiziert werden, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereiche
    6.0.6001.22xxxWindows Vista und WindowsServer 2008SP1LDR
    6.0.6002.22xxxWindows Vista und WindowsServer 2008SP2LDR
  • Service Pack 1 ist in die endgültige Produktversion von Windows Server 2008 integriert.
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sindseparat aufgeführtim Abschnitt "Weitere Dateiinformationen für WindowsServer 2008 und Windows Vista". MUM- und MANIFEST-Dateien sowie die zugeordneten (.cat) Sicherheitskatalogdateien, sind äußerst wichtig, den Status der aktualisierten Komponenten verwalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 86-basierten Versionen von Windows Server 2008 und Windows Vista
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DateinameDateiversionDateigrößeDatumZeitPlattform
"ESENT.dll"6.0.6001.228031,453,56823 Nov-201015: 31X 86
"ESENT.dll"6.0.6002.225311,460,73623 Nov-201018: 47X 86
Für alle unterstützten x 64-basierten Versionen von Windows Server 2008 und Windows Vista
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
"ESENT.dll"6.0.6001.228032,523,64823 Nov-201019: 56X 64
"ESENT.dll"6.0.6002.225312,507,26423 Nov-201016: 59X 64
"ESENT.dll"6.0.6001.228031,453,56823 Nov-201015: 31X 86
"ESENT.dll"6.0.6002.225311,460,73623 Nov-201018: 47X 86
Für alle IA-64-basierten Versionen von Windows Server 2008 unterstützten
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
"ESENT.dll"6.0.6001.228033,593,72823 Nov-201016: 23IA-64
"ESENT.dll"6.0.6002.225313,593,72823 Nov-201017: 09IA-64
"ESENT.dll"6.0.6001.228031,453,56823 Nov-201015: 31X 86
"ESENT.dll"6.0.6002.225311,460,73623 Nov-201018: 47X 86

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684  (http://support.microsoft.com/kb/824684/ ) Beschreibung der Standardterminologie, die zum Beschreiben von Softwareupdates von Microsoft verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Vista und Windows Server 2008

Weitere Dateien für alle unterstützten x 86-basierten Versionen von Windows Vista und Windows Server 2008
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DateinameUpdate.mum
DateiversionNicht zutreffend
Dateigröße3,577
Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameX86_a00b55ec0fad73fcee5a44b989698634_31bf3856ad364e35_6.0.6001.22803_none_ff1fc79a072100ae.Manifest
DateiversionNicht zutreffend
Dateigröße716
Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameX86_cbd46d9b1e778a42c2e4a807df0ee30a_31bf3856ad364e35_6.0.6002.22531_none_16e1236c1d52c817.Manifest
DateiversionNicht zutreffend
Dateigröße716
Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6001.22803_none_f270f1d4452696e9.manifest
DateiversionNicht zutreffend
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Datum (UTC)23 Nov-2010
Zeit (UTC)15: 48
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6002.22531_none_f434f36442670d32.manifest
DateiversionNicht zutreffend
Dateigröße8,529
Datum (UTC)23 Nov-2010
Zeit (UTC)19: 06
PlattformNicht zutreffend
Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Vista und Windows Server 2008
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DateinameAmd64_4496090fe2ed4b55faec3bb6a37ace41_31bf3856ad364e35_6.0.6002.22531_none_e69a003e2a9858f3.Manifest
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DateinameAmd64_6bb5b11ef44590247d548b6daebdc8a8_31bf3856ad364e35_6.0.6001.22803_none_bf9c7af067a0b8f9.Manifest
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Datum (UTC)24-Nov-2010
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DateinameAmd64_fa29ef6f84924efc8ae3a6a65054cfcf_31bf3856ad364e35_6.0.6001.22803_none_626f192d3104a520.Manifest
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Datum (UTC)24-Nov-2010
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Datum (UTC)23 Nov-2010
Zeit (UTC)17: 15
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Datum (UTC)24-Nov-2010
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Dateigröße8,529
Datum (UTC)23 Nov-2010
Zeit (UTC)19: 06
PlattformNicht zutreffend
Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008
Tabelle minimierenTabelle vergrößern
DateinameIa64_918a0c8a0b358b2e1bbda5b3a167d2db_31bf3856ad364e35_6.0.6001.22803_none_09f59e92687bfd90.Manifest
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Datum (UTC)24-Nov-2010
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PlattformNicht zutreffend
DateinameIa64_9dd2bb1af74b0e6e1ca038eb7c5d2152_31bf3856ad364e35_6.0.6002.22531_none_e4e41af7aff067f6.Manifest
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Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameIa64_cbf834760282e0881e4013008f011298_31bf3856ad364e35_6.0.6001.22803_none_829b14ab676064f8.Manifest
DateiversionNicht zutreffend
Dateigröße1,078
Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameIa64_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6001.22803_none_f27295ca45249fe5.manifest
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Time (UTC)16: 41
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DateinameIa64_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6002.22531_none_f436975a4265162e.manifest
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Dateigröße8,539
Datum (UTC)23 Nov-2010
Zeit (UTC)17: 26
PlattformNicht zutreffend
DateinameUpdate.mum
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Dateigröße2,758
Datum (UTC)24-Nov-2010
Zeit (UTC)08: 04
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6001.22803_none_f270f1d4452696e9.manifest
DateiversionNicht zutreffend
Dateigröße8,529
Datum (UTC)23 Nov-2010
Zeit (UTC)15: 48
PlattformNicht zutreffend
DateinameX86_microsoft-Windows-e...Estorageengine-isam_31bf3856ad364e35_6.0.6002.22531_none_f434f36442670d32.manifest
DateiversionNicht zutreffend
Dateigröße8,529
Datum (UTC)23 Nov-2010
Zeit (UTC)19: 06
PlattformNicht zutreffend

Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit edition
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2470478 KbMtde
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Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 2470478  (http://support.microsoft.com/kb/2470478/en-us/ )
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