DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 270139 - Geändert am: Montag, 31. März 2008 - Version: 3.2

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
270139  (http://support.microsoft.com/kb/270139/EN-US/ ) PRJ: Description of the MPX Project File Exchange Format
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Zusammenfassung

Das MPX 4.0-Format ist ein ASCII-Dateiformat, das Sie verwenden können, um Projektinformationen zwischen verschiedenen Versionen von Microsoft Project und Fremdanbieterprogrammen auszutauschen, die das MPX-Dateiformat unterstützen (wie zum Beispiel Primavera Project Planner und Timberline Precision Estimating).

Die Datei "Mpxfile.wri" (Windows) und die Datei "MPX File Format" (Macintosh) beschreiben das Format von MPX 4.0-Dateien, die in den Microsoft Project-Versionen 4.0, 4.1 und 98 erstellt wurden. Sie finden diese Dateien in dem Ordner, in dem Sie Microsoft Project 4.0 oder 4.1 installiert haben. Der Abschnitt "Weitere Informationen" dieses Artikels enthält den kompletten Wortlaut der Datei "Mpxfile.wri". (HINWEIS: Die Datei "Mpxfile.wri" ist in Microsoft Project 98 und Microsoft Project 2000 nicht enthalten.)

In der folgenden Tabelle sind die Versionen von Microsoft Project aufgelistet, mit denen Dateien im MPX 4.0-Format erstellt oder gelesen werden können:
                                     Erstellen  Lesen
                                     ----------------
      Microsoft Project 4.0          Ja         Ja
      Microsoft Project 4.1          Ja         Ja
      Microsoft Project 98           Ja         Ja
      Microsoft Project 2000         Nein       Ja
				
Der "Microsoft Project Converter" ist ein Programm auf Windows-Basis, mit dem Sie Dateien, die in Projektmanagementprogrammen von Fremdanbietern erstellt wurden, in das MPX 4.0-Format konvertieren können. Weitere Informationen finden Sie in folgenden Artikeln der Microsoft Knowledge Base:
130206  (http://support.microsoft.com/kb/130206/DE/ ) PRJ: der Microsoft Project-Konverter für Projekt 4.0 und 4.1
221256  (http://support.microsoft.com/kb/221256/DE/ ) PRJ: aktualisierte Projektkonverter für ABT Projekt Workbench 4.x
Informationen zur Problembehandlung bei Fehlermeldungen, die beim Öffnen einer MPX-Datei mit ungültigen Daten angezeigt werden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
141261  (http://support.microsoft.com/kb/141261/DE/ ) PRJ: wie Interpretieren von Nachricht, die empfangen wird, wenn Sie .mpx-Datei öffnen

Weitere Informationen

Es folgt der vollständige Wortlaut der Datei "Mpxfile.wri".

Verwendung des MPX-Dateiformats

Das MPX-Dateiformat

Das MPX-Dateiformat ist ein ASCII-Dateiformat, das Sie verwenden können, um Projektinformationen zwischen Microsoft Project und anderen Anwendungen zu übertragen, sofern sie das MPX-Dateiformat unterstützen, zum Beispiel Primavera Project Planner und Timberline Precision Estimating. Das MPX-Dateiformat ermöglicht Ihnen Projektinformationen zu übertragen, die nicht in einer Tabelle erscheinen können, zum Beispiel detaillierte Ressourcenzuordnungsinformationen, Kalenderinformationen oder Informationen im Dialogfeld "Projekt-Info".

Bevor Sie eine Microsoft Project-Datei im MPX-Dateiformat abspeichern, vergewissern Sie sich, dass die Anwendung, in die Sie die Projektinformation übertragen wollen, das MPX-Format interpretieren kann. In einigen Fällen müssen Sie vor der Verwendung Ihrer Datei in der anderen Anwendung ein Konvertierungsprogramm ausführen.

Microsoft Project kann ebenfalls Dateien öffnen, die im MPX-Dateiformat gespeichert sind. Microsoft Project Version 4.1 für Windows 95 kann MPX-Dateien der Versionen 1.0, 3.0, 4.0 und 4.1 öffnen und speichern.

Sie öffnen eine MPX-Datei genau wie jede andere Microsoft Project-Datei Wenn Sie eine MPX-Datei öffnen, können Sie die Datei mit dem aktiven Projekt verknüpfen und die Informationen in ein neues Projekt übertragen. Wenn Sie das Verknüpfen der Dateien wählen und einmalige Kennnummern verwenden, ersetzen die Informationen in der neuen Datei die Informationen in den übereinstimmenden Datensätzen. Sie können MPX-Dateien erstellen, die nur die Informationen enthalten, die Sie mit dem vorhandenen Projekt verknüpfen wollen, einschließlich der Ressourcenzuordnungen. Sie können beispielsweise eine MPX-Datei erstellen, die nur Kosteninformationen enthält, die sich geändert haben. Durch die Aufnahme der einmaligen Kennung und der neuen Kosten für den Ressourcensatz, werden nur diese Informationen in dem neuen Projekt ersetzt.

Um eine Datei im MPX-Format zu speichern, lesen Sie die Online-Hilfe unter "Exportieren einer Projektdatei im MPX-Dateiformat". Wenn Sie eine MPX-Datei exportieren, müssen Sie keine Tabelle angeben, weil die Vorgangs- und Ressourcentabellen mit der Bezeichnung "Export" automatisch verwendet werden. Wenn Sie die Exporttabellen aus der Datei GLOBAL.MPT löschen, können Sie keine MPX-Datei exportieren, außer wenn Sie die Exporttabellen vorher aus der Sicherungskopie der Globaldatei in die Datei GLOBAL.MPT oder in Ihre aktuelle Projektdatei kopieren.

Sie können die Exporttabellen ändern, indem Sie aus dem Menü Ansicht den Befehl Tabelle und dann den Befehl Weitere Tabellen wählen, die Tabelle "Export" auswählen und dann auf die Schaltfläche "Bearbeiten" klicken. Jedoch sollten Sie dies nur tun, wenn Sie von der Anwendung, in die Sie die exportierten Informationen übertragen, die Anweisung dazu erhalten. Die mit Microsoft Project angebotenen Exporttabellen sind standardmäßige Tabellen, die von den meisten Anwendungen verwendet werden, die das MPX-Dateiformat unterstützen.

Wenn die ankommenden Vorgänge oder Ressourcen an der ersten oder zweiten Position die einmaligen Kennnummern enthalten und Sie zwei Dateien verbinden, verbindet Microsoft Project die Informationen mit dem übereinstimmenden Datensatz. Wenn keine Übereinstimmung gefunden wird, wird am Ende der Vorgänge oder Ressourcen ein neuer Datensatz erstellt. Wenn Sie die Datei, die Sie öffnen, nicht verbinden und die ankommenden Vorgänge oder Ressourcen im ersten Feld eine Kennnummer enthalten, fügt Microsoft Project jeden Vorgang oder jede Ressource in die Zeile mit der entsprechenden Kennnummer ein, so dass die Kennnummer jedes Vorgangs oder jeder Ressource in Microsoft Project der ursprünglichen Kennnummer entsprechen. Wenn die ankommende Datei eine Kennnummer überspringt, bleibt die Vorgangs- oder Ressourcenzeile mit der Kennummer leer, so dass Sie Leerzeilen zwischen Vorgängen oder Ressourcen importieren können.

Folgende Unterschiede bestehen zwischen den MPX-Dateien in Microsoft Project, Version 3.0, und den MPX-Dateien in Microsoft Project, Version 4.0 und 4.1:

• Wenn Sie eine MPX-Datei in Microsoft Project öffnen, werden Sie nicht mehr per Vorgabe dazu aufgefordert, die Datei mit dem bestehenden Projekt zusammenzuführen. Wenn Sie die Informationen der MPX-Datei mit der bestehenden Datei zusammenführen möchten, müssen Sie das entsprechende Kontrollkästchen im Dialogfeld Importieren aktivieren bzw. den entsprechenden Parameter des Befehls DateiÖffnen angeben. Weitere Informationen hierüber finden Sie in der Online-Hilfe unter "Zusammenführen: MPX-Dateiformat".

• Es wurde ein neuer Datensatz für die Workgroup-Funktionen aufgenommen.

• Es wurde ein neuer Datensatz aufgenommen, um Informationen zu periodischen Vorgängen zu speichern.

• Die Einstellung für die Anordnung des Symbols im Datensatz Währungseinstellungen unterstützt jetzt ein Leerzeichen zwischen dem Währungssymbol und der Zahl.

Anmerkung: Es besteht kein Unterschied zwischen dem MPX-Dateiformat in Microsoft Project, Version 4.1, und dem MPX-Dateiformat in Microsoft Project, Version 4.0.

Spezifizierungen des MPX-Dateiformats

Dieser Abschnitt ist für Entwickler gedacht, die Dienstprogramme für die Übertragung von Informationen zwischen einer anderen Anwendung und Microsoft Project erstellen. Wenn Sie MPX-Dateien zwischen Microsoft Project und einer anderen Anwendung übertragen, die bereits das MPX-Dateiformat unterstützt, müssen Sie diesen Abschnitt nicht lesen.

Ein MPX-Dateiformat besteht aus Datensätzen, die durch Wagenrückläufe und Zeilenvorschübe getrennt sind. Innerhalb jedes Datensatzes gibt es Felder, die Informationen für das Projekt enthalten. Die Datensatztypen und die Reihenfolge dieser Datensätze sind festgesetzt. Die folgende Tabelle enthält alle Datensatztypen, die zur Identifizierung jedes Datensatztyps verwendete Nummer und die Anzahl der Datensätze für jeden Typ, die in der MPX-Datei enthalten sein können. Die MPX-Datei muss nicht alle Datensatztypen enthalten. Der einzige, unbedingt erforderliche Datensatz ist der Datensatz "Dateierstellung" (File Creation). Alle in der MPX-Datei enthaltenen Datensätze müssen in derselben Reihenfolge, wie in der Tabelle dargestellt, vorhanden sein, nur die Kommentardatensätze können an beliebigen Positionen in der Datei eingefügt werden.
   Datensatzname                Datensatznummer    Max. Anzahl der Datensätze
   -------------                ---------------    --------------------------
   Dateierstellung (erforderl.) Keine              1
   Währungseinstellungen        10                 1
   Standardeinstellungen        11                 1
   Datums- und Uhrzeiteinstell. 12                 1
   Basiskalenderdefinition      20                 250
   Basiskalenderstunden         25                 7 pro Datensatz der
                                                   Basiskalenderdefinition
   Basiskalenderausnahmen       26                 250 pro Datensatz
                                                   Basiskalenderdefinition
   Projektkennsatz              30                 1
   Textdefinition:
   Ressourcentabelle            40                 1
   (Sie können auch den Datensatz "Numerische Definition: Ressourcentabelle" verwenden.)
   Numerische Definition:
   Ressourcentabelle            41                 1
   Ressource                    50                 9.999
   Ressourcennotizen            51                 1 pro Ressourcendatensatz
   Ressourcenkalenderdefinition 55                 1 pro Ressourcendatensatz
   Ressourcenkalenderstunden    56                 7 pro Datensatz der Res-
                                                   sourcenkalenderdefinition
   Ressourcenkalenderausnahme   57                 250 pro Datensatz der Res-
                                                   sourcenkalenderdefinition
   Textdefinition:
   Vorgangstabelle              60                 1
   (Sie können auch den Datensatz "Numerische Definition: Vorgangstabelle" verwenden.)
   Numerische Definition:
   Vorgangstabelle              61                 1
   Vorgang                      70                 9.999
   Vorgangsnotizen              71                 1 pro Vorgangsdatensatz
   Periodischer Vorgang         72                 1 pro Vorgangsdatensatz
   Ressourcenzuordnung          75                 100 pro Vorgangsdatensatz
   Workgroup-Zuordnung          76                 1 pro Zuordnungsdatensatz
   Projektnamen                 80                 500
   DDE-Verknüpfungen            81                 500
   Kommentare                    0                 unbegrenzt
				
Anmerkung
Einige Datensätze innerhalb der Datei müssen nach anderen Datensätzen folgen. Die Datensätze in der vorausgehenden Tabelle, die mit der Angabe "pro" eine Maximalanzahl für den vorausgehenden Datensatz angeben, müssen unmittelbar nach diesem Datensatz aufgeführt werden. Beispielsweise können bis zu 100 Ressourcenzuordnungen pro Vorgangsdatensatz aufgeführt werden. Wenn ein Vorgang 10 Ressourcenzuordnungen hat, müssen diese 10 Ressourcenzuordnungsdatensätze unmittelbar nach dem Vorgangsdatensatz und vor dem nächsten Vorgangsdatensatz stehen.

Eine MPX-Datei beginnt immer mit dem Datensatz "Dateierstellung". Dieser Datensatz identifiziert das Dateiformat (MPX), das Auflistungs-Trennzeichen, das zum Trennen der Felder innerhalb der Datensätze verwendet wird, die Anwendung und die zur Erstellung der MPX-Datei verwendete Versionsnummer, die Version des MPX-Formats, das die Datei benutzt und die zum Erstellen der Datei verwendete Code-Seite. Jeder Datensatz außer dem Datensatz "Dateierstellung" beginnt mit der Datensatznummer. Nach der Datensatznummer folgen das Auflistungstrennzeichen und die Informationen für die einzelnen Felder; jedes Feld ist durch das Auflistungstrennzeichen getrennt.

Die allgemeinen Regeln für die Feldinhalte lauten:

• Berechnete Felder müssen nicht importiert werden; sie werden ignoriert.

• Wenn das Auflistungs-Trennzeichen, normalerweise ein Komma oder Semikolon, in ein Feld aufgenommen ist, zum Beispiel zum Trennen der Vorgänger, wird das Feld in Anführungszeichen eingefasst.

• Wenn ein Feld ein Anführungszeichen enthält, werden zwei Anführungszeichen verwendet.

• Das Auflistungs-Trennzeichen muss für Leerfelder am Ende eines Datensatzes nicht aufgenommen werden.

• Das Auflistungs-Trennzeichen muss für Leerfelder zwischen Feldern, die Informationen enthalten, eingesetzt werden.

• Wenn eine Microsoft Project-Datei im MPX-Format exportiert wird, werden Daten und Zeiten im standardmäßigen Datumsformat für die Export-Tabelle geschrieben. Microsoft Project kann Daten in jedem Format importieren, das in der Liste im Dialogfeld Optionen enthalten ist. Weitere Informationen über Datums- und Zeitformate finden Sie in der Online-Hilfe unter "Datum".

• Microsoft Project ignoriert leeren Platz (Leerzeichen und Tabulatoren) am Beginn und Ende von Feldern, wenn eine MPX-Datei importiert wird.

• Leere importierte Felder ersetzen vorhandene Informationen nicht, wenn MPX-Dateien zusammengeführt werden.

Die Reihenfolge und der exakte Inhalt der Felder jedes Datensatzes sind in den folgenden Datensatzdefinitionen beschrieben. Nach dem Datensatznamen folgt die Datensatznummer, die zur Identifizierung des Datensatztyps verwendet wird. Das Beispiel in jeder Datensatzdefinition verwendet ein Komma als Auflistungs-Trennzeichen.

Dateierstellung - keine Datensatznummer   Dies ist ein erforderlicher Datensatz, der das Dateiformat (MPX), das in der Datei verwendete Auflistungs-Trennzeichen, das zum Erstellen der Datei verwendete Programm und die Versionsnummer, die Versionsnummer des in der Datei verwendeten MPX-Dateiformats und die zum Erstellen der Datei verwendete Code-Seite identifiziert. Dieser Datensatz muss der erste Datensatz in der Datei sein. Wenn Sie von Microsoft Project exportieren, wird das in der Windows-Systemsteuerung unter "Ländereinstellungen" im Register "Zahlen" eingestellte Listentrennzeichen verwendet.

In diesem Datensatz sind folgende Felder enthalten:
• MPX, unmittelbar gefolgt durch das Auflistungs-Trennzeichen
• Programmname/Identifizierung
• Versionsnummer der Datei
• Code-Seite (850, 437, MAC, ANSI)

Beispiel: MPX, Microsoft Project, 3.0

Dieses Beispiel spezifiziert, dass in dieser aus Microsoft Project Version 3.0 exportierten MPX-Datei, ein Strichpunkt als Auflistungs-Trennzeichen verwendet wird.

Währungseinstellungen - 10   Dieser Datensatz spezifiziert die Einstellungen für die Währung im Dialogfeld Optionen. Wenn Sie Währungsangaben in Ihre Import-Datei aufnehmen, geben Sie hier die Währungseinstellungen an, so dass diese Werte korrekt importiert werden. Ist dieser Datensatz nicht enthalten, werden die aktuellen Einstellungen aus dem Dialogfeld Optionen verwendet. Weitere Informationen über die Währungseinstellungen finden Sie in der Online-Hilfe unter "Währung". Das Tausender- und das Dezimaltrennzeichen werden in der Windows-Systemsteuerung unter "Ländereinstellungen" im Register "Zahlen" eingestellt.

In diesem Datensatz sind folgende Felder enthalten:
• Währungssymbol
• Symbolposition (0 = nach, 1 = vor, 2 = nach mit Leerzeichen, 3 = vor mit Leerzeichen)
• Währungsziffern (0,1,2)
• Tausendertrennzeichen
• Dezimaltrennzeichen

Beispiel: 10; DM;0;2;.;,

Dieses Beispiel spezifiziert, dass vor den Währungswerten das Währungssymbol (DM) steht, dass zwei Stellen nach dem Dezimalpunkt folgen, dass ein Punkt als Tausendertrennzeichen und ein Komma als Dezimaltrennzeichen verwendet wird. Da das Listentrennzeichen im Feld "Tausendertrennzeichen" enthalten ist, ist das Feld von Anführungszeichen umgeben.

Standardeinstellungen - 11   Dieser Datensatz spezifiziert die Einstellungen für die Standardeinstellungen des Dialogfelds Optionen. Wenn die von Ihnen importierte Dauer keine Abkürzung der Dauer enthält, spezifizieren Sie hier die "Standardeinheit der Dauer", damit die Einheiten der Dauer korrekt sind. Wird dieser Datensatz nicht aufgenommen, so werden die Standardeinstellungen im Dialogfeld Optionen verwendet. Weitere Informationen über die Standardeinstellungen finden Sie in der Online-Hilfe unter "Standarddauer".

In diesem Datensatz sind folgende Felder enthalten:
• Standardeinheiten der Einheiten (0 = Minuten, 1 = Stunden, 2 = Tage, 3 = Wochen)
• Standardeinstellung der Dauer (0 = nicht fest, 1 = fest)
• Standard-Arbeitseinheiten (0 = Minuten, 1 = Stunden, 2 = Tage, 3 = Wochen)
• Standard-Tagesarbeitszeit
• Standard-Wochenarbeitszeit
• Standardsatz
• Standard-Überstundensatz
• Aktualisierung des Vorgangsstatus aktualisiert den Ressourcenstatus (0 = nein, 1 = ja)
• Automatisches Teilen von angefangenen Vorgängen (0 = nein, 1 = ja)

Beispiel: 11; 2; 0; 1; 8; 40; 10 DM/h; 15 DM/h; 1

Dieses Beispiel spezifiziert die folgenden Standardeinstellungen: Die Dauer ist in Tagen angegeben und nicht fest, Arbeitseinheiten sind Stunden, ein Arbeitstag hat 8 Arbeitsstunden und eine Arbeitswoche 40 Stunden. Die standardmäßige Bezahlung beträgt 10 DM pro Stunde, Überstunden werden mit 15 DM pro Stunde bezahlt, und die Option "Aktualisierung des Vorgangsstatus aktualisiert den Ressourcenstatus " ist auf "Ja" gesetzt.

MPX 1.0-Format: Weil für die Standard-Tagesarbeitszeit und die Standard-Wochenarbeitszeit in Microsoft Project-Version 1.0, nur ganzzahlige Werte erlaubt sind, wird ein nicht ganzzahliger Wert beim Erstellen einer Datei im MPX 1.0-Format zur nächsten ganzen Zahl gerundet. Optionen, die in der Microsoft Project-Version 1.0 nicht enthalten sind, werden beim Erstellen einer Datei im MPX 1.0-Format nicht geschrieben.

Datum- und Zeiteinstellungen - 12Dieser Datensatz spezifiziert die Einstellungen für "Datum" und "Zeit" des Dialogfelds Optionen und die Einstellung für das "Datumsformat für Balken" des Dialogfelds Layout. Wenn dieser Datensatz nicht aufgenommen wird, werden die aktuellen Einstellungen im Dialogfeld Optionen verwendet. Weitere Informationen über die Einstellungen des Datums und der Zeit finden Sie in der Online-Hilfe unter "Datum".

In diesem Datensatz sind folgende Felder enthalten:
• Datumsreihenfolge (0 = Monat/Tag/Jahr, 1 = Tag/Monat/Jahr, 2 = Jahr/Monat/Tag)
• Zeitformat (0 = 12 Stunden, 1 = 24 Stunden)
• Standard-Uhrzeit (Anzahl Minuten nach Mitternacht)
• Datumstrennzeichen
• Zeit-Trennzeichen
• 0:00 bis 11:59, Text
• 12:00 bis 23:59, Text
• Datumsformat (0 -14)*
• Balkentext-Datumsformat (0 -194)*

* Es stehen 20 verschiedene Datumsformate zur Verfügung. Um die verfügbaren Datumsformate zu sehen, wählen Sie aus dem Menü Extras den Befehl Optionen und dann das Register Ansicht. Wählen Sie aus dem Dropdown-Listenfeld "Datumsformat" ein Datumsformat aus. Weitere Informationen über die Einstellungen des Datums und der Zeit finden Sie in der Online-Hilfe unter "Datum".

Beispiel: 12; 1; 0; 480; .; :; am; pm

Dieses Beispiel spezifiziert, dass die Daten in der Reihenfolge Tag/Monat/Jahr vorliegen, dass Zeiten im 12-Stunden-Format angegeben sind, dass die Standardzeit 8 Uhr beträgt (oder 480 Minuten nach Mitternacht), dass Tag, Monat und Jahr durch einen Punkt und Stunden und Minuten durch einen Doppelpunkt getrennt werden. Vormittags- und Nachmittagsstunden werden durch "am" und "pm" gekennzeichnet.

Basiskalenderdefinition - 20   Dieser Datensatz definiert Basiskalender und deren Arbeitstage und arbeitsfreie Tage in der Woche. Wenn eine MPX-Datei zusammengeführt wird, werden Kalenderinformationen mit dem aktiven Projekt zusammengeführt, wobei vorhandene Kalender mit demselben Namen überschrieben werden. Wenn für einen Tag kein Eintrag vorliegt, werden die Standardeinstellungen verwendet. In der Standardeinstellung sind die Tage Montag bis Freitag Arbeitstage und Samstag und Sonntag arbeitsfreie Tage. In diesem Datensatz ist das Feld "Name" erforderlich. Bei jedem dieser Tage zeigt ein Eintrag von "0" an, dass der Tag ein arbeitsfreier Tag ist, ein Eintrag von "1" bezeichnet den Tag als einen Arbeitstag.

In diesem Datensatz sind folgende Felder enthalten:
• Name
• Sonntag
• Montag
• Dienstag
• Mittwoch
• Donnerstag
• Freitag
• Samstag

Beispiel: 20; Schriftsteller; 0; 1; 1; 1; 1; 1; 0

Dieses Beispiel gibt an, dass für den Basiskalender mit der Bezeichnung "Schriftsteller" die Tage von Montag bis Freitag Arbeitstage und Sonnabend und Sonntag arbeitsfreie Tage sind.

Basiskalenderstunden - 25   Dieser Datensatz spezifiziert die Arbeitsstunden für die Wochentage, wenn sie von den Standardeinstellungen abweichen. Die standardmäßigen Arbeitsstunden sind von 8:00 bis 12:00 und von 13:00 bis 17:00. Jeder Datensatz der Basiskalenderstunden bezieht sich auf den vorausgehenden Datensatz der Basiskalenderdefinition. Es können nach jedem Datensatz der Basiskalenderdefinition bis zu sieben dieser Datensätze folgen.

• Wochentag (1 - 7, wobei 1 = Sonntag und 7 = Samstag ist)
• Von-Zeit 1
• Bis-Zeit 1
- • Von-Zeit 2
• Bis-Zeit 2
• Von-Zeit 3
• Bis-Zeit 3

Beispiel: 25; 2; 7:00; 11:00; 12:00; 16:00

Dieses Beispiel spezifiziert, dass am Montag die Arbeitsstunden von 7:00 bis 11:00 und von 12:00 bis 16:00 festgelegt sind.

Basiskalenderausnahme - 26Dieser Datensatz definiert die Ausnahmen der in den beiden vorherigen Datensatztypen angegebenen Tage und Stunden. Nach dem Basiskalenderdefinitionsdatensatz können bis zu 250 dieser Datensätze folgen. Die Datensätze müssen in chronologischer Reihenfolge aufgeführt sein. Wenn es sich bei der Ausnahme um einen einzigen Tag handelt, können Sie das Feld "Bis Datum" leer lassen. Wenn keine Zeiten angegeben sind, werden die Standardzeiten von 8:00 bis 12:00 und von 13:00 bis 17:00 verwendet.

In diesem Datensatz sind folgende Felder enthalten:
• Von Datum
• Bis Datum
• Arbeitsfrei/Arbeitstag (0 = arbeitsfrei, 1 = Arbeitstag)
• Von-Zeit 1
• Bis-Zeit 1
• Von-Zeit 2
Bis-Zeit 2
• Von-Zeit 3
• Bis-Zeit 3

Beispiel 1: 26; 24.12.95; 25.12.95; 0
Beispiel 2: 26; 4.10.95;; 1; 8:00;12:30

Das Beispiel 1 macht den 24. und den 25. Dezember 1995 zu arbeitsfreien Tagen.
Das Beispiel 2 macht Sonntag, den 4. Oktober 1995 zu einem Arbeitstag mit einer Arbeitszeit von 8:00 bis 12:30.
Beispiel 2 erfordert einen zusätzlichen Strichpunkt als Platzhalter für das Feld "Bis-Datum".

MPX 1.0-Format: Weil in Microsoft Project Version 1.0 nur 50 Ausnahmen erlaubt sind, werden alle Ausnahmen nach der 50. Ausnahme beim Erstellen einer Datei im MPX-Format 1.0 ignoriert.

Projektkennsatz - 30   Dieser Datensatz legt globale Projektfelder fest, zum Beispiel den Projektanfangstermin und den Projektendtermin. Die Felder in diesem Datensatz entsprechen den Feldern der Dialogfelder Projekt-Info und Projekt-Statistik.

In diesem Datensatz sind folgende Felder enthalten:
• Register Projekt
• Firma
• Projektleitung
• Kalender (ohne Eintrag wird der Standardkalender verwendet)
• Anfangstermin (für eine importierte Datei wird entweder dieses Feld oder das nächste Feld berechnet, je nach Einstellung "Berechnung von")
• Endtermin
• Berechnung von (0 = Anfang, 1 = Ende)
• Aktuelles Datum*
• Kommentar
• Kosten*
• Geplante Kosten*
• Aktuelle Kosten*
• Arbeit*
• Geplante Arbeit*
• Aktuelle Arbeit*
• Arbeit*
• Dauer*
• Geplante Dauer*
• Aktuelle Dauer*
• % Abgeschlossen*
• Geplanter Anfang*
• Geplantes Ende*
• Aktueller Anfang*
• Aktuelles Ende*
• Anfangsabweichung*
• Endabweichung*
• Titel
• Autor
• Schlüsselwort

* Diese Felder werden durch Microsoft Project berechnet, so dass importierte Werte ignoriert werden.

Beispiel: 30; Uhrenausstellung; Nationales Museum; Michael Ewald; Standard; 2.1.1995

In diesem Beispiel wird das Projekt "Uhrenausstellung" des Nationalen Museums von Michael Ewald geleitet, es verwendet den Standardkalender und beginnt am 2. Januar 1995.

MPX 1.0 und 3.0-Format: Felder, die nicht in den Microsoft Project Versionen 1.0 oder 3.0 enthalten sind, werden beim Erstellen einer Datei im MPX 1.0 oder 3.0-Format nicht geschrieben.

Textdefinition: Ressourcentabelle - 40   Dieser Datensatz listet die Ressourcenfelder in der Reihenfolge auf, in der sie importiert oder exportiert wurden. Bei importierten Dateien müssen die Namen mit den in Microsoft Project verwendeten Feldnamen übereinstimmen. Bei exportierten Dateien kommt dieser Datensatz aus der Export-Tabelle der Ressource. Sie müssen entweder diesen Datensatz oder den als nächstes beschriebenen Datensatz "Numerische Definition: Ressourcentabelle" verwenden. Wenn Sie aus Microsoft Project exportieren, werden diese beiden Datensätze aufgenommen. Eine vollständige Beschreibung der zur Verfügung stehenden Felder finden Sie in der Online-Hilfe unter "Exporttabelle" und "Zusammenfassung der Tabelle 'Export' (Ressource)" oder "Zusammenfassung der Tabelle 'Export' (Vorgang)".

Listen Sie für diesen Datensatz die gewünschten Ressourcenfelder auf, trennen Sie die Felder dabei mit dem Auflistungs-Trennzeichen.

Beispiel: 40; Name; Max. Einheiten; Standardsatz

Dieses Beispiel spezifiziert, dass jeder Ressourcendatensatz in der Datei den Ressourcennamen, die maximalen Einheiten und den Standardpreis enthält.

Hinweis
Wenn Sie bei importierten Dateien die neue Datei nicht mit der offenen Datei verknüpfen und das Feld "Nr." das erste Feld ist, das nach der Datensatznummer im Datensatz "Textdefinition: Ressourcentabelle" oder "Numerische Definition: Ressourcentabelle" folgt, werden die Datensätze mit derselben Kennummer importiert, wie es im Datensatz angegeben ist. Wenn beispielsweise der erste importierte Ressourcendatensatz eine Kennummer von 1 und der zweite importierte Ressourcendatensatz eine Kennummer 3 hat, werden die Datensätze in Microsoft Project als Ressource 1 und Ressource 3 importiert, wobei Ressource 2 leer bleibt. Wenn Sie Dateien verknüpfen, und das Feld "Einmalige Kennung" ist entweder das erste Feld oder das zweite Feld nach dem Feld "Nr.", sucht Microsoft Project nach einem Datensatz mit derselben einmaligen Kennung und ersetzt die vorhandenen Informationen durch die neuen Informationen. Wird keine Übereinstimmung gefunden, wird am Ende der Liste ein neuer Datensatz hinzugefügt.

MPX 1.0 und 3.0-Format: Felder, die in Microsoft Project der Version 1.0 oder 3.0 nicht enthalten sind, werden beim Erstellen einer Datei im MPX 1.0 oder 3.0-Format nicht geschrieben.

Eine MPX-Datei muss mindestens zwei Vorgangs- und zwei Ressourcenfelder haben.

Numerische Definition: Ressourcentabelle - 41   Dieser Datensatz listet unter Verwendung von Zahlen anstelle der Namen die Ressourcenfelder in der Reihenfolge auf, in der sie importiert oder exportiert werden. Es handelt sich um eine andere Methode zur Identifizierung der Ressourcenfelder, die in jedem Ressourcendatensatz enthalten sind. Das Verfahren ist beim Definieren einer MPX-Datei nützlich, die von einem fremdsprachigen Produkt erstellt wurde.

Die folgende Tabelle zeigt die Feldnummern für alle Ressourcenfelder in Microsoft Project. Eine vollständige Beschreibung der zur Verfügung stehenden Felder finden Sie in der Online-Hilfe unter "Exporttabelle" und "Zusammenfassung der Tabelle 'Export' (Ressource)".

Listen Sie für diesen Datensatz die Nummern der gewünschten Ressourcenfelder auf, trennen Sie sie mit dem Auflistungs-Trennzeichen.
Field                   Number
------------------------------
% Work Complete         26
Accrue At               45
Actual Cost             32
Actual Work             22
Base Calendar           48
Baseline Cost*          31
Baseline Work*          21
Code                    4
Cost*                   30
Cost Per Use            44
Cost Variance*          34
Email Address           11
Group                   3
ID                      40
Initials                2
Linked Fields*          51
Max Units               41
Name                    1
Notes                   10
Objects*                50
Overallocated*          46
Overtime Rate           43
Overtime Work*          24
Peak*                   47
Remaining Cost*         33
Remaining Work*         23
Standard Rate           42
Text1                   5
Text2                   6
Text3                   7
Text4                   8
Text5                   9
Unique ID               49
Work*                   20
Work Variance*          25

* Wenn Sie eine Datei erstellen, die in Microsoft Project importiert werden soll, brauchen Sie dieses Feld nicht aufzuführen, da es ignoriert wird.
				
Beispiel: 41; 1; 41; 42

Dieses Beispiel listet die Feldnummern auf, die den im vorigen Beispiel dargestellten Feldern entsprechen (Name, Max. Einheiten und Standardsatz).

MPX 1.0 und 3.0-Format: Felder, die nicht in den Microsoft Project Versionen 1.0 oder 3.0 enthalten sind, werden beim Erstellen einer Datei im MPX 1.0 oder 3.0-Format nicht geschrieben.

Ressource - 50   Dieser Datensatz enthält die Informationen für jede importierte oder exportierte Ressource. Jeder Ressourcendatensatz beschreibt eine Ressource. Wenn Sie Informationen importieren, werden die aufgenommenen Felder durch den Datensatz "Textdefinition: Ressourcentabelle" oder "Numerische Definition: Ressourcentabelle" definiert. Wenn Sie Informationen exportieren, sind die aufgenommenen Felder diejenigen, die in der Export-Tabelle der Ressource aufgeführt sind.

Listen Sie für diesen Datensatz die Feldwerte für die Ressource auf, trennen Sie sie mit dem Auflistungs-Trennzeichen.

Beispiel: 50; Zimmermann; 4; 80 DM/h

Dieses Beispiel zeigt die Informationen für die Ressource "Zimmermann", die mit der im vorherigen Beispiel angegebenen Ressourcentabellendefinition übereinstimmt. Die maximalen Einheiten betragen 4 und der Standardsatz pro Stunde beträgt DM 80.

MPX 1.0-Format: Zu lange Textfelder werden beim Erstellen einer Datei im MPX 1.0-Format abgeschnitten. Im MPX 1.0-Format werden nur 2.000 Ressourcen gespeichert.

Ressourcennotizen - 51   Diese Datensätze enthalten Anmerkungen zu dem unmittelbar vorausgehenden Ressourcendatensatz. Benutzen Sie das ASCII-Zeichen 127, um innerhalb der Notizen eine neue Zeile zu zeigen. Schließen Sie die Anmerkung in Anführungszeichen ein, wenn darin das Auflistungs-Trennzeichen enthalten ist.

MPX 1.0-Format: Wenn die Notiz zu lang ist, wird sie beim Erstellen einer Datei im MPX 1.0-Format abgeschnitten.

Ressourcenkalenderdefinition - 55   Dieser Datensatz definiert die Arbeitstage für die im unmittelbar vorausgehenden Ressourcendatensatz spezifizierte Ressource. Bei importierten Dateien werden die Standardwerte verwendet, wenn kein Eintrag für das Feld "Basiskalendername" vorliegt. Kein Eintrag für den speziellen Tag zeigt an, dass der Tag auf den Standardwert gesetzt ist (2). Wenn keine Datensätze für die Ressourcenkalenderdefinition vorliegen, wird als Basiskalender für die Ressource der Standardkalender mit den Standardvorgaben für die Tage verwendet. Ein Eintrag von "0" für die Tage zeigt an, dass es sich um einen arbeitsfreien Tag handelt, "1" gibt an, dass es sich um einen Arbeitstag handelt, und "2" spezifiziert die Verwendung der Standardwerte. Weitere Informationen über Ressourcenkalender finden Sie in der Online-Hilfe unter "Ressourcenkalender" und "Arbeitszeit ändern (Menü Extras)".

In diesem Datensatz sind folgende Felder enthalten:
• Basiskalendername
• Sonntag
• Montag
• Dienstag
• Mittwoch
• Donnerstag
• Freitag
• Samstag

Beispiel: 55; Standard; 2; 2; 2; 2; 2; 0; 2

Dieses Beispiel spezifiziert, dass die unmittelbar vor diesem Datensatz definierte Ressource (in diesem Fall "Zimmermann") von Sonntag bis Donnerstag und am Samstag dieselben Arbeitstage und -stunden wie der Standardbasiskalender hat, jedoch am Freitag nicht arbeitet.

Ressourcenkalenderstunden - 56   Diese Datensätze definieren die Arbeitsstunden für die Ressource, die von dem von der Ressource genutzten Basiskalender abweichen. Diese Datensätze gelten für den Datensatz "Ressourcenkalenderdefinition", der unmittelbar vor diesem Datensatz steht. Es können nach jedem Datensatz "Ressourcenkalenderdefinition" bis zu sieben dieser Datensätze folgen.

In diesem Datensatz sind folgende Felder enthalten:
• Wochentag (1-7, wobei 1 = Sonntag und 7 = Samstag)
• Von-Zeit 1
• Bis-Zeit 1
• Von-Zeit 2
• Bis-Zeit 2
• Von-Zeit 3
• Bis-Zeit 3

Beispiel: 56; 3; 7:00; 11:00; 12:00; 16:00

Dieses Beispiel gibt an, dass die unmittelbar vorausgehende Ressource (in diesem Fall "Zimmermann") am Dienstag von 7:00 bis 16:00 Uhr mit einer Pause von 11:00 bis 12:00 Uhr arbeitet.

Ressourcenkalenderausnahme - 57   Diese Datensätze definieren Ausnahmen für die in den beiden vorherigen Datensatztypen spezifizierten Tage und Stunden. Nach jedem Datensatz "Ressourcenkalenderdefinition" können bis zu 250 dieser Datensätze folgen. Sie müssen in chronologischer Reihenfolge aufgeführt sein. Wenn sich die Ausnahme nur auf einen Tag bezieht, können Sie das Feld "Bis-Datum" leer lassen. Werden keine Zeiten angegeben, so werden die Standardzeiten von 8:00 bis 12:00 Uhr und von 13:00 bis 17:00 Uhr verwendet.

In diesem Datensatz sind folgende Felder enthalten:
• Von Datum
• Bis Datum
• Arbeitsfrei/Arbeitstag (0 = arbeitsfrei, 1 = Arbeitstag, 2 = Standard))
• Von-Zeit 1
• Bis-Zeit 1
• Von-Zeit 2
Bis-Zeit 2
• Von-Zeit 3
• Bis-Zeit 3

Beispiel: 57; 9.11.95; 13.11.95; 0

Dieses Beispiel spezifiziert, dass die Ressource (in diesem Fall "Zimmermann") vom 9. November 1995 bis zum 13. November 1995 nicht arbeitet.

MPX 1.0-Format: Weil in Microsoft Project Version 1.0 nur 50 Ausnahmen erlaubt sind, werden alle Ausnahmen nach der 50. Ausnahme beim Erstellen einer Datei im MPX-Format 1.0 ignoriert.

Textdefinition: Vorgangstabelle - 60   Dieser Datensatz listet die Vorgangsfelder in der Reihenfolge auf, in der sie importiert oder exportiert wurden. Bei importierten Dateien müssen die Namen mit den in Microsoft Project verwendeten Feldnamen übereinstimmen. Bei exportierten Dateien kommt dieser Datensatz aus der Export-Tabelle des Vorgangs. Sie können entweder diesen Datensatz oder den als nächstes beschriebenen Datensatz "Numerische Definition: Vorgangstabelle" verwenden; einer dieser Datensätze ist jedoch erforderlich. Wenn Sie aus Microsoft Project exportieren, werden diese beiden Datensätze aufgenommen. Eine vollständige Beschreibung der zur Verfügung stehenden Felder finden Sie in der Online-Hilfe unter "Exporttabelle" und "Zusammenfassung der Tabelle 'Export' (Ressource)" oder "Zusammenfassung der Tabelle 'Export' (Vorgang)".

Durch Microsoft Project berechnete Felder, zum Beispiel "Berechneter Anfang" und "Berechnetes Ende", werden beim Importieren ignoriert. Wenn Sie Vorgangsanfangs- und Endtermine haben, die feststehend sind, verwenden Sie die Felder "Einschränkungstyp" und "Termineinschränkung".

Listen Sie für diesen Datensatz die gewünschten Vorgangsfelder auf, trennen Sie sie mit dem Auflistungs-Trennzeichen.

Beispiel: 60; Name; Dauer; Vorgänger

Dieses Beispiel spezifiziert, dass jeder Vorgangsdatensatz der Datei den Vorgangsnamen, die Dauer und die Vorgänger enthält.

ANMERKUNG
Wenn Sie bei importierten Dateien die neue Datei nicht mit der offenen Datei verknüpfen und das Feld "Nr." das erste Feld ist, das nach der Datensatznummer im Datensatz "Textdefinition: Vorgangstabelle" oder "Numerische Definition: Vorgangstabelle" ist, werden die Datensätze mit derselben Kennummer importiert, wie es im Datensatz angezeigt ist. Wenn beispielsweise der erste importierte Vorgangsdatensatz eine Kennummer von 1 und der zweite importierte Vorgangsdatensatz eine Kennummer 3 hat, werden die Datensätze in Microsoft Project als Vorgang 1 und Vorgang 3 importiert, wobei Vorgang 2 leer bleibt. Wenn Sie Dateien verknüpfen und das Feld "Einmalige Kennung" ist entweder das erste Feld oder das zweite Feld nach dem Feld "Nr.", sucht Microsoft Project nach einem Datensatz mit derselben einmaligen Kennung und ersetzt die vorhandenen Informationen durch die neuen Informationen. Wird keine Übereinstimmung gefunden, wird am Ende der Liste ein neuer Datensatz hinzugefügt. Wenn Sie über einmalige Kennungen verknüpfen und korrekte Beziehungen erhalten wollen, nehmen Sie als ein zu importierendes Feld das Feld "Einmalige Nr. für Vorgänger" auf und entfernen die Vorgänger.

Wenn Sie die Datei mit einer neuen Datei zusammenführen, müssen Sie den Datensatz 75 einschließen, wenn Sie Ressourcenzuordnungen beibehalten möchten. Wenn Sie dies nicht tun, werden die Ressourcenzuordnungen gelöscht.

MPX 1.0 und 3.0-Format: Nicht in Microsoft Project Version 1.0 oder 3.0 enthaltene Felder werden beim Erstellen einer Datei im MPX 1.0 oder 3.0-Format nicht geschrieben. Die Prioritäten in den Versionen 4.0 und 4.1 entsprechen wie folgt der Version 1.0 und 3.0: "Nicht abgleichen" und "Höchste" wird "Höchste"; "Sehr hoch", "Höher" und "Hoch" wird zu "Hoch", "Mittel" ist "Mittel"; "Niedrig", "Niedriger" und "Sehr niedrig" wird zu "Niedrig", und "Niedrigste" ist "Niedrigste".

Eine MPX-Datei muss mindestens zwei Vorgangs- und zwei Ressourcenfelder haben.

Numerische Definition: Vorgangstabelle - 61Dieser Datensatz listet die Vorgangsfelder unter Verwendung von Zahlen anstelle der Namen in der Reihenfolge auf, in der sie importiert oder exportiert werden. Es handelt sich um eine andere Methode zur Identifizierung der Vorgangsfelder, die in jedem Vorgangsdatensatz enthalten sind. Das Verfahren ist beim Definieren einer MPX-Datei nützlich, die von einem fremdsprachigen Produkt erstellt wurde.

Folgende Tabelle zeigt die Feldnummern für alle Vorgangsfelder in Microsoft Project. Eine vollständige Beschreibung der zur Verfügung stehenden Felder finden Sie in der Online-Hilfe unter "Exporttabelle" und "Zusammenfassung der Tabelle 'Export' (Vorgang)".

Listen Sie für diesen Datensatz die gewünschten Vorgangsfelder auf, trennen Sie sie mit dem Auflistungs-Trennzeichen.

Field                   Number
------------------------------
% Complete              44
% Work Complete         25
Actual Cost             32
Actual Duration         42
Actual Finish           59
Actual Start            58
Actual Work             22
Baseline Cost           31
Baseline Duration       41
Baseline Finish         57
Baseline Start          56
Baseline Work           21
BCWP                    86
BCWS                    85
Confirmed               135
Constraint Date         68
Constraint Type         91
Contact                 15
Cost                    30
Cost1                   36
Cost2                   37
Cost3                   38
Cost Variance*          34
Created*                125
Critical*               82
CV*                     88
Delay                   92
Duration                40
Duration1               46
Duration2               47
Duration3               48
Duration Variance*      45
Early Finish*           53
Early Start*            52
Finish                  51
Finish1                 61
Finish2                 63
Finish3                 65
Finish4                 127
Finish5                 129
Finish Variance*        67
Fixed                   80
Fixed Cost              35
Flag1                   110
Flag2                   111
Flag3                   112
Flag4                   113
Flag5                   114
Flag6                   115
Flag7                   116
Flag8                   117
Flag9                   118
Flag10                  119
Free Slack*             93
Hide Bar                123
ID                      90
Late Finish*            55
Late Start*             54
Linked Fields*          122
Marked                  83
Milestone               81
Name                    1
Notes                   14
Number1                 140
Number2                 141
Number3                 142
Number4                 143
Number5                 144
Objects*                121
Outline Level           3
Outline Number          99
Predecessors            70
Priority                95
Project                 97
Remaining Cost          33
Remaining Duration      43
Remaining Work          23
Resource Group*         16
Resource Initials       73
Resource Names          72
Resume                  151
Resume No Earlier Than  152
Rollup                  84
Start                   50
Start1                  60
Start2                  62
Start3                  64
Start4                  126
Start5                  128
Start Variance*         66
Stop                    150
Subproject File         96
Successors              71
Summary*                120
SV*                     87
Text1                   4
Text2                   5
Text3                   6
Text4                   7
Text5                   8
Text6                   9
Text7                   10
Text8                   11
Text9                   12
Text10                  13
Total Slack*            94
Unique ID               98
Unique ID Predecessors  74
Unique ID Successors    75
Update Needed           136
WBS                     2
Work                    20
Work Variance*          24

* Sie brauchen diese Felder nicht aufzunehmen, wenn Sie eine Datei zum Importieren in Microsoft Project erstellen, weil sie ignoriert werden. Wenn Sie Anfangs- und Endtermine haben, die feststehend sind, benutzen Sie die Felder "Einschränkungsart" und "Einschränkungstermin".
				
Beispiel: 61; 1; 40; 70

Dieses Beispiel listet die Feldnummern auf, die den im vorigen Beispiel dargestellten Feldern entsprechen (Name, Dauer und Vorgänger).

MPX 1.0 und 3.0-Format: In Microsoft Project Version 1.0 oder 3.0 nicht enthaltene Felder werden beim Erstellen einer Datei im MPX 1.0 oder 3.0-Format nicht geschrieben.

Vorgang - 70   Dieser Datensatz enthält die Informationen für jeden importierten oder exportierten Vorgang. Jeder Vorgangsdatensatz beschreibt einen Vorgang. Wenn Sie Informationen importieren, werden die aufgenommenen Felder durch den Datensatz "Textdefinition: Vorgangstabelle" oder "Numerische Definition: Vorgangstabelle" definiert. Wenn Sie Informationen exportieren, sind die aufgenommenen Felder in der Export-Tabelle des Vorgangs aufgeführt.

Listen Sie für diesen Datensatz die Feldwerte für den Vorgang auf, trennen Sie sie mit dem Auflistungs-Trennzeichen.

Beispiel: 70; Zement gießen; 6t

Dieses Beispiel zeigt die Informationen für den Vorgang "Zement gießen", die mit der im vorigen Beispiel angegebenen Vorgangstabellendefinition übereinstimmen. Die Vorgangsdauer beträgt 6 Tage.

MPX 1.0-Format: Gliederungsebenen größer als 5 werden als Ebene 5 gespeichert. Zu lange Textfelder werden abgeschnitten. Es werden nur 2.000 Vorgänge gespeichert.

Vorgangsnotizen - 71   Diese Datensätze enthalten Notizen über den unmittelbar vorausgehenden Vorgangsdatensatz. Benutzen Sie das ASCII-Zeichen 127, um innerhalb der Notiz eine neue Zeile anzugeben. Wenn in der Notiz das Auflistungs-Trennzeichen enthalten ist, schließen Sie die Notiz in Anführungszeichen ein.

MPX 1.0-Format: Wenn die Notiz zu lang ist, wird sie beim Erstellen einer Datei im MPX 1.0-Format abgeschnitten.

Periodischer Vorgang- 72   Diese Datensätze zeigen an, ob der Vorgang ein periodischer Vorgang ist.

Wenn der Vorgang ein übergeordneter periodischer Vorgang ist, sind folgende Felder in dem Datensatz enthalten:
• Anfang der Auftritte, entsprechend der Eingabe im Dialogfeld Informationen zum periodischen Vorgang.
• Endtermin entsprechend der Eingabe im Dialogfeld Informationen zum periodischen Vorgang.
• Dauer eines jeden Auftritts.
• Art der Dauer (Tag, Monat, etc.)
• Anzahl der Auftritte.
• Das im Dialogfeld Informationen zum periodischen Vorgang im Gruppenfeld "Auftreten" gewählte Intervall (1 = täglich, 4 = wöchentlich, 8 = monatlich, 16 = jährlich).
• Auswahl im Dropdown-Listenfeld des Gruppenfeldes "Täglich" (1 = jeden, 2 = jeden zweiten, usw.).
• Auswahl im Dropdown-Listenfeld des Gruppenfeldes "Wöchentlich".
• Auswahl im Dropdown-Listenfeld (Ersten, Zweiten,...) des Gruppenfeldes "Monatlich".
• Auswahl im Dropdown-Listenfeld (Montag, Dienstag,...) des Gruppenfeldes "Monatlich".
• Auswahl im Dropdown-Listenfeld (Jedem, Jedem 2.,...) des Gruppenfeldes "Monatlich", wenn die untere Option ausgewählt ist.
• Der ausgewählte Tag im numerischen Textfeld des Gruppenfeldes "Monatlich".
• Auswahl im Dropdown-Listenfeld (Jedem, Jedem 2.,...) des Gruppenfeldes "Monatlich", wenn die untere Option ausgewählt ist.
• Auswahl im Dropdown-Listenfeld (Ersten, Zweiten,...) des Gruppenfeldes "Jährlich".
• Auswahl im Dropdown-Listenfeld (Montag, Dienstag,...) des Gruppenfeldes "Jährlich".
• Auswahl im Dropdown-Listenfeld (Januar, Februar,...) des Gruppenfeldes "Jährlich".
• Der ausgewählte Datum im Textfeld des Gruppenfeldes "Jährlich".

Wenn der Vorgang ein untergeordneter periodischer Vorgang ist, ist folgendes Feld in dem Datensatz enthalten:
• Einmalige Nr. des übergeordneten Vorgangs

Beispiel: 72;1

Dieses Beispiel zeigt, dass der Vorgang ein untergeordneter periodischer Vorgang ist, dessen übergeordneter Vorgang die einmalige Nr. 1 hat.

Ressourcenzuordnung - 75   Diese Datensätze listen Informationen über die dem Vorgang zugeordneten Ressourcen auf, der in dem vorausgehenden Vorgangsdatensatz definiert wurde. Wenn Sie Dateien verknüpfen, ersetzen alle von Ihnen gesendeten Ressourcenzuordnungsdatensätze alle vorhandenen Zuordnungen der verknüpften Vorgänge. Wenn Sie Dateien auf Grundlage der einmaligen Kennungen verknüpfen, werden die Ressourcen unter der Verwendung der einmaligen Kennung der Ressource an Stelle der Kennummern zugeordnet.

In diesem Datensatz sind folgende Felder enthalten:
• Nr.
• Einheiten
• Arbeit
• Geplante Arbeit
• Aktuelle Arbeit
• Überstundenarbeit
• Kosten
• Geplante Kosten
• Aktuelle Kosten
• Anfang*
• Ende*
• Verzögerung
• Einmalige Nr.

* Diese Felder werden durch Microsoft Project berechnet, importierte Werte werden ignoriert.

Beispiel: 75; 3; 0,5; 40h

Dieses Beispiel spezifiziert, dass die Ressource mit der Kennummer 3 dem unmittelbar vorausgehenden Vorgang zugeordnet ist. Wenn die ankommenden Ressourcen keine Kennummern haben, wird die dritte ankommende Ressource zugeordnet. In diesem Beispiel ist die Ressource für 40 Arbeitsstunden mit 0,5 Einheiten dem Vorgang "Zement gießen" zugeordnet.

MPX 1.0-Format: Wenn Sie eine Datei im MPX 1.0-Format erstellen, wird das Feld "Verzögerung" ignoriert.

Workgroup-Ressourcenzuordnung - 76   Diese Datensätze listen Informationen über Zuordnungen der Workgroup-Funktion in Microsoft Project, Version 4.0 und 4.1, auf. Wenn Sie die Workgroup-Funktionen verwenden, müssen Sie diesen Datensatz aufnehmen, um sicherzustellen, dass keine Informationen verloren gehen.

In diesem Datensatz sind folgende Felder enthalten:
• Einmalige Nr. der Nachricht
• Bestätigt (0 = Falsch; 1 = Wahr)
• Ausstehende Antwort (0 = Falsch; 1 = Wahr)
• Aktualisierter Anfang (Datum)
• Aktualisiertes Ende (Datum)
• Schedule+ Kennung

Beispiel: 76; 1;0;1;1.6.95; 2.6.95

Dieses Beispiel zeigt die Ressourcenzuordnung des Zuordnungs-Datensatzes 75 die einmalige Nachrichten-Nr. 1 hat, die die Zuordnung nicht bestätigt ist, die zuletzt gesendete Nachricht noch nicht beantwortet wurde, die mitgeteilten Daten sind, 1.6.95 für den Vorgangsanfang und 2.6.95 für das Vorgangsende.

Projektnamen - 80   Diese Datensätze listen alle für DDE-Verknüpfungen in dem Projekt gespeicherten Namen auf.

In diesem Datensatz sind folgende Felder enthalten:
• Name
• Beschreibung

Beispiel: 80; VERKNÜPFUNG_1; "V((1;3;5);(Name;Dauer))"

Dieses Beispiel listet die DDE-Verknüpfung mit der Bezeichnung VERKNÜPFUNG_1 und deren Beschreibung auf. Weitere Informationen DDE finden Sie in der Online-Hilfe unter "DDE" und dem zugehörigen Hilfe-Thema "Dynamischer Datenaustausch". Weil im Feld "Beschreibung" das Auflistungs-Trennzeichen enthalten ist, wird das Feld in Anführungszeichen eingefasst.

MPX 1.0-Format: Wenn Sie im MPX 1.0-Format speichern, wird dieser Datensatz nicht geschrieben.

DDE- und OLE-Verknüpfungen - 81   Dieser Datensatz listet alle DDE-Verknüpfungen zu dem Projekt auf.

• Quelle
• Verknüpfung zu

Beispiel: 81; Winword|d:\winword\MPX.doc!VERKNÜPFUNG_1;"V(1;Name)"

In diesem Beispiel ist "Winword|d:\winword\MPX.doc!VERKNÜPFUNG_1" das Argument "Verknüpfung von" und "V (1,Name)" ist das Argument "Verknüpfung zu". Weil im Feld "Verknüpfung zu" das Auflistungs-Trennzeichen enthalten ist, wird das Feld in Anführungszeichen eingefasst. OLE-Verknüpfungen werden von DDE-Verknüpfungen unterschieden, indem als erstes Zeichen ein ":" angegeben wird. Beispiel: 81; :\VERKNÜPFUNG_!; "V (2;1)". Der Doppelpunkt ":" am Anfang des Feldes "Quelle" zeigt an, dass es sich um ein OLE-Objekt handelt.

MPX 1.0-Format: Wenn Sie im MPX 1.0-Format speichern, wird dieser Datensatz nicht geschrieben.

Kommentare - 0   Diese Datensätze können zum Ergänzen von Kommentaren in der Datei verwendet werden. Sie können an einer beliebigen Position in der Datei erscheinen. Jeder Kommentardatensatz muss mit einer "0" beginnen.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Project 2000 Standard Edition
  • Microsoft Project 98 Standard Edition
  • Microsoft Project 4.1 Standard Edition
  • Microsoft Project 4.1a
  • Microsoft Project 4.0 Standard Edition
  • Microsoft Project 4.0 für Macintosh
Keywords: 
kbinfo KB270139
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store