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Artikel-ID: 313853 - Geändert am: Freitag, 16. Juni 2006 - Version: 1.0

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
313853  (http://support.microsoft.com/kb/313853/EN-US/ ) System Restore Tool Displays a Blank Calendar in Windows XP
In Artikel 275646  (http://support.microsoft.com/kb/275646/DE/ ) wird dieses Thema für Microsoft Windows Millennium Edition behandelt.

Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Problembeschreibung

Wenn Sie das Dienstprogramm Systemwiederherstellung auf einem Windows-XP-Computer ausführen, wird der Kalender rechts neben dem Fenster "Wiederherstellungspunkt auswählen" nicht angezeigt.

Ursache

Dieses Verhalten kann auftreten, wenn die Dateizuordnung für HTML (Hypertext Markup Language)-Dateien nicht in der Registrierung hinterlegt ist.

Lösung

WARNUNG: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Um das Problem zu beheben, stellen Sie sicher, dass die folgenden Schlüssel in der Registrierung enthalten sind. Wenn einer der Registrierungsschlüssel nicht vorhanden ist, erstellen Sie den Schlüssel und fügen Sie die Werte hinzu, die zu dem entsprechenden Schlüssel gehören.
HKEY_CLASSES_ROOT\.htc
Name: Content Type
Wert: text/x-component

HKEY_LOCAL_MACHINE\Software\Classes\.htc
Name: Content Type
Wertdaten: text/x-component

HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component
Name: CLSID
Wert: {3050f4f8-98b5-11cf-bb82-00aa00bdce0b}

Erstellen Sie einen zweiten Eintrag mit den folgenden Werten:
Name: Extension
Wert: .htc

HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}
Name ="Microsoft Html Component"

HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32
Name: Default
Wertdaten: "C:\Windows\System32\Mshtml.dll"

Erstellen Sie einen zweiten Eintrag mit den folgenden Werten:
Name: "ThreadingModel"
Wert: "Apartment"
Hinweis: Bei diesem Verfahren wird davon ausgegangen, dass Windows XP im Ordner "C:\Windows" installiert ist. Ändern Sie "C:\Windows" in den entsprechenden <Windows_Ordner> um, falls sich Windows an einem anderen Ort befindet.

Um alle Informationen gleichzeitig zusammenzuführen, können Sie den folgenden Text kopieren, in einen Texteditor einfügen und anschließend als REG-Datei speichern.

Hinweis: Sie müssen jeden der folgenden Texte kopieren, um sicherzugehen, dass der Vorgang wie erwartet ausgeführt wird.
   Windows-Registrierungs-Editor Version 5.00

   [HKEY_CLASSES_ROOT\.htc]
   "Content Type"="text/x-component"
   @="htcfile"

   [HKEY_CLASSES_ROOT\MIME\Database\Content Type\text/x-component]
   "CLSID"="{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}"
   "Extension"=".htc"

   [HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}]
   @="Microsoft Html Component"
   [HKEY_CLASSES_ROOT\CLSID\{3050f4f8-98b5-11cf-bb82-00aa00bdce0b}\InProcServer32]
   @="C:\\WINDOWS\\System32\\mshtml.dll"
   "ThreadingModel"="Apartment""

   [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.htc]
   "Content Type"="text/x-component"
   @="htcfile"
					
Nachdem Sie die oben genannten Schritte durchgeführt haben, können Sie das Dienstprogramm Systemwiederherstellung verwenden. Wenn Sie allerdings mit dem Dienstprogramm Systemwiederherstellung eine frühere Konfiguration wiederherstellen, wird das Registrierungsupdate aus der Windows-Registrierung entfernt. Um sicherzustellen, dass das Problem nicht wieder auftritt, nachdem Sie die frühere Konfiguration wiederhergestellt haben, wiederholen Sie die oben genannten Schritte, um das Dienstprogramm Systemwiederherstellung zu akualisieren, erstellen Sie einen neuen Systemwiederherstellungspunkt und kennzeichnen Sie ihn so, dass erkennbar ist, dass er das Systemwiederherstellungsupdate enthält. Nach Ausführung dieser Schritte können Sie das Dienstprogramm Systemwiederherstellung jederzeit verwenden, um den Systemwiederherstellungspunkt, der das Update enthält, wiederherzustellen, ohne dabei das Dienstprogramm Systemwiederherstellung zu beschädigen.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kbprb kbprod2web kbui KB313853
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