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Artikel-ID: 319440 - Geändert am: Mittwoch, 14. Mai 2008 - Version: 7.0

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Problembeschreibung

In Windows können erhebliche Anmeldeverzögerungen auftreten, wenn Clients anmelden. Dieses Problem tritt auf, wenn die meisten oder alle der folgenden Bedingungen erfüllt sind:
  • Mehrere Clients sind gleichzeitig anmelden.
  • Die Clients sind Freigabe von eine großen Richtliniendatei oder wenigen großen Richtliniendateien.
  • Die Clients verwenden (langsame) Verbindungen mit geringer Bandbreite.
  • Die Clients haben Zugriff auf wenigen Domänencontrollern.
  • Die Clients haben langsamer Erkennung deaktiviert für Richtlinie Downloads oder die Registry.pol-Datei aufgrund eines Updates abgerufen wird.

Ursache

Dieses Verhalten kann auftreten, wenn der Client ist nicht verwenden, opportunistisches Sperren, wenn der Client die Richtlinie heruntergeladen wird. Dieser Leistungsabfall verursacht eine Verzögerung in Richtlinien, die mehr erkennbar ist, wenn der Zugriff auf Domänencontroller über eine Verbindung mit niedriger Bandbreite erfolgt, downloaden.

Lösung

Windows Server 2003 Service Pack-Informationen

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Windows Server 2003 Hotfix-Informationen

In diesem Artikel beschriebene Hotfix wurde durch einen anderen Hotfix ersetzt. Weitere Informationen zu den neuen Hotfix finden Sie im folgenden Artikel der Microsoft Knowledge Base:
930597  (http://support.microsoft.com/kb/930597/ ) Einige der Registrierung basierende Richtlinieneinstellungen verloren und Fehlermeldungen werden im Anwendungsprotokoll auf einem Windows XP-basierten Computer oder auf einem Windows Vista-Computer protokolliert
Der Hotfix fügt und setzt den Wert des folgenden Registrierungsschlüssels auf der Registrierung:
Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Eintrag: BufferPolicyReads
Typ: DWORD
Wert: 1
Hinweis: Datei liest nur gepuffert, wenn die BufferPolicyReads-Registrierungseintrag vorhanden ist und auf 1 festgelegt ist.

Voraussetzungen

Um diesen Hotfix installieren, müssen Sie Windows Server 2003 Service Pack 1 (SP1) auf X 86 und Itanium-basierten Versionen von Windows Server 2003 installiert haben. Weitere Informationen, wie Sie Windows Server 2003 Service Pack 1 erhalten können finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Userenv.dll5.2.3790.2749790,52818-Jul-200613: 38X 86
Windows Server 2003, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Userenv.dll5.2.3790.27491,565,69618-Jul-200601: 32IA-64SP1SP1QFE
Wuserenv.dll5.2.3790.2749790,52818-Jul-200601: 32X 86SP1WOW
Windows Server 2003 x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Userenv.dll5.2.3790.27491,070,59218-Jul-200601: 30X 64SP1SP1QFE
Wuserenv.dll5.2.3790.2749790,52818-Jul-200601: 30X 86SP1WOW

Windows XP Hotfix-Informationen

Ein unterstützter Hotfix ist inzwischen von Microsoft. Es ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Wenden Sie es nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Sie durch dieses Problem nicht schwerwiegend betroffen sind, empfiehlt Microsoft daher, auf das nächste Windows XP Service Pack warten, das diesen Hotfix enthält wird.

Dieses Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services, um den Hotfix zu erhalten. Eine vollständige Liste mit Telefonnummern der Microsoft Product Support Services und Informationen über Supportkosten der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: PLEASE DO NOT TRANSLATE and DELETE THIS PASSAGE. IT DOES NOT APPLY TO GERMANY.
Der Hotfix fügt und setzt den Wert des folgenden Registrierungsschlüssels auf der Registrierung:
Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Eintrag: BufferPolicyReads
Typ: DWORD
Wert: 1
Hinweis: Datei liest nur gepuffert, wenn die BufferPolicyReads-Registrierungseintrag vorhanden ist und auf 1 festgelegt ist.

Voraussetzungen

Um diesen Hotfix installieren, müssen Sie Windows XP Service Pack 2 (SP2) auf dem Computer installiert sein.
Weitere Informationen, wie Sie Windows XP Service Pack 2 (SP2) erhalten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) Wie Sie das neueste Service Pack für Windows XP erhalten

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Userenv.dll5.1.2600.2913724,99222-Mai 200612: 14X 86

Abhilfe

Zum Arbeiten um dieses Verhalten müssen alle Clients die Richtliniendateien schnell herunterladen, damit andere Clients nicht über die opportunistic locking-Funktion angehalten werden. Verwenden Sie hierzu eine der folgenden Methoden.

Domänencontroller lokal hinzugefügt

Wenn Sie dies tun, müssen Clients nicht über eine langsame Verbindung eine Verbindung herstellen.

Verteilen der Last mit zusätzlicher Domänencontroller

Wenn es nicht sinnvoll, die Domänencontroller am selben Standort wie der Client platziert ist, können Sie Domänencontroller zur Hauptsite hinzufügen, um die Clients eine Verbindung zu besseren Lastenausgleich bereitstellen. Diese Methode erhöht die Wahrscheinlichkeit von dem Client die Richtliniendatei Zugriff mithilfe der opportunistic locking-Funktion auf.

Teilen Sie eine einzelne Richtlinie-Datei in mehrere Richtliniendateien

Wenn die Richtliniendatei mehrere KB übersteigt, erstellen Sie ein paar exklusive Richtliniendateien auf den gleichen Bereich von Richtlinien behandelt. Dies verringert den Zeitaufwand, die für die Richtliniendateien downloaden, ob die opportunistic locking-Funktion verfügbar ist oder nicht erforderlich ist. Mehrere Dateien erhöht auch die Wahrscheinlichkeit, dass der Client verwendet die opportunistic locking-Funktion für den Zugriff auf die Datei.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals im Microsoft Windows Server 2003 Service Pack 2.

Weitere Informationen

Clients werden durch diese langsame Anmeldung Verhalten betroffen, beim Downloaden der Richtliniendatei. Administratoren können zur Erkennung langsamer (mithilfe von Administrator Vorlagen\system\gruppenrichtlinie) deaktivieren downloads um Richtlinie zu erzwingen, unabhängig von der Verbindungsgeschwindigkeit. Jede Änderung der Richtliniendatei wird die Registry.pol-Datei durch Remoteclients bei jeder Änderung gedownloadet werden.

Weitere Informationen wie eine langsame Verbindung erkannt wird und das Standardverhalten von Erweiterungen der Gruppenrichtlinien über langsame Verbindung finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
227369  (http://support.microsoft.com/kb/227369/ ) Standardverhalten für Gruppenrichtlinienerweiterung mit langsamer
227260  (http://support.microsoft.com/kb/227260/ ) Wie eine langsame Verbindung für Benutzerprofilen und Gruppenrichtlinien erkannt
Standardmäßig versucht der Redirector eine opportunistische Sperre abrufen, wenn eine Datei von einem Remotestandort aus geöffnet wird. Dies ermöglicht den Redirector zum Zwischenspeichern von Read-ahead-Leistung verbessern. Weitere Informationen zu Oplocks finden Sie im folgenden Artikel der Microsoft Knowledge Base:
129202  (http://support.microsoft.com/kb/129202/ ) Erklärung des opportunistic locking unter Windows NT
In bestimmten Fällen kann der Dateiserver opportunistisches Sperre Anfragen ablehnen. Dies tritt häufig auf, wenn die Datei für die exklusive-schreiben-Verwendung gesperrt ist. Außerdem führt der Server-Dienst die folgenden Prüfungen um Daten Schaden zu vermeiden und die Stabilität zu verbessern:
  • Überprüfen Sie, ob die Datei eine Systemdatei ist
  • Überprüfen Sie, ob die Netzwerkverbindung zuverlässig gilt
  • Überprüfen Sie, ob Filtertreiber, die nicht Ihre Auftrag abgeschlossen haben vorhanden sind
Weitere Informationen zu einem verwandten Thema finden Sie im folgenden Artikel der Microsoft Knowledge Base:
306981  (http://support.microsoft.com/kb/306981/ ) Ebene II Oplocks werden nicht erteilt werden, nachdem eine Datei gesperrt ist
Benutzer, die die Dateien, zugreifen indem Oplocks führen Sie dieses Verhalten nicht auftreten, weil der Redirector-Dienst führt Read-ahead-Zwischenspeicherung und Datei Lesevorgänge werden vom Redirector-Cache bedient.

Wenn der Redirector-Dienst nicht die Remotedatei geöffnet wird mithilfe der opportunistic locking-Funktion, wird die Windows NT 4.0 SMB oder CIF-2.0-Spezifikation von MSDN:
Wenn ein Client keine Oplocks enthält, müssen alle Anforderungen außer Lesevorgänge an den Server gesendet werden. Lesevorgänge können Cache oder Read-ahead-Daten verwenden, solange der Bytebereich vom Client gesperrt wurde durchgeführt werden; andernfalls diese zu müssen an den Server gesendet.
Dadurch wird die Richtlinie laden Methode Lesevorgänge Zugriff auf den Server mithilfe des Netzwerks für jedes Unicode-Zeichen, die gelesen wird. Wenn die Richtliniendatei groß ist und wenn die verfügbare Bandbreite für die Clients niedrig ist, erhebliche Verzögerungen, auftreten während Richtlinien laden, und diese Anmeldeverzögerungen erstellen.

Um diese Situation zu identifizieren, verwenden Sie eine der folgenden Methoden.

Methode 1

Sie können die Tools von Drittanbietern FileMon.exe von der folgenden Sysinternals-Website ausführen:
http://technet.microsoft.com/en-us/sysinternals/default.aspx (http://technet.microsoft.com/en-us/sysinternals/default.aspx)
Die Ausgabe aus dem Tool FileMon.exe ähnelt:
System: 8 FSCTL_REQUEST_BATCH_OPLOCK C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol OPLOCK nicht erteilt
System: 8 FSCTL_REQUEST_OPLOCK_LEVEL_2 C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol OPLOCK nicht erteilt
System: 8 FASTIO_QUERY_NETWORK_OPEN_INFO C:\WINNT\SYSVOL\domain\Policies\{Policy-GUID}\user\registry.pol erfolgreich

Methode 2

Microsoft Netzwerkablaufverfolgungen Monitor anzeigen Oplock-Level = none für die Server-Antwort auf die Datei geöffnet-Anforderung:
SMB: R NT erstellen und X, FID = 0x4009
+ SMB: NT-Statuscode = 0 x 0, Einrichtung = System, Schweregrad = Erfolg Code = (0) STATUS_WAIT_0
+ SMB: Kopfzeile: PID = 0x00B8 TID = 0x0804 Teil = 0x0841 UID = 0 x 1000
Befehl SMB: C NT = erstellen und X
SMB: Word Count = 42
SMB: Word-Parameter
SMB: Weiter offset = 0x0087
SMB: Word Count = 42
SMB: Word-Parameter
SMB: Oplock-Level = NONE
SMB: Datei-ID (FID) = 16393 (0x4009)
SMB: Dateiname = \mydom.com\Policies\{E3FDB1FB-0FA1-484E-8751-7009DD5287BD}\User\registry.pol
Sequenzielle 2 Byte liest der Richtliniendatei, sodass einen langsamen Download die Datei groß ist:
107 26.234375 SMB C NT erstellen n X, File = \mydom.com\Policies\{E3FDB1FB-0FA1-484E-8751-7009DD5287BD}\User\registry
108 26.234375 SMB R NT erstellt n X, FID = 0x4009 161.123.162.142 161.123.110.40
109 26.296875 SMB C lesen n X, FID = 0x4009, Read 0 x 4 in 0 x 00000000 161.123.110.40 161.123.162.142
0 X 4 110 26.296875 SMB R n X lesen lesen 161.123.162.142 161.123.110.40
111 26.343750 SMB C lesen n X, FID = 0x4009, Read 0 x 4 auf 0 x 00000004 161.123.110.40 161.123.162.142
Lesen von 112 26.343750 SMB R n X, 0 x 4 Lesen 161.123.162.142 161.123.110.40
113 26.406250 SMB C lesen n X, FID = 0x4009, Read 0 x 2 bei 0 x 00000008 161.123.110.40 161.123.162.142
0 X 2 114 26.406250 SMB R n X lesen lesen 161.123.162.142 161.123.110.40
115 26.453125 SMB C lesen n X, FID = 0x4009, Read 0 x 2 am 0x0000000A 161.123.110.40 161.123.162.142

Technischer Support für x 64-basierten Versionen von Microsoft Windows

Wenn Ihre Hardware mit einer Microsoft Windows X 64 Edition bereits installiert war, bietet der Hardwarehersteller technischen Support und Unterstützung für Windows X 64 Edition. In diesem Fall bietet der Hardwarehersteller unterstützt, da eine Windows X 64 Edition zusammen mit Ihrer Hardware geliefert wurde. Hardwarehersteller möglicherweise die Windows X 64 Edition-Installation mithilfe von spezifischen Komponenten angepasst haben. Eindeutige Komponenten gehören bestimmte Gerätetreiber oder gehören optionale Einstellungen, um die Leistung der Hardware zu optimieren. Wenn Sie technische Hilfe zu Windows X 64 Edition benötigen, bietet Microsoft in diesem Fall angemessenem Unterstützung Rahmen. Allerdings müssen Sie möglicherweise den Hersteller direkt. Der Hersteller ist am besten ihm, um die Software zu unterstützen, die der Hersteller der Hardware installiert. Wenn Sie eine Windows X 64 Edition z. B. eine Windows Server 2003 x 64 Edition) separat erworben haben, wenden Sie sich an Microsoft, für technischen Support.

Weitere Informationen zu Windows XP Professional X 64 Edition die folgende Microsoft-Website:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Weitere Informationen zu x 64-basierten Versionen von Windows Server 2003 die folgende Microsoft-Website:
http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx)


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Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows 2000 Advanced Server SP2
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