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Artikel-ID: 319624 - Geändert am: Donnerstag, 19. Februar 2004 - Version: 1.0

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
319624  (http://support.microsoft.com/kb/319624/EN-US/ ) PRB: Incorrect Default DCOM Settings Cause Windows Installer to Stop Responding
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Nach der Aktualisierung auf Windows Installer 2.0 lässt sich der Windows Installer-Dienst möglicherweise nicht starten, und es wird folgende Fehlermeldung angezeigt:
Auf den Windows-Installationsdienst konnte nicht zugegriffen werden. Dies kann auftreten, wenn Windows im abgesicherten Modus ausgeführt wird oder wenn der Windows Installer nicht korrekt installiert wurde. Setzen Sie sich mit dem Supportpersonal in Verbindung, um weitere Unterstützung zu erhalten.
Hinweis: Dieses Verhalten tritt bei den folgenden Produkten nicht auf:
  • Microsoft Windows XP
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98

Ursache

Dieses Verhalten kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • In den DCOM-Berechtigungen ist die Standardauthentifizierungsebene auf Keine gesetzt, und die Standardebene für den Identitätswechsel ist auf Anonym gesetzt.
  • Das Systemkonto hat keine Vollzugriffsberechtigung auf einen Ordner oder Registrierungsschlüssel, auf den Windows Installer versucht zuzugreifen. Dies gilt für NTFS.

Lösung

Wenden Sie je nach dem vorliegenden Problem eine oder alle der folgenden Methoden an:
  • Methode 1: Überprüfen Sie die DCOM-Berechtigungen.
  • Methode 2: Gewähren Sie dem SYSTEM-Konto die Vollzugriffsberechtigung.
  • Methode 3: Überprüfen Sie die Registrierungsberechtigungen.
  • Methode 4: Reparieren Sie den beschädigten Sicherheitsschlüssel für den MsiServer-Dienst.

Voraussetzung: Vergewissern Sie sich, dass das Service Pack installiert ist

Wenn Sie Windows 2000 verwenden, stellen Sie sicher, dass SP 2 installiert ist.
Wenn Sie Windows NT 4.0 verwenden, stellen Sie sicher, dass SP 6 installiert ist.

Wenn Sie die entsprechenden Service Packs nicht installieren, kann es sein, dass die im Abschnitt "Weitere Informationen" dieses Artikels beschriebenen Schritte nicht wie vorgesehen funktionieren.

Weitere Informationen

Methode 1: Überprüfen Sie die DCOM-Berechtigungen

Bei dieser Methode wird die DCOM-Standardebene für den Identitätswechsel in Identifizieren geändert, die Datei "Msisip.dll" entfernt und SP 3 für Windows 2000 anschließend neu installiert.

Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start und anschließend auf Ausführen, geben Sie dcomcnfg ein, und klicken Sie auf OK.
  2. Klicken Sie auf die Registerkarte Standardeigenschaften, und führen Sie folgende Schritte durch:
    1. Wählen Sie in der Liste für die Standardauthentifizierungsebene die Option Verbinden.
    2. Wählen Sie in der Liste für die Standardidentitätswechselebene die Option Identifizieren, und klicken Sie auf OK.
  3. Klicken Sie auf Start und anschließend auf Ausführen, geben Sie explorer /select, %windir%\system32\msisip.dll ein, und klicken Sie auf OK.
  4. Benennen Sie die Datei "Msisip.dll" in Msisip.old um.
  5. Installieren Sie Windows 2000 Service Pack 3 neu.

Methode 2: Gewähren Sie dem SYSTEM-Konto die Vollzugriffsberechtigung

  1. Starten Sie Windows Explorer, klicken Sie mit der rechten Maustaste auf die Stammfestplatte des Computers, und klicken Sie auf Eigenschaften.
  2. Klicken Sie auf die Registerkarte Sicherheit und anschließend auf Hinzufügen.
  3. Klicken Sie im Dialogfeld Benutzer, Computer oder Gruppen auswählen auf das Konto SYSTEM, klicken Sie auf Hinzufügen und anschließend auf OK.
  4. Aktivieren Sie unter Zulassen das Kontrollkästchen Vollzugriff, und klicken Sie auf OK.
  5. Klicken Sie auf den Ordner "TEMP", und stellen Sie sicher, dass dem Konto SYSTEM die Vollzugriffsberechtigung zugewiesen ist.

Methode 3: Überprüfen Sie die Registrierungsberechtigungen

  1. Klicken Sie auf Start und anschließend auf Ausführen, geben Sie Regedt32 ein, und klicken Sie auf OK.
  2. Führen Sie für jede Registrierungsstruktur die folgenden Schritte durch:
    1. Markieren Sie die Struktur.
    2. Klicken Sie in Windows XP im Menü Bearbeiten auf Berechtigungen.

      Klicken Sie in Windows 2000 und Windows NT 4 im Menü Sicherheit auf Berechtigungen.
  3. Stellen Sie sicher, dass das Konto SYSTEM hinzugefügt wurde und über die Vollzugriffsberechtigung verfügt. Ist dies nicht der Fall, fügen Sie das Konto SYSTEM mit Vollzugriffsberechtigung hinzu.

Methode 4: Reparieren Sie den beschädigten Sicherheitsschlüssel für den MsiServer-Dienst

  1. Starten Sie den Computer unter Windows 2000.
  2. Klicken Sie auf Start und anschließend auf Ausführen, geben Sie regedit.exe ein, und benennen Sie den folgenden Schlüssel in "Old_Security" um.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security
  3. Starten Sie den Computer neu (dies ist erforderlich).
  4. Führen Sie "Instmsiw.exe" für Installer 2.0 erneut aus. Hierdurch wird der beschädigte Sicherheitsschlüssel für den MSI-Dienst repariert.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Installer 1.0unter den folgenden Betriebssystemen
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.1unter den folgenden Betriebssystemen
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.2unter den folgenden Betriebssystemen
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 2.0unter den folgenden Betriebssystemen
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
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kbprb KB319624
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