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Artikel-ID: 319740 - Geändert am: Montag, 9. Juni 2008 - Version: 7.6

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
319740  (http://support.microsoft.com/kb/319740/EN-US/ ) MFC applications leak GDI objects on computers that are running Windows Server 2003 or Windows XP
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Problembeschreibung

Wenn Sie auf einem Computer mit Microsoft Windows XP Service Pack 2 (SP2) eine MFC-Anwendung ausführen (MFC = Microsoft Foundation Classes), stellen Sie beim Erstellen und Beseitigen untergeordneter Fenster eventuell Speicherlecks bei GDI-Objekten fest (GDI = Graphics Device Interface). Zeigen Sie die GDI-Objekte des Prozesses im Task-Manager an, um die Speicherlecks zu sehen.

Dieses Problem tritt auch auf Windows Server 2003-Computern auf, wenn der Designdienst gestartet wird. Standardmäßig ist der Designdienst in Windows Server 2003 deaktiviert.

Ursache

Dieses Problem tritt wegen eines Fehlers in der Implementierung der neuen Designschnittstelle auf.

Lösung

Hotfix-Informationen

Windows 2003

Ein Hotfix zur Behebung des Problems ist bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Eine vollständige Liste mit Telefonnummern des technischen Supports sowie die Möglichkeit zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, steht der Hotfix für Ihre Sprache nicht zur Verfügung.

Voraussetzungen

Keine

Neustart

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
Windows Server 2003, x86-Versionen
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DateinameDateiversionDateigrößeDatumZeitPlattform
Uxtheme.dll6.0.3790.274200.70418.02.200505:38x86
Updspapi.dll6.1.22.0371.93616.02.200500:18x86

Windows Server 2003, Itanium-Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattformServicebereich
Uxtheme.dll6.0.3790.274539.64817.02.200513:38IA-64RTMQFE
Wuxtheme.dll6.0.3790.274200.70417.02.200513:38x86WOW
Updspapi.dll6.1.22.0639.71215.02.200508:18IA-64Nicht zutreffend

Windows XP

Voraussetzungen

Sie müssen Windows XP Service Pack 2 (SP2) installiert haben, um diesen Hotfix anwenden zu können.

Neustart

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen zuvor veröffentlichten Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
Uxtheme.dll6.0.2900.2523218.62423.09.0417:16x86
Updspapi.dll6.1.22.4371.93625.02.0503:53x86
Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:

Bild minimierenBild vergrößern
Download
Updatepaket für Windows XP (KB319740) jetzt herunterladen (http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=9b5edfc8-a4bb-4080-9063-6518166e2dab)
Freigabedatum: 21.03.2006

Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/DE/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.

Abhilfe

Wenn dieses GDI-Leck die Leistung ernsthaft beeinträchtigt, können Sie das neue Benutzeroberflächendesign in Windows XP deaktivieren. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start und anschließend auf Systemsteuerung.
  2. Klicken Sie auf Darstellung und Designs und anschließend auf Anzeige.
  3. Klicken Sie im Dialogfeld Eigenschaften von Anzeige auf der Registerkarte Designs in der Liste Design auf Windows - klassisch.
  4. Klicken Sie auf Übernehmen und anschließend auf OK.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
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