DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 329316 - Geändert am: Donnerstag, 16. Mai 2013 - Version: 4.0

Hotfix-Download ist verfügbar
Hotfix-Downloads anzeigen und anfordern
 
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
329316  (http://support.microsoft.com/kb/329316/EN-US/ ) Error Message: User Interface Failure: The Logon User Interface DLL Msgina.dll Failed to Load
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Problembeschreibung

Nach der Installation von Windows 2000 Service Pack 3 (SP3) wird möglicherweise beim Starten des Computers die folgende Fehlermeldung angezeigt:
Versagen der Benutzeroberfläche:
Die Anmeldungsbenutzeroberflächen-DLL msgina.dll wurde nicht geladen.
Wenden Sie sich an den Systemadministrator, um die DLL zu ersetzen, oder stellen Sie die ursprüngliche DLL wieder her.
Der Windows-Anmeldebildschirm wird nicht angezeigt, und Sie können Windows 2000 nicht öffnen.

Ursache

Dieses Problem kann auftreten, wenn die Datei "Winlogon.exe" den Registrierungsschlüssel "Mpr.dll" abfragt, bevor die Datei "Services.exe" diesen Registrierungsschlüssel erstsellt hat. In Windows 2000 SP3 ist die Datei "Msgina.dll" von der Datei "Mpr.dll" abhängig. Die Datei "Mpr.dll" erfordert den folgenden Registrierungsschlüssel zur Initialisierung:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NetworkProvider\HwOrder
Dieser Schlüssel wird erstellt, wenn die Datei "Services.exe" gestartet wird. Da die Datei "Winlogon.exe" gleichzeitig mit der Datei "Services.exe" gestartet wird, fragt Winlogon den Registrierungsschlüssel "Mpr.dll" möglicherweise ab, bevor dieser von der Datei "Services.exe" erstellt wurde. In diesem Fall wird die Datei "Msgina.dll" nicht geladen, und die folgende, im Abschnitt "Problembeschreibung" dieses Artikels beschriebene Fehlermeldung wird angezeigt. In Windows 2000 Service Pack 2 (SP2) gibt es diese Abhängigkeit nicht.

Lösung

Service Pack-Informationen

Installieren Sie das neueste Service Pack für Microsoft Windows 2000, um dieses Problem zu beheben. Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/DE/ ) Wie Sie das neueste Service Pack für Windows 2000 erhalten

Hotfix-Informationen

Ein Update zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich; dieses Update wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt. Das Update sollte daher nur bei Computern angewandt werden, bei denen dieses spezielle Problem auftritt. Dieses Update wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft, auf das nächste Windows 2000 Service Pack zu warten, das dieses Update enthält.

Wenn Sie das Problem sofort beheben möchten, wenden Sie sich an Microsoft Product Support Services, um das Update zu erhalten.

Sie finden die Telefonnummern des technischen Supports unter:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Die englische Version dieses Updates weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Die Abweichung zwischen UTC-Zeit und lokaler Zeit können Sie im Systemsteuerungsprogramm Datum/Uhrzeit mithilfe der Registerkarte Zeitzone ermitteln.
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   15-Oct-2002  18:53  5.0.2195.6090  332,560  Msgina.dll


Sie müssen den Computer starten können und Windows 2000 öffnen können, um dieses Update anzuwenden. Sie benötigen Zugriff auf einen anderen Windows 2000 SP2-Computer sowie auf eine leere, formatierte 3,5-Zoll-Diskette.

Öffnen Sie Windows 2000, und wenden Sie den Hotfix an, um dieses Problem zu beheben:
  1. Legen Sie eine leere, formatierte 3,5-Zoll-Diskette in das Diskettenlaufwerk eines zweiten Windows 2000 SP2-Computers ein.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie den Befehl cmd ein, und klicken Sie anschließend auf OK.
  3. Geben Sie an der Eingabeaufforderung die folgenden Befehle ein, und drücken Sie anschließend nach jedem Befehl die [EINGABETASTE]:
    C:
    CD \
    CD \WINNT\system32\dllcache
    COPY msgina.dll A:
  4. Entnehmen Sie die 3,5-Zoll-Diskette aus dem Diskettenlaufwerk.
  5. Starten Sie den Computer, auf dem das im Abschnitt "Problembeschreibung" beschriebene Problem auftritt, und starten Sie anschließend die Wiederherstellungskonsole. Wenn Sie die Wiederherstellungskonsole nicht als Startoption installiert haben, gehen Sie folendermaßen vor:
    1. Legen Sie die Windows 2000 Server-Installationsdiskette 1 in das Diskettenlaufwerk ein, oder legen Sie die Windows 2000 Server-CD-ROM in das startfähige CD-ROM-Laufwerk (falls vorhanden) ein.
    2. Starten Sie den Computer neu.
    3. Befolgen Sie die Anweisungen auf dem Bildschirm. Wenn Sie die Setup-Disketten, werden Sie jeweils dazu aufgefordert, die nächste Setup-Diskette in das Diskettenlaufwerk einzulegen. Es kann einige Minuten dauern, bis alle Dateien eingelesen sind.
    4. Wählen Sie die geeigneten Optionen zur Wiederherstellung der Windows 2000-Installation und zum Starten der Wiederherstellungskonsole.
  6. Geben Sie an der Eingabeaufforderung der Wiederherstellungskonsole die folgenden Befehle ein, und drücken Sie nach jedem Befehl die [EINGABETASTE]:
    CD system32
    REN msgina.dll mdgina.old
    CD dllcache
    REN msgina.dll msgina.old
    Hinweis: Wenn die Datei "Msgina.dll" nicht im Ordner "System32" oder im Ordner "Dllcache" vorhanden ist, fahren Sie mit Schritt 7 fort.
  7. Legen Sie die 3,5-Zoll-Disektte mit der Datei "Msgina.dll" des zweiten Windows 2000 SP2-Computers in das Diskettenlaufwerk des Computers ein, auf dem das im Abschnitt "Problembeschreibung" beschriebene Problem auftritt.
  8. Geben Sie an der Eingabeaufforderung der Wiederherstellungskonsole die folgenden Befehle ein, und drücken Sie anschließend nach jedem Befehl die [EINGABETASTE]:
    COPY a:\msgina.dll
    CD ..
    COPY a:\msgina.dll
    exit
  9. Starten Sie den Computer neu, und wenden Sie den Hotfix an.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den oben genannten Microsoft-Produkten handelt. Dieses Problem wurde erstmals in Microsoft Windows 2000 Service Pack 4 behoben.

Weitere Informationen

Weitere Informationen dazu, wie Sie Hotfixes für Windows 2000 Datacenter Server erhalten können, finden Sie in folgendem Artikel der Microsoft Knowledge Base:
265173  (http://support.microsoft.com/kb/265173/DE/ ) Das Datacenter-Programm und das Windows 2000 Datacenter Server-Produkt
Weitere Informationen über die Verwendung der Wiederherstellungskonsole finden Sie in folgendem Artikel der Microsoft Knowledge Base:
301645  (http://support.microsoft.com/kb/301645/DE/ ) SO WIRD'S GEMACHT: Wiederherstellung eines Servers unter Windows 2000, der nicht mehr gestartet werden kann
Keywords: 
kbqfe kbhotfixserver kbsecurity kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB329316
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store
Folgen Sie uns: