DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 834427 - Geändert am: Montag, 19. März 2007 - Version: 2.1

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
834427  (http://support.microsoft.com/kb/834427/EN-US/ ) The Remove Hidden Data tool for Office 2003 and Office XP
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Zusammenfassung

Das Add-In zum Entfernen verborgener Daten ist ein Tool, mit dem persönliche oder verborgene Daten entfernt werden können, die bei der Anzeige von Dokumenten in einem Microsoft Office-Programm nicht sofort sichtbar sind.

Sie können das Add-In zum Entfernen verborgener Daten in Ihrem Microsoft Office XP-Programm oder Microsoft Office 2003-Programm für einzelne Dateien ausführen. Alternativ können Sie das Add-In zum Entfernen verborgener Daten an der Befehlszeile auch gleichzeitig für mehrere Dateien ausführen. In beiden Fällen muss zum Ausführen des Tools das Programm installiert sein, mit dem das Dokument erstellt wurde.

Weitere Informationen zum Add-In-Tool zum Entfernen verborgener Daten und dazu, wie Sie es erhalten können, finden Sie auf folgender Website von Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=144e54ed-d43e-42ca-bc7b-5446d34e5360 (http://www.microsoft.com/downloads/details.aspx?displaylang=de&FamilyID=144e54ed-d43e-42ca-bc7b-5446d34e5360)
Weitere Informationen zu bekannten Problemen und Themen, die nicht in der Readme-Datei behandelt werden, finden Sie in folgenden Artikeln der Microsoft Knowledge Base:
834636  (http://support.microsoft.com/kb/834636/DE/ ) Bekannt Probleme mit der Add-In-Version 1.0 Remove Hidden Data für Office 2003 und Office XP
842684  (http://support.microsoft.com/kb/842684/DE/ ) Bekannt Probleme mit der Add-In-Version 1.1 Remove Hidden Data für Office 2003 und Office XP

Gehen Sie folgendermaßen vor, um die auf Ihrem Computer installierte Version des Tools zum Entfernen verborgener Daten zu ermitteln:
  1. Klicken Sie auf Start und anschließend auf Systemsteuerung.
  2. Klicken Sie auf Software.
  3. Klicken Sie in der Liste der aktuell installierten Programme auf Tool zum Entfernen verborgener Daten und anschließend auf Klicken Sie hier, um Supportinformationen zu erhalten.
  4. Anhand der folgenden Tabelle können Sie die installierte Version des Tools zum Entfernen verborgener Daten ermitteln.

    Tabelle minimierenTabelle vergrößern
    Freigegebene VersionVersion
    Tool zum Entfernen verborgener Daten 1.111.0.6361.0
    Tool zum Entfernen verborgener Daten 1.06.00.2600.0000

Weitere Informationen

Im Folgenden finden Sie die Readme-Datei für das Add-In zum Entfernen verborgener Daten. Nach der Installation des Add-Ins zum Entfernen verborgener Daten befindet sich diese Readme-Datei in folgendem Ordner:
Pfad\Programme\Microsoft Office\Remove Hidden Data Tool\1031

Microsoft Office 2003-Readme-Datei: Add-In zum Entfernen verborgener Daten

© 2003 Microsoft Corporation. Alle Rechte vorbehalten.

Dieses Dokument enthält aktuelle Informationen über das Microsoft Office 2003-Add-In zum Entfernen verborgener Daten. Im Abschnitt "Inhalt" sind alle in dieser Datei enthaltenen Informationen aufgeführt. Aktuelle Informationen für ein einzelnes Office System-Produkt finden Sie in der Readme-Datei für das jeweilige Produkt.

Das Tool zum Entfernen verborgener Daten ist ein Add-In für die Microsoft Office 2003-Editionen oder für Microsoft Office XP, mit dessen Hilfe Benutzer verborgene Daten und Kooperationsdaten endgültig aus Microsoft Word-, Microsoft Excel- und Microsoft PowerPoint-Dateien entfernen können.

Verwenden dieses Dokuments

Maximieren Sie das Fenster Ihres Browsers, um die Readme-Datei im Bildschirmfenster anzuzeigen. Klicken Sie auf der Symbolleiste auf die Schaltfläche Drucken, um die Readme-Datei zu drucken.

Inhalt

Überblick

Wenn Sie ein Office-Dokument auf elektronischem Weg weitergeben, enthält das Dokument möglicherweise Informationen, die Sie nicht veröffentlichen möchten, z. B. Informationen für die Zusammenarbeit beim Verfassen und Bearbeiten des Dokuments oder verborgene Informationen, mit denen die verschiedenen Bearbeiter des Dokuments verwaltet werden.

Das Add-In zum Entfernen verborgener Daten ist ein Tool, mit dem persönliche oder verborgene Daten entfernt werden können, die bei der Anzeige von Dokumenten in einer Microsoft Office-Anwendung nicht sofort sichtbar sind.

Sie können das Add-In zum Entfernen verborgener Daten in einer Office XP- oder Office System 2003-Anwendung für einzelne Dateien ausführen. Sie können es aber auch an der Befehlszeile für mehrere Dateien ausführen. In beiden Fällen muss die Anwendung installiert sein, mit der das Dokument erstellt wurde, damit das Tool ausgeführt werden kann.

Hinweise:

Führen Sie das Add-In zum Entfernen verborgener Daten kurz vor der Veröffentlichung von Dateien aus. Einige der mit dem Tool entfernten Informationen werden von Office-Features für die Zusammenarbeit verwendet, z. B. zum Nachverfolgen von Änderungen, für Kommentare und zum Senden zur Durchsicht. Nachdem das Add-In zum Entfernen verborgener Daten ausgeführt wurde, funktionieren die Features für die Zusammenarbeit nicht mehr.

Mit dem Add-In zum Entfernen verborgener Daten werden bestimmte Datentypen automatisch und ohne Bestätigung endgültig aus Office-Dateien entfernt. Standardmäßig werden Sie aufgefordert, die Datei unter einem neuen Namen zu speichern.

Speichern Sie die Datei immer unter einem neuen Namen, anstatt die ursprüngliche Datei zu überschreiben. So behalten Sie stets eine Kopie des Dokuments mit den ursprünglichen Daten.

Wenn Sie die Sprache ändern möchten, die das Add-In zum Entfernen verborgener Daten verwendet, müssen Sie das Add-In deinstallieren und es anschließend in der gewünschten Sprachversion neu herunterladen. Nachdem Sie das Add-In in der neuen Sprachversion installiert haben, ersetzt es die ursprüngliche Sprachversion. Alle Kopien des Add-Ins zum Entfernen verborgener Daten enthalten, unabhängig von ihrer Sprachversion, eine englischsprachige Version zur Unterstützung des Befehlszeilentools.

Es ist nicht möglich, mit dem Tool verborgene Daten aus den folgenden Dateitypen zu entfernen:
  • Dokumente, die Berechtigungen zum Verwalten von Informationsrechten verwenden
  • Geschützte Dokumente
  • Digital signierte Dokumente
  • Freigegebene Arbeitsmappen
Wenn Sie versuchen, das Tool für eine Datei auszuführen, die mindestens eine der genannten Bedingungen erfüllt, wird der Vorgang abgebrochen und eine Fehlermeldung angezeigt. Die ursprüngliche Datei wird nicht verändert.

Systemvoraussetzungen

Unterstützte Betriebssysteme: Microsoft Windows XP SP1 oder höher, Microsoft Windows 2000 SP4 oder höher oder Microsoft Windows Server 2003

Dieser Download kann mit folgenden Office-Anwendungen verwendet werden:
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002 SP2 oder höher
  • Microsoft Excel 2002 SP2 oder höher
  • Microsoft PowerPoint 2002 SP2 oder höher
Damit Sie das Add-In ausführen können, muss die Anwendung installiert sein, mit der das Dokument erstellt wurde. Außerdem muss die installierte Office-Version mindestens der Version des Dokuments entsprechen, für das Sie das Tool zum Entfernen verborgener Daten ausführen möchten. Beispielsweise können Sie das Tool unter Verwendung von Office 2003 für ein Office 2000-Dokument ausführen, nicht jedoch unter Verwendung von Office XP für ein Office 2003-Dokument.

Das Tool kann für Word-Dokumente, Excel-Arbeitsmappen und PowerPoint-Präsentationen sowie für in Word, Excel und PowerPoint erstellte Webseiten und Webseiten in einer Datei verwendet werden. Andere Dokumentformate werden nicht unterstützt.

Datentypen, die mit dem Add-In entfernt werden können

Die folgenden Datentypen werden automatisch entfernt:
  • Kommentare
  • Frühere Autoren und Bearbeiter
  • Benutzername
  • Persönliche Zusammenfassungsinformationen
  • Überarbeitungsmarkierungen. Das Tool nimmt alle im Dokument enthaltenen Überarbeitungen an. Der Inhalt des Dokuments entspricht dann der Ansicht Endgültige Version enthält Markups auf der Symbolleiste Überarbeiten.
  • Gelöschter Text. Diese Daten werden automatisch entfernt.
  • Versionen
  • VB-Makros. Beschreibungen und Kommentare werden aus den Modulen entfernt.
  • Die ID-Nummer zur Bezeichnung des Dokuments für das spätere Zusammenführen von Änderungen im Originaldokument.
  • Verteiler
  • E-Mail-Header
  • Kommentare zu Szenarien
  • Eindeutige Bezeichner (nur Office 97-Dokumente)
Hinweis: Das Tool zum Entfernen verborgener Daten aktiviert außerdem das Feature zum Entfernen persönlicher Daten. Weitere Informationen zu diesem Feature finden Sie in der Anwendungshilfe unter dem Suchbegriff "Entfernen persönlicher Informationen".

Bekannte Probleme

  • Excel: In Excel 2002 werden die Druckerpfade nicht entfernt, in Excel 2003 hingegen schon.
  • Excel: Verknüpfungen zu unterstützenden externen Arbeitsmappen werden bei Excel-Webseiten in einer Datei möglicherweise nicht entfernt.
  • Wenn das Add-In zum Entfernen verborgener Daten unerwartet beendet wird, wird möglicherweise ein leeres Editor-Fenster angezeigt und im temporären Verzeichnis eine Protokolldatei gespeichert. Klicken Sie im Editor auf Datei und dann auf Beenden, um das Editor-Fenster zu schließen. Löschen Sie den Inhalt des temporären Verzeichnisses in Ihrem lokalen Einstellungsordner, um die Protokolldatei zu entfernen.
  • Wenn Sie das Add-In zum Entfernen verborgener Daten schließen, bevor die Bearbeitung eines Dokuments abgeschlossen wurde, verbleiben möglicherweise temporäre Dateien im Zielverzeichnis. Sie können diese Dateien entfernen, indem Sie sie aus dem Zielverzeichnis löschen.
  • Webseiten in einer Datei, die mit dem Tool überarbeitet wurden, enthalten möglicherweise den Namen einer zufällig erzeugten temporären Datei im Format "file:///c:/<Nummer>/". Die im Namen verwendete Nummer basiert auf dem Dateinamen der Webseite in einer Datei und kann nicht zu Ihrem Computer zurückverfolgt werden.
  • In Word-Dateien vorhandene verborgene Zufallszahlen zur Erhöhung der Präzision beim Zusammenführen werden nicht entfernt.
  • Wenn das Add-In zum Entfernen verborgener Daten an der Befehlszeile ausgeführt wird, funktioniert es für in Word, Excel oder PowerPoint erstellte XML-Dokumente nicht.

Grundlegende Verwendung

Nachdem Sie das Add-In zum Entfernen verborgener Daten installiert haben, öffnen Sie das Dokument, das Sie überprüfen möchten, und klicken Sie dann im Menü Datei auf Verborgene Daten entfernen.

Hinweis: Wenn im Menü Datei der Befehl Verborgene Daten entfernen nicht angezeigt wird, überprüfen Sie Folgendes:
  1. Klicken Sie im Menü Extras auf Optionen und anschließend auf die Registerkarte Sicherheit.
  2. Klicken Sie unter Makrosicherheit auf Makrosicherheit.
  3. Klicken Sie auf die Registerkarte Vertrauenswürdige Herausgeber.
  4. Aktivieren Sie das Kontrollkästchen Allen installierten Add-Ins und Vorlagen vertrauen, und klicken Sie dann zweimal auf OK.
Nachdem Sie den Dateinamen angegeben haben, entfernt das Tool automatisch die angegebenen verborgenen Daten. Weitere Informationen finden Sie unter Datentypen, die mit dem Add-In entfernt werden können.

Hinweise:

Speichern Sie die Datei immer unter einem neuen Namen, anstatt die ursprüngliche Datei zu überschreiben. So behalten Sie stets eine Kopie des Dokuments mit den ursprünglichen Daten.

Mit dem Add-In zum Entfernen verborgener Daten können Dokumente nicht als Vorlage gespeichert werden.

Befehlszeile

Gehen Sie folgendermaßen vor, um das Add-In zum Entfernen verborgener Daten an der Befehlszeile auszuführen:
  1. Beenden Sie alle Instanzen von Excel, Word, Outlook und PowerPoint, bevor Sie das Befehlszeilentool starten.
  2. Klicken Sie im Menü Start auf Ausführen.
  3. Geben Sie cmd ein, und drücken Sie dann die [EINGABETASTE].
  4. Wechseln Sie in das Verzeichnis, in dem sich die Datei "OFFRHD.EXE" befindet. Standardmäßig ist dies das Verzeichnis, in dem das Add-In zum Entfernen verborgener Daten installiert wurde.
  5. Geben Sie an der Befehlszeile die Syntax für die gewünschte Aufgabe ein.
Hinweise:

Die Anwendung, in der das Dokument erstellt wurde, ist zwar nicht sichtbar, wird aber im Hintergrund ausgeführt. Wenn die Anwendung ein Dialogfeld startet, wird das Add-In zum Entfernen verborgener Daten unterbrochen, bis das Dialogfeld geschlossen worden ist. Wenn das Dialogfeld länger als 120 Sekunden geöffnet bleibt, wird die Anwendung beendet und das Add-In zum Entfernen verborgener Daten setzt den Vorgang mit der nächsten Datei fort bzw. wird geschlossen, sobald die letzte Datei erreicht ist.

Geben Sie als Flag vor Parametern entweder einen Schrägstrich (/) oder einen Bindestrich (-) ein. Bei Flags muss die Groß- und Kleinschreibung nicht beachtet werden.

Wenn Sie mehrere Flags eingeben, wird nur das erste erkannt.

Sie müssen den Parameter "Quelle" zuerst eingeben. Darauf kann optional der Parameter "Ziel" folgen. Alle anderen Parameter können in beliebiger Reihenfolge angegeben werden.

Wenn Sie am Ende des Quellverzeichnisnamens einen Schrägstrich (/) eingeben, tritt im Tool ein Fehler auf.

Für "OFFRHD.EXE" gilt die folgende Syntax:
OFFRHD [/?] Quelle [Ziel] [/O] [/R] [/F:Dateityp] [/L: Protokolldatei] [/A]
Tabelle minimierenTabelle vergrößern
ParameterBeschreibung
QuelleZwingend erforderlich. Gibt das Laufwerk, das Verzeichnis und die Dateien an, aus denen Sie persönliche Informationen entfernen möchten. Kann jeder gültige, voll qualifizierte Pfadname sein.
ZielOptional. Gibt einen Speicherort für die überprüften Dateien an. Wenn Sie dieses Feld nicht angeben, werden alle Dateien im gleichen Verzeichnis mit einem Suffix für das aktuelle Datum gespeichert. Das Suffix "-C010503" bezeichnet beispielsweise den 5. Januar 2003. Wenn die Zieldatei bereits vorhanden ist, wird sie überschrieben.
/OGibt an, dass Sie nicht zum Bestätigen des Überschreibens einer vorhandenen Datei aufgefordert werden.
/RGibt an, dass die Inhalte des Quellverzeichnisses und aller Unterverzeichnisse überprüft werden.
/F:DateitypGibt das Format der Zieldateien an.
/F:HHTML-Format
/F:MMHTML-Format
/F:BBinärformat. Wenn Sie diesen Parameter nicht angeben, wird die Datei standardmäßig im gleichen Format wie die Quelldatei gespeichert.
/L:ProtokolldateiGibt einen Speicherort zum Speichern der Protokolldatei an. Wenn Sie diesen Parameter nicht angeben, wird das Protokoll angezeigt, sobald die Verarbeitung abgeschlossen ist.
/AGibt an, dass das Tool einen Bericht mit den in der Datei gefundenen Problemen generiert, aber keine Daten entfernt.
/:?Zeigt eine Liste aller verfügbaren Parameter an.

Protokolldatei

Wenn das Add-In zum Entfernen verborgener Daten die Überprüfung der Datei(en) abgeschlossen hat, werden in einer Protokolldatei die Ergebnisse der Überprüfung angezeigt. Sie können diese Datei speichern, wenn Sie später darauf zurückgreifen möchten.

Entfernen verborgener Daten bei Verwendung von IRM

In Office 2003 kann das Tool zum Entfernen verborgener Daten nicht für mit IRM (Information Rights Management, Verwaltung von Informationsrechten) geschützte Dokumente ausgeführt werden, es sei denn, Sie sind der Besitzer des Dokuments oder besitzen die Berechtigung zum Ändern mit der Option zum programmatischen Zugriff auf Inhalte.

Gehen Sie folgendermaßen vor, um die Berechtigung zum Ausführen des Tools zum Entfernen verborgener Daten für mit IRM geschützte Dokumente zu erteilen:
  1. Klicken Sie im Menü Datei auf Berechtigung, Berechtigung einschränken als.
  2. Wählen Sie das Benutzerkonto (in der Regel Ihr eigenes), um den Inhalt zu erstellen oder zu öffnen, und klicken Sie dann auf OK.
  3. Klicken Sie im Dialogfeld Berechtigung auf Weitere Optionen.
  4. Klicken Sie nun auf das Benutzerkonto, für das Sie den Zugriff ermöglichen möchten. (Das Benutzerkonto muss über die Berechtigung zum Ändern für das Dokument verfügen, damit das Tool zum Entfernen verborgener Daten verwendet werden kann.)
  5. Klicken Sie auf Auf Inhalt programmatisch zugreifen, und klicken Sie anschließend auf OK.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbcommandline kbconfig kbtooltip kbinfo KB834427
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store
Folgen Sie uns: