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Artikel-ID: 840669 - Geändert am: Freitag, 20. Juni 2008 - Version: 7.4

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
840669  (http://support.microsoft.com/kb/840669/EN-US/ ) Group Policy application fails on a computer that is running Windows 2000, Windows XP Service Pack 1, or Windows XP Service Pack 2
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

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Problembeschreibung

Wenn Sie Ihren Computer mit dem Betriebssystem Microsoft Windows 2000, Windows XP Service Pack 1 (SP1) oder Windows XP Service Pack 2 (SP2) in einem drahtgebunden oder drahtlosen Netzwerk mit 802.11-Authentifizierung starten, wird entweder die Gruppenrichtlinie nicht wie erwartet angewendet oder der Computer schließt sich dem Active Directory-Verzeichnisdienst nicht an.

In den Protokolldateien in der Ereignisanzeige sehen Sie die folgenden Einträge:
  • Ereigniskennung: 1054
    Quelle: Userenv
    Typ: Fehler
    Beschreibung: Der Domänencontrollername für das Computernetzwerk konnte nicht ermittelt werden. (Die angegebene Domäne ist nicht vorhanden oder es konnte keine Verbindung hergestellt werden.) Die Verarbeitung der Gruppenrichtlinie wird abgebrochen. Daten: (nicht verfügbar)

  • Ereigniskennung: 1000
    Quelle: UserInit
    Typ: Fehler
    Beschreibung: Folgendes Skript konnte nicht ausgeführt werden: AdminPassword.bat. Die angegebene Datei wurde nicht gefunden. Daten: (nicht verfügbar)

Außerdem können in der Datei "Userenv.log" die folgenden Einträge protokolliert sein:
  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available at startup. Retrying. (DC für Domäne <Domäne> beim Start nicht verfügbar. Vorgang wird wiederholt.)

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Enter.

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Failed to query GpNetworkStartTimeoutPolicyValue with 2, exit. (GpNetworkStartTimeoutPolicyValue konnte nicht mit 2 abgefragt werden, Beendigung.)

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Exit with status 1355. (Beendigung mit Status 1355).

  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available after retries. (DC für Domäne <Domäne> nach Wiederholungsversuchen nicht verfügbar).

  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available. Aborting (DC für Domäne <Domäne> nicht verfügbar. Abbruch.)

  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: No WMI logging done in this policy cycle. (Keine WMI-Protokollierung in diesem Richtlinienzyklus.)

  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: Processing failed with error 1355. (Verarbeitung mit Fehler 1355 gescheitert.)

Ursache

Dieses Problem kann auftreten, wenn für das Gruppenrichtlinienmodul oder Active Directory eine Zeitüberschreitung erfolgt, während diese Komponenten darauf warten, dass das Netzwerk gestartet wird. Zwischen TCP/IP-Protokoll und dem Netzwerkadaptertreiber kann es zu einem selten auftretenden Problem kommen, wenn diese Komponenten versuchen, sich bei Microsoft-NDIS (Network Driver Interface Specification) zu registrieren. Registriert sich das TCP/IP-Protokoll vor dem Netzwerkadaptertreiber bei NDIS, meldet es den Netzwerkkomponenten mit höherem Benutzermodus für einen kurzen Zeitraum, dass die Netzwerkverbindung nicht verfügbar ist. Während dieser kurzen Zeitspanne ist ein Herunterladen des Gruppenrichtlinien-Startskripts nicht möglich.

Eine höhere Wahrscheinlichkeit für das Auftreten dieses Problems besteht bei schnellen Netzwerken mit 1-GB-Netzwerkadaptern oder in Teamumgebungen, in denen das Netzwerk mehrere zusätzliche Zyklen durchläuft, um die Verbindungsgeschwindigkeit auszuhandeln.

Lösung

Windows 2000

Ein Hotfix zur Behebung des Problems ist bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste mit Telefonnummern der Kundenbetreuung bzw. des Support von Microsoft zu erhalten oder um eine separate Serviceanfrage zu erstellen:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix.

Voraussetzungen

Keine

Neustart

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen anderen Hotfix.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
   Datum        Zeit   Version        Größe      Dateiname
   ----------------------------------------------------------
   17.06.2004   23:05  5.0.2195.6951     46.352  Basesrv.dll
   21.09.2003   00:45  5.0.2195.6824    236.304  Cmd.exe
   17.06.2004   23:05  5.0.2195.6945    231.184  Gdi32.dll
   17.06.2004   23:05  5.0.2195.6946    712.464  Kernel32.dll
   24.03.2004   02:17  5.0.2195.6898     37.136  Mf3216.dll
   24.03.2004   02:17  5.0.2195.6824     54.544  Mpr.dll
   17.06.2004   23:05  5.0.2195.6928    335.120  Msgina.dll
   24.03.2004   02:17  5.0.2195.6892     90.264  Rdpwd.sys
   06.01.2005   04:29  5.0.2195.7017  6.278.656  Sp3res.dll
   24.03.2004   02:17  5.0.2195.6897    403.216  User32.dll
   18.01.2005   05:44  5.0.2195.7021    396.048  Userenv.dll
   10.08.2004   03:51  5.0.2195.6966  1.632.624  Win32k.sys
   24.08.2004   22:59  5.0.2195.6970    182.544  Winlogon.exe
   17.06.2004   23:05  5.0.2195.6946    244.496  Winsrv.dll
   17.06.2004   23:05  5.0.2195.6946    712.464  Kernel32.dll
   10.08.2004   03:51  5.0.2195.6966  1.632.624  Win32k.sys
   17.06.2004   23:05  5.0.2195.6946    244.496  Winsrv.dll  
Nach Anwendung des Hotfixes müssen Sie den Registrierungseintrag "GpNetworkStartTimeoutPolicyValue" hinzufügen. Dieser Eintrag legt die Anzahl an Sekunden fest, die abgewartet werden muss, bis Sie erneut versuchen können, das Gruppenrichtlinien-Startskript auszuführen. Um den besten Wert für Ihre Konfiguration zu ermitteln, legen Sie zunächst einen Dezimalwert von 60 fest, und steigern Sie dann diesen Wert schrittweise, bis das Problem behoben ist. Gehen Sie folgendermaßen vor, um den Registrierungseintrag hinzuzufügen und den Wert festzulegen:
  1. Klicken Sie auf Start und auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
  2. Erweitern Sie den folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Klicken Sie mit der rechten Maustaste auf Winlogon, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.
  4. Geben Sie den Namen GpNetworkStartTimeoutPolicyValue für den neuen Eintrag ein, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf GpNetworkStartTimeoutPolicyValue, und klicken Sie dann auf Ändern.
  6. Klicken Sie unter Basis auf Dezimal.
  7. Geben Sie im Feld Wert den Wert 60 ein, und klicken Sie anschließend auf OK.
  8. Beenden Sie den Registrierungs-Editor. Starten Sie anschließend den Computer neu.
  9. Falls das Gruppenrichtlinien-Startskript nicht ausgeführt wird, erhöhen Sie den Wert für den Registrierungseintrag "GpNetworkStartTimeoutPolicyValue".

Windows XP Service Pack 1

Ein Hotfix zur Behebung des Problems ist bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Falls der Hotfix zum Download zur Verfügung steht, finden Sie am Anfang dieses Knowledge Base-Artikels den Hinweis "Hotfix-Download ist verfügbar". Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste mit Telefonnummern der Kundenbetreuung bzw. des Support von Microsoft zu erhalten oder um eine separate Serviceanfrage zu erstellen:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix-Anfrage" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Falls Ihre Sprache nicht angezeigt wird, gibt es für diese Sprache (noch) keinen Hotfix. Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter "Datum und Uhrzeit" mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
Windows XP, 64-Bit-Versionen
   Datum        Zeit   Version        Größe      Dateiname     Plattform
   ---------------------------------------------------------------------
   04.06.2004   05:52  5.1.2600.1534  1.718.272  Userenv.dll   IA-64
   04.06.2004   05:44  5.1.2600.1534    672.256  Wuserenv.dll  x86
Windows XP, 32-Bit-Versionen
   Datum        Zeit   Version        Größe    Dateiname
   -------------------------------------------------------
   04.06.2004   05:44  5.1.2600.1534  672.256  Userenv.dll
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base::
322756  (http://support.microsoft.com/kb/322756/DE/ ) Unter Windows XP und Windows Server 2003 eine Sicherungskopie der Registrierung erstellen und die Registrierung bearbeiten und wiederherstellen


Nachdem Sie diesen Hotfix installiert haben, müssen Sie den Registrierungseintrag GpNetworkStartTimeoutPolicyValue hinzufügen. Dieser Eintrag legt die Anzahl an Sekunden fest, die abgewartet werden muss, bis erneut versucht wird, das Gruppenrichtlinien-Startskript auszuführen. Um den besten Wert für Ihre Konfiguration zu ermitteln, legen Sie zunächst einen Dezimalwert von 60 fest, und steigern Sie dann diesen Wert schrittweise, bis das Problem behoben ist. Gehen Sie folgendermaßen vor, um den Registrierungseintrag hinzuzufügen und den Wert festzulegen:
  1. Klicken Sie auf Start, auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
  2. Erweitern Sie den folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Klicken Sie mit der rechten Maustaste auf Winlogon, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.
  4. Geben Sie den Namen GpNetworkStartTimeoutPolicyValue für den neuen Eintrag ein, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf GpNetworkStartTimeoutPolicyValue, und klicken Sie dann auf Ändern.
  6. Klicken Sie unter Basis auf Dezimal.
  7. Geben Sie im Feld Wert den Wert 60 ein, und klicken Sie auf OK.
  8. Beenden Sie den Registrierungs-Editor, und starten Sie anschließend den Computer neu.
  9. Falls das Gruppenrichtlinien-Startskript nicht ausgeführt wird, erhöhen Sie den Wert für den Registrierungseintrag GpNetworkStartTimeoutPolicyValue.

Windows XP Service Pack 2

Nachdem Sie Windows XP Service Pack 2 angewendet haben, müssen Sie den Registrierungseintrag GpNetworkStartTimeoutPolicyValue hinzufügen. Dieser Eintrag legt die Anzahl an Sekunden fest, die abgewartet werden muss, bis erneut versucht wird, das Gruppenrichtlinien-Startskript auszuführen. Um den besten Wert für Ihre Konfiguration zu ermitteln, legen Sie zunächst einen Dezimalwert von 60 fest, und steigern Sie dann diesen Wert schrittweise, bis das Problem behoben ist. Gehen Sie folgendermaßen vor, um den Registrierungseintrag hinzuzufügen und den Wert festzulegen:
  1. Klicken Sie auf Start, auf Ausführen, geben Sie regedit ein, und klicken Sie auf OK.
  2. Erweitern Sie den folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Klicken Sie mit der rechten Maustaste auf Winlogon, zeigen Sie auf Neu, und klicken Sie dann auf DWORD-Wert.
  4. Geben Sie den Namen GpNetworkStartTimeoutPolicyValue für den neuen Eintrag ein, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie mit der rechten Maustaste auf GpNetworkStartTimeoutPolicyValue, und klicken Sie dann auf Ändern.
  6. Klicken Sie unter Basis auf Dezimal.
  7. Geben Sie im Feld Wert den Wert 60 ein, und klicken Sie auf OK.
  8. Beenden Sie den Registrierungs-Editor, und starten Sie anschließend den Computer neu.
  9. Falls das Gruppenrichtlinien-Startskript nicht ausgeführt wird, erhöhen Sie den Wert für den Registrierungseintrag GpNetworkStartTimeoutPolicyValue.

Festlegen eines Zeitüberschreitungswerts für eine Gruppenrichtlinie zum Netzwerkstart

Der Zeitüberschreitungswert für GpNetworkStartTimeoutPolicyValue kann an zwei Speicherorten in der Registrierung festgelegt werden:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System
Sie können dies tun, indem Sie einen DWORD-Wert "GpNetworkStartTimeoutPolicyValue" mit einer Anzahl von Sekunden zwischen 30 und 600 hinzufügen.

Windows liest zuerst den Unterschlüssel "Winlogon" und anschließend den Unterschlüssel "Policies". Der Wert im Unterschlüssel "Policies" ersetzt die vorhandenen Werte im Unterschlüssel "Winlogon". Es gibt keine Benutzeroberfläche, über die Sie dieses Gruppenrichtlinienobjekt einstellen können. Sie müssen deshalb eine benutzerdefinierte ADM-Datei bereitstellen, um das Gruppenrichtlinienobjekt einzustellen.

Der festgelegte Wert sollte ausreichend groß sein, um sicherzustellen, dass die Verbindung aufgebaut wird. Während der Zeitüberschreitungsperiode überprüft Windows den Verbindungsstatus alle zwei Sekunden und setzt den Systemstart fort, sobald die Verbindung bestätigt ist. Es wird daher empfohlen, einen Wert festzulegen, der größer ist als der Mindestwert von 30 Sekunden. Beachten Sie jedoch, dass Windows während der gesamten Zeitüberschreitungsperiode keine weiteren Aktionen ausführt, wenn die Verbindung des Systems aus guten Gründen getrennt wird.

Hinweis: Derartige gute Gründe gelten auch als gegeben, wenn das Netzwerkkabel abgezogen wird oder der Server offline ist.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Hinweis: Dieses Problem tritt bekanntermaßen auf Toshiba Dynabook-Laptops auf, die einen Intel-Netzwerkadapter verwenden. Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Informationsquellen

Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/DE/ ) Erläuterung von Standardbegriffen bei Microsoft Software Updates
Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Professional SP1
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