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Artikel-ID: 885353 - Geändert am: Dienstag, 20. Mai 2008 - Version: 4.1

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Problembeschreibung

Wenn eine Verbindung Microsoft Windows Media Player 9-Reihe für Windows in einen Stream mit einem authentifizierten Proxy herstellt, möglicherweise der Windows Media Player-Client zur Eingabe der Anmeldeinformationen aufgefordert. Dieses Problem kann auftreten, wenn Windows Media Player 9-Reihe für Windows-Protokoll-Daten zurück an den Server sendet. Dieses Problem kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • Windows Media Player fallen am Ende eines Streams.
  • Windows Media Player oder der Benutzer sucht, oder in der Datei wird übersprungen.
  • Windows Media Player oder der Benutzer manuell den Datenstrom beendet oder unterbricht den Stream.

Ursache

Je nach Typ des streaming, dass Windows Media Player 9-Reihe für Windows verwendet kann es versucht, die Protokolle senden, indem mithilfe des HTTP-Protokolls. Standardmäßig versucht Windows Media Player 9-Reihe für Windows HTTP 1.1 zu verwenden. Allerdings kann manchmal Windows Media Player 9-Reihe für Windows über HTTP 1.0. Abhängig von Proxy-spezifische Implementierungen von HTTP 1.0-Spezifikation können Windows Media Player 9-Reihe für Windows aufgefordert werden, Anmeldeinformationen anzugeben.

Lösung

Ein unterstützter Hotfix ist inzwischen von Microsoft. Es ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Wenden Sie es nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Sie durch dieses Problem nicht schwerwiegend betroffen sind, empfiehlt Microsoft daher, auf die nächste Version zu warten, das diesen Hotfix enthält.

Dieses Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services, um den Hotfix zu erhalten. Eine vollständige Liste mit Telefonnummern der Microsoft Product Support Services und Informationen über Supportkosten der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: PLEASE DO NOT TRANSLATE and DELETE THIS PASSAGE. IT DOES NOT APPLY TO GERMANY.

Windows Media Player 9-Reihe für Microsoft Windows XP

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Download the WindowsXP-KB885353-v4-x86-enu.exe package now. (http://download.microsoft.com/download/9/4/4/9443cfc5-d7f8-4ec6-ba58-5705e890ff77/windowsxp-kb885353-v4-x86-enu.exe)

Windows Media Player 9-Reihe für Microsoft Windows 2000 und Microsoft Windows Server 2003

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Download the WindowsMedia9-KB885353-v5-x86-INTL.exe package now. (http://download.microsoft.com/download/e/a/2/ea284623-613a-4dd0-bf08-3edd3e13fbca/windowsmedia9-kb885353-v5-x86-intl.exe)

Windows Media Player 9-Reihe für Microsoft Windows Server 2003, Japanisch

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:

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Download the WindowsMedia9-KB885353-x86-JPN.exe package now. (http://download.microsoft.com/download/8/4/3/843f8926-d783-4879-9f7f-27cd4145ecb1/windowsmedia9-kb885353-x86-jpn.exe)

Windows Media Player 10

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
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Download the WindowsMedia10-KB885353-x86-ENU.exe package now. (http://download.microsoft.com/download/0/7/b/07bedf3a-39db-4fcf-ab95-85b57f90ac7d/windowsmedia10-kb885353-x86-enu.exe) Weitere Informationen zum Microsoft Support-Dateien herunterladen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) So erhalten Sie Dateien vom Microsoft Support im Internet
Microsoft hat diese Datei auf Viren überprüft. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei wird auf Servern mit verstärkter Sicherheit gespeichert, nicht autorisierte Änderungen an der Datei verhindert.

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
 Date         Time   Version      Size       File name 
-------------------------------------------------------------- 
 11-Oct-2004  13:15  9.0.0.3260   1,053,184  Wmnetmgr.dll (Windows Media Player 9 Series, all operating systems) 
 01-Mar-2005  11:19  10.0.0.3904  1,027,584  Wmnetmgr.dll (Windows Media Player 10)

Status

Microsoft hat bestätigt, dass dies einen Fehler in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Warnung Dieser Artikel enthält Informationen zum Bearbeiten des Namespaces. Bevor Sie den Namespace bearbeiten, stellen Sie sicher, dass Sie eine Sicherungskopie, die Sie wiederherstellen können haben, wenn ein Problem auftritt. Wenn Sie den Namespace falsch bearbeiten, können Sie schwerwiegende Probleme verursachen, erforderlich machen können Sie jedes Produkt installieren, der den Namespace verwendet. Microsoft kann nicht garantieren, dass Probleme, wenn Sie den Namespace falsch bearbeiten herrühren, behoben werden können. Bearbeiten Sie den Namespace auf eigenes Risiko.

Gehen Sie folgendermaßen vor um dieses Update zu deaktivieren:
  1. Windows Media Player 9-Reihe finden Sie das folgende Verzeichnis, in denen der Clientnamespace befindet:

    C:\Dokumente und Einstellungen Settings\%username%\Local Einstellungen\Anwendungsdaten\Microsoft\Windows Media\9.0

    Windows Media Player 10 finden Sie das folgende Verzeichnis, in denen der Clientnamespace befindet:

    C:\Dokumente und Einstellungen Settings\%username%\Local Einstellungen\Anwendungsdaten\Microsoft\Windows Media\10.0
  2. Öffnen Sie die Wmsdkns.xml-Datei in einem Texteditor wie Editor.
  3. Suchen Sie den Den Quelle -Knoten im Namespace.
  4. Suchen Sie den Object Store Knoten unter dem Knoten Der Quelle .
  5. Suchen Sie den WMS HTTP der Source -Knoten unter dem Knoten Objekt speichern .
  6. Suchen Sie den Eigenschaften -Knoten unter dem Knoten LAGERVERWALTUNG HTTP der Quelle .
  7. Im folgenden Codebeispiel wird unter den Knoten Eigenschaften hinzufügen.
    <node name="SendPostProxyKeepAlive" opcode="create" type="int32" value="0x0" />

Dieser Namespace-Wert kann eine der folgenden Werte haben:
  • 0 x 0 - Deaktivieren des Updates
  • 0 x 1 - aktivieren Sie das Update (Standard)

Im folgenden Codebeispiel ist eine andere Darstellung der Wert, den Sie in der Datei Wmsdkns.xml festlegen können.
<node name="Network Source" opcode="create">
    ...
    <node name="Object Store" opcode="create">
        ...
        <node name="WMS Http Network Source" opcode="create">
            ...
            <node name="Properties" opcode="create">
                ...
                <node name="SendPostProxyKeepAlive" opcode="create" type="int32" value="0x0" />
            </node> <!--  Properties -->
            ...
        </node> <!--  WMS Http Network Source -->
        ...
    </node> <!--  Object Store -->
    ...
</node><!--  Network Source -->

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Media Player 9 Series
  • Windows Media 9 Series Software Development Kit
  • Microsoft Windows Media Player 10
Keywords: 
kbmt kbtshoot kbfix kbqfe kbhotfixserver KB885353 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 885353  (http://support.microsoft.com/kb/885353/en-us/ )
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