DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 894472 - Geändert am: Mittwoch, 29. August 2007 - Version: 4.3

Hotfix-Download ist verfügbar
Hotfix-Downloads anzeigen und anfordern
 
 
Ein Microsoft Windows Server 2003 Service Pack 1-Version dieses Artikels finden Sie unter 912570  (http://support.microsoft.com/kb/912570/ ) .

Auf dieser Seite

Problembeschreibung

Einige Programme von Drittanbietern führen Sie nach der Installation von Microsoft Windows XP Service Pack 2 (SP2) nicht. Wenn dieses Symptom auftritt, erhalten Sie eine Fehlermeldung, die eine der folgenden ähnelt:
Es ist nicht genügend Speicher vorhanden
Nicht genuegend Arbeitsspeicher
Nicht genügend Speicher

Ursache

Dieses Problem, wenn das Fremdanbieterprogramm viel fortlaufenden Speicher reservieren. Beispielsweise tritt das Problem Wenn die Fremdanbieter-Programm mehrere Hundert MB zusammenhängenden Speicher reservieren. Die neue Xpsp2res.DLL-Datei, die in Windows XP SP2 hinzugefügt wird in den Speicher an Position 0 x 20000000 geladen. Dadurch wird der virtuelle Speicher, die das Programm eines Fremdanbieters fragmentiert werden zur Verfügung steht.

Lösung

Hotfix-Informationen

wichtig Dieser Hotfix enthält eine neue Xpsp2res.DLL-Datei, die dynamisch findet eine Speicheradresse Fragmentierung des virtuellen Speichers zu reduzieren. Bevor Sie diesen Hotfix angewendet haben, empfiehlt Microsoft bitten, den Hersteller Ihrer Programme, um sicherzustellen, dass diese Lösung akzeptabel ist.

Dieser Hotfix ermöglicht die neue Xpsp2res.DLL-Datei, suchen eine Speicheradresse dynamisch und Verringern der Fragmentierung des virtuellen Speichers.

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Windows XP Service Pack 2 muss installiert sein, bevor Sie den Hotfix installieren.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie den Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Apr-2005  00:17  5.1.2600.2653   2,897,920  Xpsp2res.dll

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Dieses Problem tritt nicht in allen Programmen, die viel fortlaufenden Speicher reservieren.

Die Datei Xpsp2res.dll ist auch enthalten einige Hotfixes, die für Windows XP Service Pack 1 und nach der Veröffentlichung von Windows XP SP2 veröffentlicht wurden. Allerdings tritt dieses Problem nicht mit der Version der Datei Xpsp2res.dll auf, die in diese Hotfixes enthalten ist.

Weitere Informationen zu den Bedingungen, die zum Beschreiben von Softwareupdates verwendet werden, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition
Keywords: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbwinxpsp2fix kbfix kbbug kbpubtypekc KB894472 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 894472  (http://support.microsoft.com/kb/894472/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store
Folgen Sie uns: