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Artikel-ID: 902409 - Geändert am: Donnerstag, 15. November 2007 - Version: 4.6

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Sollten Sie die Registrierung sichern, bevor Sie Sie ändern. Stellen Sie sicher, dass Sie die Registrierung wiederherstellen kennen, wenn ein Problem auftritt. Weitere Informationen zum Sichern, Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Beschreibung der Microsoft Windows-Registrierung

Auf dieser Seite

Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Der Webserver verwendet den HTTP-Aushandlung Authorization-Header, um Clients auf einer Website zu authentifizieren.
  • Sie verwenden Microsoft Internet Explorer 6, um diese Website von einem Clientcomputer zugreifen.
  • Sie werden aufgefordert, den Benutzernamen und das Kennwort eingeben.
  • Nachdem Sie den Benutzernamen und das Kennwort eingeben, und klicken Sie dann auf OK , erhalten Sie eine Forms Based Authentication HTML-Seite, die ein Web Form enthält. Dieses Webformular enthält ein Feld für Benutzernamen und ein Kennwortfeld. Die Seite enthält auch eine Meldung, dass der Server NTLM-Authentifizierung verweigert.
  • Sie geben Sie den Benutzernamen und das Kennwort im Webformular, und senden Sie das Web Form.
In diesem Szenario wird das Webformular nicht den Benutzernamen und das Kennwort für den Webserver senden.

Ursache

Dieses Problem rührt von Datei "Wininet.dll" verhindert, dass die Daten gesendet werden, wenn der Client NTLM-Authentifizierung verwendet und der Server eine Antwort SPNEGO Simple and Protected GSSAPI Aushandlung von () erwartet.

Wenn Sie den Benutzernamen und das Kennwort zum ersten Mal senden, wird die Datei "Wininet.dll" auf dem Clientcomputer eine NTLM-Antwort an der Negotiate Authorization-Header hinzugefügt. Wenn der Server eine SPNEGO-Antwort erwartet, kann der Server eine Antwort, die nicht senden "401 Zugriff verweigert." Da die Antwort nicht "401 Zugriff verweigert" ist, nimmt Wininet.dll fälschlicherweise, dass die Authentifizierung erfolgreich war. Wenn Wininet.dll voraussetzt, dass eine erfolgreiche Authentifizierung aufgetreten ist, entfernt Wininet.dll die Authentifizierungsdaten, dass es gespeichert und ist nicht die Daten erneut.

Lösung

Windows XP

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.
Voraussetzungen
Um diesen Hotfix installieren, muss Windows XP Service Pack 1 (SP1) oder Windows XP Service Pack 2 (SP2) installiert sein.
Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:02  6.0.2900.2754  660,480  Wininet.dll         SP2
   07-Sep-2005  00:09  5.1.2600.2754   30,720  Arpidfix.exe        SP2
   06-Sep-2005  10:36  6.0.2800.1521  585,728  Wininet.dll         SP1

Windows Server 2003

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Voraussetzungen
Es gelten keine Voraussetzungen.
Neustartanforderung
Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Dateiinformationen
Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version           Size  File name  Service pack
   -------------------------------------------------------------------
   07-Sep-2005  02:29  6.0.3790.404   628,224  Wininet.dll
   07-Sep-2005  02:50  6.0.3790.2524  663,040  Wininet.dll         SP1
   07-Sep-2005  00:29  5.2.3790.2524   32,256  Arpidfix.exe        SP1

Hotfix-Installationsanweisungen

Warnung Schwerwiegende Probleme können auftreten, wenn Sie die Registrierung falsch mithilfe des Registrierungs-Editors oder mithilfe einer anderen Methode ändern. Diese Probleme erfordern möglicherweise eine Ihr Betriebssystem neu installieren. Microsoft kann nicht garantieren, dass diese Probleme gelöst werden können. Ändern Sie die Registrierung auf eigene Gefahr.

Nachdem Sie diesen Hotfix angewendet haben, aktivieren Sie den Hotfix, indem Sie zwei Registrierungseinträge in der Registrierung hinzufügen. Gehen Sie folgendermaßen vor um diese Registrierungseinträge hinzuzufügen,
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Klicken Sie auf einen der folgenden Registrierungsunterschlüssel, um diesen Hotfix auf einzelne Benutzer zu aktivieren:
    • HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_CURRENT_USER\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Hinweis: Sie müssen nur die Registrierungseinträge auf eine der folgenden Registrierungsunterschlüssel hinzufügen.

    Klicken Sie auf einen der folgenden Registrierungsunterschlüssel, um diesen Hotfix auf einer computerspezifischen Basis zu aktivieren:
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    • HKEY_LOCAL_MACHINE\Software\Policies\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409
    Hinweis: Sie müssen nur die Registrierungseinträge auf eine der folgenden Registrierungsunterschlüssel hinzufügen.
  3. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  4. Geben Sie FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409, und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie auf FEATURE_HTTP_DISABLE_NTLM_PREAUTH_IF_ABORTED_KB902409 .
  6. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  7. Geben Sie Iexplore.exe als Namen den neuen DWORD-Wert, und drücken Sie anschließend die [EINGABETASTE].
  8. Doppelklicken Sie auf Iexplore.exe , geben Sie 1 im Feld Wert ein, und klicken Sie auf OK , um den Hotfix zu aktivieren.

    Hinweis: Um den Hotfix zu deaktivieren, geben Sie 0 im Feld Wertdaten .
  9. Wiederholen Sie die Schritte 3 bis 5, um hinzuzufügen den Registrierungseintrag "Explorer.exe". Geben Sie im Schritt 4 Explorer.exe anstatt Iexplore.exe .
  10. Beenden Sie den Registrierungseditor.

Abhilfe

Konfigurieren Sie den Webserver für die Unterstützung der NTLM-Authentifizierung, wird um dieses Problem zu umgehen. Wenden Sie sich um weitere Informationen dazu, wie den Webserver die NTLM-Authentifizierung konfigurieren zu erhalten, an den Hersteller des Webservers.

Informationen zu den Hersteller Ihrer Hardware die folgenden-Website:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 2.

Weitere Informationen

Weitere Informationen zur Terminologie, die in diesem Artikel verwendet wird, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer 6.0 SP1, wenn verwendet mit:
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
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Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 902409  (http://support.microsoft.com/kb/902409/en-us/ )
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