DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 908002 - Geändert am: Montag, 3. Dezember 2007 - Version: 4.1

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
908002  (http://support.microsoft.com/kb/908002/EN-US/ ) FIX: Add-ins, smart documents, or smart tags that you create by using Microsoft Visual Studio 2005 do not run in Office
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Auf dieser Seite

Problembeschreibung

Wenn Sie mit Microsoft Visual Studio 2005 Add-Ins, SmartDocuments oder Smarttags erstellen, können die folgenden Symptome auftreten:
  • Die Add-Ins, SmartDocuments oder Smarttags können in keine Microsoft Office-Anwendung geladen werden.
  • Die Add-Ins, SmartDocuments oder Smarttags können in keiner Version von Microsoft Office ausgeführt werden.
Dieses Problem tritt auf, wenn Sie die Add-Ins, SmartDocuments oder Smarttags auf einem Computer erstellen, auf dem das Microsoft .NET Framework 2.0 installiert ist.

Hinweis: Dieses Problem tritt nicht auf, wenn Sie sich mit einem Microsoft Windows-Benutzerkonto mit eingeschränkten Berechtigungen anmelden.

Lösung

Das in diesem Artikel beschriebene Update für Visual Studio 2005 ermöglicht Ihnen die Neuverteilung der erforderlichen Fixes in Office und dem .NET Framework zusammen mit den Lösungen, die Sie in Visual Studio 2005 schreiben. Dieses Update fügt der Liste der erforderlichen Komponenten in Visual Studio 2005 die neue Option Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002) hinzu. Wenn Sie ein Setup-Projekt für verwaltete Add-Ins, SmartDocuments oder Smarttags erstellen, müssen Sie diese Option in dem Setup-Projekt aktivieren, das die erforderlichen weitervertreibbaren Updates für Office und das .NET Framework enthält.

Um dieses Problem auch für Visual Studio 2005-Entwickler zu beheben, ist auch eine weitervertreibbare Version des Updates für Visual Studio 2005 verfügbar.

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:
Bild minimierenBild vergrößern
Download
Paket VS2005-KB908002-ENU-x86.EXE jetzt herunterladen (http://download.microsoft.com/download/b/6/7/b6711d3b-b509-4567-8599-98bf3473310f/vs2005-kb908002-enu-x86.exe)

Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Microsoft hat dazu die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.

Gehen Sie folgendermaßen vor, um dieses Update für Visual Studio 2005 zu installieren:
  1. Speichern Sie das Downloadpaket auf Ihrem Computer.
  2. Doppelklicken Sie auf das Downloadpaket, um es auszuführen.
  3. Lesen und akzeptieren Sie die Bestimmungen des Microsoft-Softwarelizenzvertrags.
Nachdem Sie dieses Update installiert haben, müssen Sie die Option Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002) der Liste der erforderlichen Komponenten im Setup-Projekt mit der Lösung hinzufügen, wenn Sie in Visual Studio 2005 ein gemeinsames Add-In-Projekt erstellen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf das Setup-Projekt. Klicken Sie dann auf Eigenschaften.
  2. Klicken Sie auf Erforderliche Komponenten.
  3. Aktivieren Sie das Kontrollkästchen Shared Add-in Support Update for the Microsoft .NET Framework 2.0 (KB908002).
Hinweis: Sie müssen diese erforderliche Komponente für Debugbuilds und Releasebuilds separat aktivieren.

Immer wenn Sie ein Setup-Projekt erstellen, nimmt Visual Studio 2005 die weitervertreibbaren Updates in Ihr Projekt auf und speichert sie in einem Ordner mit dem Namen "KB908002". Dieser Ordner befindet sich im Installationsordner der Anwendung. Der Inhalt des Ordners "KB908002" wird benötigt, damit die Setup-Logik korrekt funktioniert. Die Datei "Setup.exe", die Visual Studio 2005 mit dem Setup-Projekt erstellt, wendet die Updates auf den Zielcomputer an, wenn die Lösung installiert wird.

Hinweis: Das .NET Framework 2.0 und Microsoft Windows Installer 2.0 sind erforderlich, damit die Updates auf dem Zielcomputer korrekt installiert werden.
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Schritte zum Reproduzieren des Problems

  1. Starten Sie Microsoft Visual Studio 2005.
  2. Erstellen Sie ein gemeinsames Add-In. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie im Menü Datei auf Neu, und klicken Sie anschließend auf Projekt.
    2. Klicken Sie im Dialogfeld Neues Projekt auf Andere Projekttypen , und klicken Sie dann auf Erweiterungen.
    3. Klicken Sie auf Gemeinsames Add-In, geben Sie einen Namen in das Feld Name ein, und klicken Sie anschließend auf OK.
    4. Folgen Sie den Anweisungen des Assistenten für gemeinsames Add-In, um ein Microsoft Word-Add-In zu erstellen.
  3. Erstellen Sie das Projekt. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie im Menü Projekt auf Ihr ProjektnameEigenschaften.
    2. Klicken Sie auf der Registerkarte Ihr Projektname auf Erstellen, und klicken Sie dann in der Liste Konfiguration auf Release.
    3. Klicken Sie im Menü Erstellen auf Projektmappe erstellen.
  4. Klicken Sie im Menü Datei auf Beenden, um Visual Studio zu beenden.
  5. Stellen Sie das Add-In bereit. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie auf Start und anschließend auf Eigene Dateien.
    2. Öffnen Sie folgenden Ordner:
      Visual Studio 2005\Projects\Ihr Projektname\Ihr ProjektnameSetup\Debug
      Das Projekt, das Sie in Schritt 3 erstellt haben, wird standardmäßig im Visual Studio 2005-Ordner gespeichert.
    3. Kopieren Sie die folgenden Dateien auf den Desktop eines zweiten Computers:
      • Setup.exe
      • Ihr ProjektnameSetup.msi
    4. Doppelklicken Sie auf die Datei Setup.exe, und übernehmen Sie dann alle Standardeinstellungen.
  6. Starten Sie Microsoft Word.
  7. Klicken Sie im Menü Extras auf Vorlagen und Add-Ins.
  8. Klicken Sie auf Hinzufügen. Im Dialogfeld COM-Add-Ins wird Ihnen eine Fehlermeldung angezeigt.

Informationsquellen

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
907417  (http://support.microsoft.com/kb/907417/DE/ ) Beschreibung des Updates für Office 2003 vom 08.11.2005
Hinweis: Das im Microsoft Knowledge Base-Artikel 907417 beschriebene Update bietet Endbenutzern von Office 2003 nur die Möglichkeit, das Problem in Bezug auf die Datei "Otkloadr.dll" zu beheben. Dieser Artikel befasst sich nicht mit dem Problem in Bezug auf die Datei "Extensibility.dll" und gilt nicht für andere Versionen von Office als Office 2003.

Weitere Informationen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
908003  (http://support.microsoft.com/kb/908003/DE/ ) UPDATE: Office 2003 stürzt ab, wenn Sie versuchen, ein Worddokument oder eine Excel-Kalkulationstabelle aus einem WinForm-Steuerelement in einem Tools in Visual Studio für die Office-System-Version-2003-Lösung zu schließen
908004  (http://support.microsoft.com/kb/908004/DE/ ) UPDATE: Sie können eine Anpassung nicht ausführen, die Microsoft Visual Studio Tools for the Microsoft Office System Version 2003 erstellt wurde

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft .NET Framework 2.0
  • Microsoft Visual Studio 2005 Tools for the Microsoft Office System
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Express Edition
  • Microsoft Visual Studio 2005 Team System Team Foundation
  • Microsoft Office Standard Edition 2003
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office 97 Standard Edition
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
Keywords: 
kbtshoot kbbug kbnofix KB908002
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store