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Artikel-ID: 910678 - Geändert am: Mittwoch, 29. August 2007 - Version: 2.2

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Problembeschreibung

Wenn Sie Sysprep-MiniSetup-Assistenten zum Installieren von einer Microsoft Windows XP mit Service Pack 2 (SP2) Bild ausführen, reagiert der Assistent möglicherweise nicht mehr, nach dem Start des Installationsvorgangs Videotreiber. Dieses Problem, wenn der OempnpDriversPath Eintrag in der Sysprep.inf-Datei auf die neuesten Intel Grafiktreiber auf der Dell-Website oder auf der Intel-Website verweist.

Wenn der Intel-Grafiktreiber mithilfe eingerichtet ist, bemerken Sie dieses Problem der Services.exe - Setup Befehl.

Ursache

Dieses Problem aufgrund eines Problems mit dem grafische Schnittstelle (GUI) Thread im Prozess Services.exe. Wenn der Services.exe-Prozess gestartet wird, treten die folgenden Ereignisse in der folgenden Reihenfolge:
  1. Alle statisch verknüpfte DLL-Dateien werden initialisiert.
  2. Die Datei Acgenral.dll lädt die Datei Shell32.dll.
  3. Die Datei Shell32.dll lädt die Comctl32.DLL-Datei, obwohl Services.exe niemals diese Binärdatei verwendet.
  4. Wenn der SvcctrlMain-Thread für die Datei Shell32.dll ausgeführt wird eine \ -Funktion, der SvcctrlMain-Thread transformiert, in einem GUI-Thread. Darüber hinaus transformiert der Services.exe-Prozess in einem Prozess im GUI-Modus.
  5. Der SvcctrlMain-Thread beendet ausgeführt, wenn der Services.exe-Prozess noch ausgeführt wird.
Beim Eintreten dieser Ereignisse alle GUI-Modus-Aspekte der Services.exe beendet, aber Services.exe kann nicht in den GUI-Modus zurück.

Wenn die Intel Gerät Treiber Co-Installationsprogramm in Services.exe-Prozess gestartet wird, ruft die UpdateDriverForPlugAndPlayDevices -Funktion die newdev.dll-Datei. Die newdev.dll-Datei wird im Kontext der Services.exe ausgeführt, da es einen Plug & Play-Prozess ist. Es ist jedoch kein Aspekt GUI-Modus für diesen Prozess, der für den Benutzer sichtbar ist. Aus diesem Grund erstellt newdev.dll eine unbeaufsichtigte Datei, die einige Standardeinstellungen für die Eigenschaft hat. Anschließend versucht newdev.dll, diese Datei im Hintergrund ausgeführt. Jedoch kann nicht newdev.dll diese Datei nicht automatisch ausgeführt, da Services.exe zu GUI zurückgeben kann nicht.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix anwenden, müssen Sie Windows XP Service Pack 2 (SP2) auf dem Computer installiert sein. Sie benötigen alle neuesten Windows-Updates auf dem Computer installiert. Sie benötigen den KB883667-Hotfix auf dem Computer installiert.

Neustartanforderung

Sie müssen den Computer nach Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools „ Datum und Uhrzeit in der Systemsteuerung.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungDienst Verzweigung
Acadproc.dll5.1.2600.279539,42414-Nov 200514: 58X 86SP2SP2QFE

Weitere Informationen

Weitere Informationen zu Standardterminologie, die zur Beschreibung der Microsoft-Softwareupdates verwendet wird, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates


Die in diesem Artikel erwähnten Fremdanbieterprodukte werden von einem Lieferanten hergestellt, der von Microsoft unabhängig ist. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Service Pack 2, wenn verwendet mit:
    • Microsoft Windows XP Professional
Keywords: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbbug kbfix kbpubtypekc KB910678 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 910678  (http://support.microsoft.com/kb/910678/en-us/ )
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