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Artikel-ID: 925336 - Geändert am: Mittwoch, 7. November 2012 - Version: 2.0

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Problembeschreibung

Wenn Sie versuchen, ein großes Microsoft Windows Installer-Paket (.msi) oder ein großes Microsoft Windows Installer-Patchpaket (.msp) auf einem Computer zu installieren, auf dem Microsoft Windows Server 2003 oder Microsoft Windows XP ausgeführt wird, wird folgende Fehlermeldung angezeigt:
Fehler 1718. Die Datei Dateiname wurde von Richtlinie für die digitale Signatur zurückgewiesen.
Im Anwendungsprotokoll können darüber hinaus die folgenden Ereignisse protokolliert werden:
Typ: Fehler
Quelle: MsiInstaller
Kategorie: Keine
Ereignis-ID: 1008
Datum: Datum
Zeit: Time
Benutzer: NA
Computer: Computername

Beschreibung: Die Installation von Dateiname ist aufgrund eines Fehlers bei der Verarbeitung der Softwareeinschränkungsrichtlinie nicht zulässig. Das Objekt ist nicht vertrauenswürdig.

Ursache

Dieses Problem tritt auf, wenn der Windows Installer-Prozess nicht über ausreichend zusammenhängenden virtuellen Speicher verfügt, um zu überprüfen, ob das MSI- oder das MSP-Paket ordnungsgemäß signiert ist.

Lösung

Für Windows Server 2003 ist ein unterstütztes Update verfügbar. Für Windows XP ist kein Update verfügbar.

Windows Server 2003-Hotfixinformationen

Ein Hotfix zur Behebung des Problems ist jetzt bei Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Service Pack für Microsoft Windows Server 2003 zu warten, das diesen Hotfix enthalten wird.

Wenn Sie das Problem sofort beheben möchten, wenden Sie sich an Microsoft Support Services, um den Hotfix zu erhalten. Eine vollständige Liste der Telefonnummern des Microsoft-Produktsupports sowie Informationen zu den Supportkosten finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ln=de&ws=support#tab0 (http://support.microsoft.com/contactus/?ln=de&ws=support#tab0)
Hinweis Laden Sie den Hotfix wie im Folgenden beschrieben herunter.

Update für Windows Server 2003 (KB925336)

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:

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Download
Paket "Update für Windows Server 2003 (KB925336)" jetzt herunterladen. (http://www.microsoft.com/de-de/download/details.aspx?id=6724)

Weitere Informationen zum Herunterladen von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/de/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Dazu wurde die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.
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File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.2895620,54407-Mar-200707:05x86SP1SP1QFE
Advapi32.dll5.2.3790.4036619,00807-Mar-200707:02x86SP2SP2QFE

Update für Windows Server 2003, x64 Edition (KB925336)

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:

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Download
Paket "Update für Windows Server 2003 x64-Edition (KB925336)" jetzt herunterladen (http://www.microsoft.com/de-de/download/details.aspx?id=1048)

Weitere Informationen zum Herunterladen von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/de/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Dazu wurde die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.
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File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.28951,051,64807-Mar-200707:52x64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620,54407-Mar-200707:52x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361,052,16007-Mar-200716:52x64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619,00807-Mar-200716:52x86SP2SP2QFE\WOW

Update für Windows Server 2003 für Itanium-Systeme (KB925336)

Die folgende Datei steht im Microsoft Download Center zum Download zur Verfügung:

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Download
Paket "Update für Windows Server 2003 für Itanium-Systeme (KB925336)" jetzt herunterladen (http://www.microsoft.com/de-de/download/details.aspx?id=12206)

Weitere Informationen zum Download von Microsoft Support-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/de/ ) So erhalten Sie Microsoft Support-Dateien im Internet
Microsoft hat diese Datei auf Viren überprüft. Dazu wurde die neueste Software zur Virenerkennung verwendet, die zum Zeitpunkt der Bereitstellung verfügbar war. Die Datei befindet sich auf Servern mit verstärkter Sicherheit, wodurch nicht autorisierte Änderungen an der Datei weitestgehend verhindert werden.
Tabelle minimierenTabelle vergrößern
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.28951,481,21607-Mar-200711:42IA-64SP1SP1QFE
Wadvapi32.dll5.2.3790.2895620,54407-Mar-200711:42x86SP1SP1QFE\WOW
Advapi32.dll5.2.3790.40361,482,24007-Mar-200716:53IA-64SP2SP2QFE
Wadvapi32.dll5.2.3790.4036619,00807-Mar-200716:53x86SP2SP2QFE\WOW

Voraussetzungen

Keine

Neustart

Sie müssen den Computer neu starten, nachdem Sie den Hotfix angewendet haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Coordinated Universal Time" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die lokale Zeit konvertiert. Den Unterschied zwischen UTC-Zeit und lokaler Zeit können Sie in der Systemsteuerung unter Datum und Uhrzeit mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.

Abhilfe

Diese Abhilfe gilt sowohl für Windows Server 2003 als auch für Windows XP.

Wichtig: Dieser Abschnitt bzw. die Methoden- oder Aufgabenbeschreibung enthält Hinweise zum Ändern der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung eine Sicherungskopie der Registrierung erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen und Wiederherstellen einer Sicherungskopie der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/de/ ) Sichern und Wiederherstellen der Registrierung in Windows


Um dieses Problem zu umgehen, ändern Sie den Registrierungswert "PolicyScope" in 1, bevor Sie versuchen, das Paket zu installieren. Gehen Sie hierzu folgendermaßen vor.

Hinweis: Wenn der Computer zu einer Domäne gehört, überschreibt ein Domänenrichtlinien-Update möglicherweise die von Ihnen durchgeführten Registrierungsänderungen. Es wird dringend empfohlen, den Computer von der Domäne zu trennen, bevor Sie folgende Schritte ausführen.
  1. Klicken Sie auf Start und auf Ausführen, geben Sie regedit ein, und klicken Sie anschließend auf OK.
  2. Klicken Sie im Registrierungs-Editor auf den folgenden Schlüssel:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers

    Hinweis Bevor Sie diesen Schlüssel ändern, sollten Sie ihn sichern. Klicken Sie hierzu mit der rechten Maustaste auf CodeIdentifiers, und klicken Sie danach auf Exportieren. Speichern Sie die Datei an einem Speicherort auf dem Computer, an dem Sie sie leicht wieder finden.
  3. Ändern Sie den Registrierungswert "PolicyScope". Doppelklicken Sie hierzu auf PolicyScope, und ändern Sie anschließend die Einstellung von 0 auf 1.
  4. Schließen Sie den Registrierungs-Editor.
  5. Klicken Sie auf Start, dann auf Ausführen, geben Sie cmd ein, und klicken Sie anschließend auf OK, um das Eingabeaufforderungsfenster zu öffnen.
  6. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie anschließend die EINGABETASTE:
    net stop msiserver
    Dieser Befehl beendet den Windows Installer-Dienst, wenn der Dienst derzeit im Hintergrund ausgeführt wird. Wenn der Dienst beendet wurde, schließen Sie das Eingabeaufforderungsfenster, und gehen Sie dann zu Schritt 7.

    Hinweis Wenn in der Eingabeaufforderung folgende Meldung angezeigt wird, schließen Sie das Eingabeaufforderungsfenster, und gehen Sie dann zu Schritt 7:
    Der Windows Installer-Dienst wurde nicht gestartet.
  7. Installieren Sie das Paket, das Sie zu installieren versuchten, als die im Abschnitt "Problembeschreibung" genannte Fehlermeldung angezeigt wurde.
  8. Wiederholen Sie nach der Installation des Pakets die Schritte 1 und 2. Ändern Sie dann den Registrierungswert "PolicyScope" zurück auf 0.
  9. Wenn Sie den Computer von einer Domäne getrennt hatten, fügen Sie ihn wieder der Domäne hinzu, und starten Sie anschließend den Computer neu.

    Hinweis Wenn Sie den Computer nicht von einer Domäne getrennt hatten, müssen Sie den Computer nicht neu starten.
Gehen Sie folgendermaßen vor, wenn sich das Problem dadurch nicht beheben lässt:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie control admintools ein, und klicken Sie anschließend auf OK.
  2. Doppelklicken Sie auf Lokale Sicherheitsrichtlinie.
  3. Klicken Sie auf Richtlinien für Softwareeinschränkung.

    Hinweis Wenn keine Softwareeinschränkungen aufgelistet sind, klicken Sie mit der rechten Maustaste auf Richtlinien für Softwareeinschränkung, und klicken Sie dann auf Neue Richtlinie erstellen.
  4. Doppelklicken Sie unter Objekttyp auf Erzwingen.
  5. Klicken Sie auf Alle Benutzer außer den lokalen Administratoren, und klicken Sie dann auf OK.
  6. Starten Sie den Computer neu.
Wichtig Nachdem Sie die vorausgehenden Schritte durchgeführt haben, können lokale Administratoren das MSI-Paket oder das MSP-Paket installieren. Setzen Sie nach der Installation des Pakets die Durchsetzungsebene zurück, indem Sie die vorherigen Schritte ausführen. Klicken Sie in Schritt 5 anstelle von Alle Benutzer außer den lokalen Administratoren auf Alle Benutzer.

Hinweise
  • Die Abhilfe funktioniert möglicherweise nicht in einer Active Directory-Domänenumgebung. In einer Active Directory-Domänenumgebung werden die lokalen Richtlinien für Softwareeinschränkungen durch eine Aktualisierung einer Domänenrichtlinie überschrieben.
  • Durch Hinzufügen von Arbeitsspeicher zum Computer wird das Problem nicht behoben.

Weitere Informationen

Ab Microsoft Windows XP wurde eine Sicherheitsrichtlinie namens "Richtlinien für Softwareeinschränkung" (auch als SAFER bezeichnet) eingeführt, um Benutzer vor dem Ausführen nicht sicherer Dateien zu schützen. Windows Installer verwendet Richtlinien zur Softwareeinschränkung, um die Signaturen signierter MSI- und MSP-Paketdateien zu verifizieren. Dadurch wird sichergestellt, dass die Dateien nicht manipuliert wurden, bevor sie auf dem Computer installiert werden. Bei Windows XP und Windows Server 2003 muss die gesamte MSI- oder MSP-Paketdatei in einen zusammenhängenden Block Arbeitsspeicher im Adressraum des Windows Installer-Prozesses geladen werden.

Wenn eine MSI- oder MSP-Paketdatei zu groß ist und nicht in einen zusammenhängenden Block virtuellen Speichers passt, kann Windows Installer nicht überprüfen, ob das Paket korrekt ist. In diesem Szenario treten die im Abschnitt "Problembeschreibung" erläuterten Probleme auf. Durch das in diesem Artikel beschriebene Update wird ermöglicht, dass die Richtlinien zur Softwareeinschränkung weniger virtuellen Speicher zum Durchführen der Signaturüberprüfung benötigen. Windows Installer kann daher Dateien jeglicher Größe überprüfen.
Hinweis Dies ist ein Artikel, der im Schnellverfahren direkt von der Microsoft-Supportorganisation erstellt wurde. Die hierin enthaltenen Informationen werden als Reaktion auf neue Probleme wie besehen bereitgestellt. Da dieser Artikel im Schnellverfahren erstellt wurde, kann er Tippfehler enthalten und zu einem späteren Zeitpunkt ohne vorherige Ankündigung überarbeitet werden. Weitere zu berücksichtigende Informationen finden Sie in den Nutzungsbedingungen (http://go.microsoft.com/fwlink/?LinkId=151500) .

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional
Keywords: 
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