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Artikel-ID: 939884 - Geändert am: Donnerstag, 11. Oktober 2007 - Version: 1.4

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Problembeschreibung

In Microsoft Windows XP und Microsoft Windows Server 2003 tritt auf, ein Handleleck Grafiken Gerät Interface (GDI), wenn eine Anwendung häufig die CreateRectRgn -Funktion aufruft. Wenn dieses Problem auftritt, wird möglicherweise die folgenden Symptome auftreten:
  • Die Anzahl der GDI verarbeitet fortlaufend erhöht.
  • Die Anwendung instabil.
  • Die Anwendung funktioniert nicht ordnungsgemäß, wenn die Anzahl der GDI-Handle das Kontingent für jeden Prozess erreicht.

    Hinweis: Standardmäßig ist das Kontingent für jeden Prozess 10.000.
Dieses Problem tritt auf, wenn folgenden Bedingungen erfüllt sind:
  • Die Anwendung ist multithreaded.
  • Der Computer verwendet mehrere Prozessoren. Oder hyper-threading aktiviert ist.
Hinweis: Dieses Problem tritt nicht in Windows Vista.

Ursache

Dieses Problem tritt aufgrund einer Racebedingung im GDI-Modul. Das GDI-Modul verwaltet falsch REGION -Ziehpunkte.

Lösung

Hotfix-Informationen für Windows XP

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, müssen Sie Windows XP Service Pack 2 installiert sein. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) Wie Sie das neueste Service Pack für Windows XP erhalten

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Win32k.sys5.1.2600.31801,843,96818-Jul-200711: 12X 86

Hotfix-Informationen für Windows Server 2003

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix installieren, muss Windows Server 2003 Service Pack 1 oder Windows Server 2003 Service Pack 2 installiert sein. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
Windows Server 2003 mit Service Pack 2, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Gdi32.dll5.2.3790.4033282,62402-Mär-200706: 41X 86SP2
Win32k.sys5.2.3790.41111,846,27204-Jul-200713: 57X 86SP2
Windows Server 2003 mit Service Pack 2, x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.4033619,52004-Jul-200702: 52X 64SP2Nicht zutreffend
Win32k.sys5.2.3790.41114,536,32004-Jul-200702: 52X 64SP2Nicht zutreffend
Wgdi32.dll5.2.3790.4033290,81604-Jul-200702: 52X 86SP2WOW
Windows Server 2003 mit Service Pack 2, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.4033913,40804-Jul-200702: 53IA-64SP2Nicht zutreffend
Win32k.sys5.2.3790.41115,559,29604-Jul-200702: 53IA-64SP2Nicht zutreffend
Wgdi32.dll5.2.3790.4033290,81604-Jul-200702: 53X 86SP2WOW
Windows Server 2003 mit Service Pack 1, x 86-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Gdi32.dll5.2.3790.2892284,16002-Mär-200708: 11X 86SP1
Win32k.sys5.2.3790.29671,856,00004-Jul-200712: 45X 86SP1
Windows Server 2003 x 64-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2892617,47204-Jul-200702: 48X 64SP1Nicht zutreffend
Win32k.sys5.2.3790.29674,542,97604-Jul-200702: 48X 64SP1Nicht zutreffend
Wgdi32.dll5.2.3790.2892287,74404-Jul-200702: 48X 86SP1WOW
Windows Server 2003 mit Service Pack 1, Itanium-basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Gdi32.dll5.2.3790.2892909,31204-Jul-200702: 48IA-64SP1Nicht zutreffend
Win32k.sys5.2.3790.29675,554,68804-Jul-200702: 48IA-64SP1Nicht zutreffend
Wgdi32.dll5.2.3790.2892287,74404-Jul-200702: 48X 86SP1WOW

Abhilfe

Starten Sie um dieses Problem zu umgehen, die Anwendung, die dieses Problem hat. Oder verwenden Sie einen einzelnen Prozessor-Computer, und deaktivieren Sie hyper-threading.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
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Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 939884  (http://support.microsoft.com/kb/939884/en-us/ )
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