DetailPage-MSS-KB

Knowledge Base

Artikel-ID: 956708 - Geändert am: Mittwoch, 1. Juni 2011 - Version: 1.0

 

Auf dieser Seite

Problembeschreibung

Wenn Sie versuchen, Updates mithilfe des Windows Update oder Microsoft Update-Website installieren, erhalten Sie die folgenden Fehlermeldung:
0 x 80004002
Dieses Problem kann auftreten, wenn eine oder mehrere der folgenden Bedingungen erfüllt sind:
  • Reparieren Sie die Installation von Windows XP Service Pack 2 (SP2) mithilfe der Windows XP SP2-CD. Anschließend installieren Sie Windows XP Service Pack 3 (SP3), bevor Sie die Windows Update-Software auf die aktuelle Version aktualisieren.
  • Sie führen eine Neuinstallation von Windows XP SP2. Anschließend installieren Sie Windows XP SP3, bevor Sie die Windows Update-Software auf die aktuelle Version aktualisieren.
  • Die aktuelle Version von Windows Update ist nicht installiert und ordnungsgemäß registriert.

Ursache

Dieses Problem tritt auf, wenn die Windows Update-Agent-Datei "Wups2.dll", nicht korrekt registriert ist. Updateinstallationen schlagen fehl, wenn die Registrierungsdateien, die die Datei "Wups2.dll" entsprechen fehlen.

Lösung

Um dieses Problem zu beheben, verwenden Sie die folgenden Methoden in der angegebenen Reihenfolge.

Wenn Methode 1 für Sie ausführen lassen möchten, fahren Sie mit dem "Fix it for me"Abschnitt. Wenn Sie es vorziehen, dieses Problem zu beheben, gehen Sie zu den "Lassen Sie mich manuell beheben"Abschnitt.

Fix it for me



Um dieses Problem automatisch zu beheben, klicken Sie auf die Fix it Schaltfläche bzw. Verknüpfung. In der Dateidownload Klicken Sie im Dialogfeld Ausführen, und befolgen Sie die Schritte in den Fix es Assistenten.


Dieses Problem zu beheben.
Microsoft Fix it 50687


Notizen
  • Dieser Assistent möglicherweise nur in englischer Sprache. Die automatische Korrektur funktioniert jedoch auch für andere Sprachversionen von Windows.
  • Wenn Sie nicht auf dem Computer, auf dem das Problem, speichern Sie die Fehlerbehebung ist es Lösung auf ein flash-Laufwerk oder eine CD, und führen Sie es auf dem Computer, auf dem das Problem ist.

Fahren Sie dann mit der "Wurde das Problem behoben?"Abschnitt.



Lassen Sie mich manuell beheben

Methode 1: Registrieren Sie die Windows Update-Dateien

Wenn Sie Windows XP, Windows Server 2003 oder Windows 2000 ausführen, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, Typ Editor , und klicken Sie dann auf OK.
  2. Kopieren Sie die folgenden Befehle ein, und fügen Sie diese in das Editor-Fenster.
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 MUCLTUI.DLL /S
    REGSVR32 WUCLTUI.DLL /S
    REGSVR32 WUWEB.DLL /S
    REGSVR32 MUWEB.DLL /S
    REGSVR32 QMGR.DLL /S
    REGSVR32 QMGRPRXY.DLL /S
  3. Im Editor Datei Menü, klicken Sie auf Speichern als.
  4. In der Dateiname Geben Sie im Feld Register.bat, und klicken Sie dann auf Alle Dateien Klicken Sie im Dialogfeld Dateityp im Feld.
  5. Speichern Sie die Datei register.bat auf dem Desktop.
  6. Doppelklicken Sie auf die Datei register.bat, die Windows Update-Dateien zu registrieren.
  7. Versuchen Sie, um Updates erneut zu installieren.
Wenn Sie Windows Vista oder Windows Server 2008 ausgeführt werden, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start
    Bild minimierenBild vergrößern
    Schaltfläche "Start"
    , Typ Editor Klicken Sie im Dialogfeld Suche starten Feld, und klicken Sie dann auf Editor in der Programme Liste.
  2. Kopieren Sie die folgenden Befehle ein, und fügen Sie diese in das Editor-Fenster.
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 WUCLTUX.DLL /S
    REGSVR32 WUWEBV.DLL /S
    REGSVR32 JSCRIPT.DLL /S
    REGSVR32 MSXML3.DLL /S
  3. Im Editor Datei Menü, klicken Sie auf Speichern als.
  4. In der Dateiname Geben Sie im Feld Register.bat, und klicken Sie dann auf Alle Dateien (*. *) Klicken Sie im Dialogfeld Dateityp im Feld.
  5. Speichern Sie die Datei register.bat auf dem Desktop.
  6. Mit der rechten Maustaste der Datei register.bat, und klicken Sie dann auf Als Administrator ausführen.
    Bild minimierenBild vergrößern
    Benutzerkontensteuerung
    Wenn Sie ein Administratorkennwort oder eine Bestätigung aufgefordert werden, geben Sie das Kennwort ein, oder klicken Sie auf Fortfahren.
  7. Versuchen Sie, um Updates erneut zu installieren.

Methode 2: Herunterladen und Installieren der Windows Update-Agent

Weitere Informationen zum Herunterladen der neuesten Version des Windows Update-Agents finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
949104  (http://support.microsoft.com/kb/949104/ ) So erhalten Sie die neueste Version des Windows Update-Agents zur Verwaltung von Updates auf einem computer

Wurde das Problem behoben?

  • Überprüfen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, sind Sie mit diesem Abschnitt Fertig. Wenn das Problem nicht behoben wird, können Sie Kontaktieren Sie den support (http://support.microsoft.com/contactus) .
  • Ihr Feedback, würden wir es begrüßen. Um Feedback bereitzustellen oder Probleme mit dieser Lösung zu informieren, Bitte hinterlassen Sie einen Kommentar auf der "Fix it for me (http://blogs.technet.com/fixit4me/) "Blog oder senden Sie uns eine e-Mail (mailto:fixit4me@microsoft.com?Subject=KB) .

Weitere Informationen

Fehlercode 0 x 80004002 wird ausgelöst, wenn der Registrierungsschlüssel für "Wups2.dll" fehlen. Dieser Fehlercode kann auch ausgelöst werden, wenn zusätzliche Schlüssel fehlen. Registrieren die Windows Update-Datei und die andere DLL-Dateien, die aufgeführt sind, in Methode 1, stellen Sie sicher, dass zusätzlicher Schlüssel ebenfalls registriert werden.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Update
  • Microsoft Windows Update
Keywords: 
kbtshoot kbprb kbexpertisebeginner kbfixme kbmsifixme kbmt KB956708 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 956708  (http://support.microsoft.com/kb/956708/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Freigeben
Weitere Supportoptionen
Microsoft Community-Supportforen
Kontaktieren Sie uns direkt
Zertifizierten Partner finden
Microsoft Store