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Artikel-ID: 973667 - Geändert am: Montag, 4. Januar 2010 - Version: 3.0

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Problembeschreibung

Windows Server 2003-basierten Domänencontrollern möglicherweise falsch den Statuscode "NO_SUCH_USER (0xc0000064)" als Antwort auf Anmeldeanforderungen zurück, nachdem der Statuscode "STATUS_INVALID_SERVER_STATE (0xc00000dc)" oder "STATUS_NO_MEMORY (0xc0000017)"-Statuscode zurückgegeben wird. Dieses Verhalten tritt auf, wenn der authentifizierende Domänencontroller heruntergefahren oder neu zu starten.

Der Statuscode kann eine der folgenden Computer zurückgegeben werden:
  • Der Computer der Domäne-Member, der die Anmeldeanforderung stammt
  • Ein Anwendungsserver
  • Ein Domänencontroller, der die Anmeldeanforderung an den authentifizierenden Domänencontroller weitergeleitet werden, mithilfe von Pass-Through-Authentifizierung
Der falschen Statuscode bewirken, dass die Anwendung, der die Anmeldeanforderung fehlschlagen oder das Zeitlimit überschritten wurde.

Hinweis: Dieses Problem kann auftreten, selbst wenn Sie den 942636-Hotfix angewendet haben.
942636  (http://support.microsoft.com/kb/942636/ ) Windows Server 2003-basierten Domänencontrollern möglicherweise den Statuscode "NO_SUCH_USER (0xc0000064)" als Antwort auf Anmeldeanforderungen falsch zurück.

Ursache

Dieses Problem tritt auf, weil der Netlogon-Dienst den zurückgegebenen Status nicht richtig verwaltet.

Lösung

Um dieses Problem zu beheben, müssen Sie diesen Hotfix auf den Windows Server 2003-Domänencontrollern und auf der Windows Server 2003-basierten Domänenclients anwenden. Nachdem Sie diesen Hotfix angewendet haben, geben die Domänencontroller während des Herunterfahrens “ STATUS_NO_MEMORY (0xc0000017) ”-Statuscode zurück. Wenn der Client diesen Statuscode empfängt, versucht der Client mit einem anderen Domänencontroller zu kommunizieren.

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems das in diesem Artikel beschriebene vorgesehen. Installieren sie diesen Hotfix nur auf systemen, bei die das in diesem artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemlösungen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen, die für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, liegt dies daran, dass ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Um diesen Hotfix anwenden zu können, muss auf dem Computer Windows Server 2003 Service Pack 2 (SP2) ausgeführt werden.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen anderen Hotfix nicht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC-Zeit und lokaler Zeit zu ermitteln, verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung.
Für alle unterstützten x 86-basierten Versionen von Windows Server 2003 SP2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-Anforderung
Ksecdd.sys5.2.3790.4616135,16806-Nov-200911: 04X 86SP2
Msv1_0.dll5.2.3790.4616146,94411-Nov-200910: 08X 86SP2
Schannel.dll5.2.3790.4530151,04016-Jun-200907: 21X 86SP2
Für alle unterstützten x 64-basierten Versionen von Windows Server 2003 SP2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Ksecdd.sys5.2.3790.4616190,97612-Nov-200900: 25X 64SP2Nicht anwendbar
Msv1_0.dll5.2.3790.4616265,21612-Nov-200900: 25X 64SP2Nicht anwendbar
Schannel.dll5.2.3790.4530259,07212-Nov-200900: 26X 64SP2Nicht anwendbar
Wmsv1_0.dll5.2.3790.4616146,94412-Nov-200900: 26X 86SP2WOW
Wschannel.dll5.2.3790.4530151,04012-Nov-200900: 26X 86SP2WOW
Für alle unterstützten Itanium-basierten Versionen von Windows Server 2003 SP2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattformSP-AnforderungServicebereich
Ksecdd.sys5.2.3790.4616322,04812-Nov-200900: 20IA-64SP2Nicht anwendbar
Msv1_0.dll5.2.3790.4616396,80012-Nov-200900: 20IA-64SP2Nicht anwendbar
Schannel.dll5.2.3790.4530474,62412-Nov-200900: 20IA-64SP2Nicht anwendbar
Wmsv1_0.dll5.2.3790.4616146,94412-Nov-200900: 21X 86SP2WOW
Wschannel.dll5.2.3790.4530151,04012-Nov-200900: 21X 86SP2WOW

Abhilfe

Um dieses Problem zu umgehen, manuell Beenden des Netlogon-Dienstes vor dem Herunterfahren des Domänencontrollers.

Status

Microsoft hat bestätigt, dass dies ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Wie sich dieses Problem auf Anwendungen auswirkt

Wenn der Statuscode "NO_SUCH_USER" empfangen wird, führen Sie Domäne Mitgliedscomputern und Domänencontrollern keine neuen Sicherheitskanal zu einem anderen Domänencontroller herstellen, die ordnungsgemäß ausgeführt wird. Daher können die Anmeldeanforderungen, die von Benutzern oder Anwendungen gesendet werden, eine Zeitüberschreitung. Die Anwendung, die die Anmeldeanforderungen stammt kann eine Zeitüberschreitung oder möglicherweise fehl, wenn die Anwendung Failover Logik verfügt oder Logik wiederholen.

Sie können die Authentifizierung in Microsoft Internet Security and Acceleration (ISA) Server, um den Netzwerkverkehr filtern aktiviert haben. Oder Sie haben in Internet Information Services, um Zugriff auf eine Website authentifizieren Authentifizierung aktiviert. Wenn ein Domänencontroller heruntergefahren wird, können Benutzer Zugriff auf den Proxy-Server oder auf die Website verweigert.

Darüber hinaus verhindert dieses Problem Microsoft BizTalk Server ordnungsgemäß funktioniert. Die BizTalk-Dienste beenden unerwartet immer ein Domänencontroller neu gestartet wird. Sie müssen die BizTalk-Dienste manuell neu zu starten.

In diesem Szenario werden die folgenden Fehler im Anwendungsprotokoll auf dem Server protokolliert, die BizTalk Server hostet:

6913-Ereignis-ID

Ereignistyp: Fehler
Ereignisquelle: BizTalk Server 2006
Ereigniskategorie: BizTalk Server 2006
Ereignis-ID: 6913
Benutzer: nicht zutreffend
Computer: <Computer name>
Beschreibung: Ein Verbindungsversuch mit <SQL server name> SQL Server-Datenbank auf Server <Server name> fehlgeschlagen mit Fehler: "Fehler bei der Anmeldung für den Benutzer (Null). Grund: Verbunden mit einer vertrauten SQL Server-Verbindung. ".
Ereignis-ID 5410

Ereignistyp: Fehler
Ereignisquelle: BizTalk Server 2006
Ereignis-ID: 5410
Benutzer: nicht zutreffend
Computer: <Computer name>
Beschreibung: Fehler, die der BizTalk-Dienst beenden benötigt. Die häufigsten Ursachen sind folgende:
1) Ein unerwartetes außerhalb des Speicherfehler. OR
2) Es kann keine Ver eine Bindung hergestellt werden oder einem Abbruch der Verbindung mit einer BizTalk-Datenbanken. Der Dienst wird heruntergefahren und automatischer Neustart in 1 Minute. Wenn die problematische Datenbank nicht zur Verfügung steht weiterhin, wird dieser Zyklus wiederholt.

Fehlermeldung: Fehler bei der Anmeldung für den Benutzer (Null). Ursache: Keiner vertrauten SQL Server-Verbindung zugeordnet.
Fehlerquelle: BizTalk
Host Name: <Server name>
Windows-Dienstname: <Service name>
Um dieses Szenario zu umgehen, können Sie ein Skript im Dienststeuerungs-Manager die BizTalk-Dienste zu starten, wenn die Dienste angehalten werden.

Debuginformationen

Wenn Sie die Protokollierung für den Netlogon-Dienst aktiviert haben, wird der Statuscode für die Anmeldeanforderung in der folgenden Datei protokolliert:
%systemroot%\Debug\Netlogon.log
Die 0xC0000064 Fehlercode in der Datei Netlogon.log auf folgenden Computern protokolliert werden:
  • Der Computer, der die Anmeldeanforderung stammt
  • Der Domänencontroller, der auf die Anmeldeanforderung geantwortet
  • Ein Anwendungsserver oder Domänencontroller, der die Anforderung an den authentifizierenden Domänencontroller weiterleitet
Hinweis: Der Statuscode "NO_SUCH_USER (0xC0000064)" ist eine gültige Rückgabecode, wenn das Benutzerkonto authentifiziert werden nicht vorhanden ist. Diese Situation kann auftreten, wenn eine der folgenden Bedingungen erfüllt ist:
  • Das Benutzerkonto wurde nicht in die authentifizierende Domäne repliziert.
  • Das Benutzerkonto wurde aus dem Active Directory-Verzeichnisdienst gelöscht.
  • Das Benutzerkonto in der Authentifizierungsanforderung ist falsch formatiert, durch den Benutzer oder von der Anwendung.
Wenn ein Domänencontroller auf eine Anmeldeanforderung geantwortet hat, die mithilfe von Pass-Through-Authentifizierung empfangen wird, protokolliert die Datei "Netlogon.log" auf dem Domänencontroller Informationen, die folgenden Inhalts angezeigt:
MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Entered 
MM/DD HH:MM:SS [LOGON] CORP-DOMAIN: SamLogon: Transitive Network logon of <Domain name> \<User account> from CALLER (via <DC or member server>) Returns 0xC0000064 
Wenn der authentifizierende Domänencontroller auf eine Anmeldeanforderung geantwortet hat, die direkt von einem Domäne-Mitgliedscomputer in der gleichen Domäne empfangen wird, protokolliert die Datei "Netlogon.log" auf dem Domänencontroller Informationen, die folgenden Inhalts angezeigt:
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Entered 
MM/DD HH:MM:SS [CRITICAL] NlPrintRpcDebug: Couldn't get EEInfo for I_NetLogonSamLogonEx: 1761 (may be legitimate for 0xc0000064) 
MM/DD HH:MM:SS [LOGON] Samlogon: Network logon of <Domain name>\<User account> from CALLER Returns 0xC0000064 
Weitere Informationen finden Sie die folgende KB-Artikelnummer:
109626  (http://support.microsoft.com/kb/109626/ ) Aktivieren der Debugprotokollierung für den Netlogon-Dienst
Weitere Informationen finden Sie die folgende KB-Artikelnummer:
824684   (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 973667  (http://support.microsoft.com/kb/973667/en-us/ )
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