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Artikel-ID: 982613 - Geändert am: Donnerstag, 5. August 2010 - Version: 3.0

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Problembeschreibung

Auf einem Computer mit Windows 7 oder Windows Server 2008 R2 ruft eine Anwendung die Funktion GetTempFileName auf, um eine temporäre Datei zu erstellen. Die Funktion GetTempFileName schlägt jedoch fehl, und Sie erhalten einige vorübergehende Fehlermeldungen, die der folgenden ähneln:
Der Zugriff auf den Pfad wurde verweigert.
Sie haben keinen Zugriff auf <Dateipfad>.

Ursache

Dieses Problem tritt auf, weil die Funktion GetTempFileName einen duplizierten Dateinamen fehlerhaft verarbeitet.

Beim Versuch der Funktion GetTempFileName einen temporären Dateinamen zu erstellen, wird geprüft, ob bereits ein duplizierter Dateiname vorhanden ist. Findet die Funktion GetTempFileName einen duplizierten Dateinamen, und die Datei soll gelöscht werden, verarbeitet die Funktion GetTempFileName den duplizierten Dateinamen fehlerhaft und schlägt insgesamt fehl, wobei der Fehlercode "ERROR_ACCESS_DENIED" ausgegeben wird.

Das erwartete Verhalten wäre, dass die Funktion erneut versucht einen weiteren temporären Dateinamen zu erstellen.

Lösung

Informationen zum Hotfix

Ein Hotfix zur Behebung des Problems ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des in diesem Artikel beschriebenen Problems vorgesehen. Deshalb sollten Sie nur Systeme aktualisieren, bei denen das in diesem Artikel beschriebene Problem auftritt. Der Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, finden Sie einen Abschnitt "Hotfix download available" (Hotfixdownload verfügbar) oben in diesem Knowledge Base-Artikel. Ist dies nicht der Fall, wenden Sie sich an die Kundenbetreuung bzw. den Support von Microsoft, um den Hotfix zu erhalten.

Hinweis: Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Für zusätzliche Supportanfragen und -belange, die sich nicht auf diesen speziellen Hotfix beziehen, fallen die üblichen Supportgebühren an. Besuchen Sie die folgende Microsoft-Website, um eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support (CSS) abzurufen oder eine separate Serviceanfrage zu erstellen:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis Das Formular "Hotfix download available" (Hotfixdownload verfügbar) zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, steht der betreffende Hotfix in Ihrer Sprache nicht zur Verfügung.

Voraussetzungen

Keine

Neustart

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfix installiert Dateien mit den in der nachstehenden Tabelle aufgelisteten Attributen. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Die Datums- und Uhrzeitangaben für diese Dateien werden auf Ihrem lokalen Computer in Ihrer Ortszeit und unter Berücksichtigung der Sommerzeit angegeben. Außerdem können sich die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen mit den Dateien ausführen.
Hinweise zu den Dateiinformationen für Windows 7 und Windows Server 2008 R2
Wichtig Hotfixes für Windows 7 und Windows Server 2008 sind im selben Paket enthalten. Auf der Seite "Hotfixanfrage" sind die Hotfixes jedoch unter beiden Betriebssystemen aufgeführt. Wählen Sie den auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgeführten Hotfix aus, um das Hotfixpaket für eines oder beide Betriebssysteme zu erhalten. Lesen Sie in den Artikeln stets den Abschnitt "Die Informationen in diesem Artikel beziehen sich auf", um zu ermitteln, für welches Betriebssystem die einzelnen Hotfixes gelten.
  • Die in den einzelnen Umgebungen installierten MANIFEST- (.manifest) und MUM-Dateien (.mum) sind im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2 und Windows 7" separat aufgeführt. MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) sind sehr wichtig, um den Status der aktualisierten Komponente beizubehalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, verfügen über eine digitale Microsoft-Signatur.
Alle unterstützten x86-basierten Versionen von Windows 7
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File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693288,25616-Apr-201007:20x86
Alle unterstützten x64-basierten Versionen von Windows 7 und Windows Server 2008 R2
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File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693420,35216-Apr-201007:29x64
Kernelbase.dll6.1.7600.20693269,82416-Apr-201007:18x86
Alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
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File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693717,82416-Apr-201005:59IA-64
Kernelbase.dll6.1.7600.20693269,82416-Apr-201007:18x86

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Weitere Informationen zur Funktion GetTempFileName finden Sie auf folgender MSDN-Website (Microsoft Developer Network):
Allgemeine Informationen zur Funktion "GetTempFileName" (http://msdn.microsoft.com/de-de/library/aa364991(v=VS.85).aspx)
Weitere Informationen zu den NTSTATUS-Werten finden Sie auf der folgenden MSDN-Website:
Allgemeine Informationen zu den NTSTATUS-Werten (http://msdn.microsoft.com/de-de/library/cc704588(v=PROT.10).aspx)
Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows 7 und Windows Server 2008 R2

Weitere Dateien für alle unterstützten x86-basierten Versionen von Windows 7
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File nameUpdate.mum
File versionNot applicable
File size1,674
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameX86_566758896d090f85fc8cb5f95c849a86_31bf3856ad364e35_6.1.7600.20693_none_211a4e5218931dcf.manifest
File versionNot applicable
File size698
Date (UTC)16-Apr-2010
Time (UTC)10:25
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File nameX86_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_27559e8e2f0f2966.manifest
File versionNot applicable
File size2,734
Date (UTC)16-Apr-2010
Time (UTC)07:56
PlatformNot applicable
Weitere Dateien für alle unterstützten x64-basierten Versionen von Windows 7 und Windows Server 2008 R2
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File nameAmd64_2194916ab24431d6bfd9fcb71de794de_31bf3856ad364e35_6.1.7600.20693_none_f1446242783acb06.manifest
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Date (UTC)16-Apr-2010
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Date (UTC)16-Apr-2010
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Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
File nameIa64_aa7e5d6fa743c1b1b31a1f9acbe9f961_31bf3856ad364e35_6.1.7600.20693_none_237f9d709bce10d3.manifest
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Date (UTC)16-Apr-2010
Time (UTC)10:25
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File nameIa64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_275742842f0d3262.manifest
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Date (UTC)16-Apr-2010
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File nameWow64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_8dc8e4641bcd5c97.manifest
File versionNot applicable
File size2,746
Date (UTC)16-Apr-2010
Time (UTC)07:50
PlatformNot applicable

Die Informationen in diesem Artikel beziehen sich auf:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Keywords: 
kbexpertiseinter kbexpertiseadvanced kbqfe kbhotfixserver kbfix kbsurveynew kbautohotfix KB982613
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