DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 146419 - Last Review: May 12, 2007 - Revision: 1.5

This article was previously published under Q146419
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:
315854  (http://support.microsoft.com/kb/315854/EN-US/ ) Windows 98 and Windows Me Error Message Resource Center
This article refers to an old version of Windows. If you need help about how to install, reinstall, or uninstall Windows, visit the following Microsoft Web site:
http://windows.microsoft.com/en-us/windows/help/install-reinstall-uninstall (http://windows.microsoft.com/en-us/windows/help/install-reinstall-uninstall)

SYMPTOMS

When you start Windows, you may receive the following error message:
Error Loading Kernel. You must reinstall Windows.
After you receive this error message, Windows quits.

CAUSE

This error can occur if the Kernel32.dll file is missing or damaged.

RESOLUTION

To resolve this situation, extract a new copy of the Kernel32.dll file from your original Windows disks or CD-ROM. To do so, follow these steps:
  1. Restart your computer. When you see the "Starting Windows 95" message, press the F8 key, and then choose Command Prompt Only from the Startup menu. If you are using Windows 98, restart your computer, press and hold down the CTRL key while your computer restarts until you see the Windows 98 Startup menu, and then choose Command Prompt Only. If you are using Windows Millennium Edition (Me), start your computer with the Windows Me startup disk.
  2. Type the following commands, pressing ENTER after each line:

    cd\windows\system
    ren kernel32.dll kernel32.xxx
  3. Extract a new copy of the Kernel32.dll file from your original Windows disks or CD-ROM to the Windows\System folder. For information about using the Extract tool, type extract at the command prompt, or see the following article in the Microsoft Knowledge Base:
    ARTICLE-ID: 129605  (http://support.microsoft.com/kb/129605/EN-US/ )
    TITLE : How to Extract Original Compressed Windows Files
  4. Restart your computer.

MORE INFORMATION

NOTE: This article was cited in a hoax regarding a problem with Windows 95/Windows 98 functioning properly on and after December 31, 1999. The problem discussed in this article is not year 2000 (Y2K) related, and Microsoft is unaware of any date-related problems in Kernel32.dll.

APPLIES TO
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbenv kberrmsg kbfaq kbkern32dll kbprb KB146419
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support