DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 171371 - Last Review: October 26, 2013 - Revision: 2.0

This article was previously published under Q171371
This article has been archived. It is offered "as is" and will no longer be updated.

On This Page

Summary

This article provides tips on using the Inbox Repair Tool (Scanpst.exe) to recover folders and items from a corrupted personal folders (.pst) file.

More information

The Inbox Repair Tool is designed to help repair issues that are associated with .pst files and offline folders (.ost) files. The Inbox Repair Tool is included with Microsoft Windows 95 and is also on the Microsoft Outlook 97 CD-ROM and the Microsoft Office 97 CD-ROM.

For additional information about installing and running the Inbox Repair Tool, click the article number below to view the article in the Microsoft Knowledge Base:
168648  (http://support.microsoft.com/kb/168648/EN-US/ ) OL97: How to Find and Run the Inbox Repair Tool
NOTE: The examples in the following procedures use the Inbox Repair Tool on a .pst file. These procedures also apply to an .ost file. To locate the .ost file, click Offline Folders (*.ost) under Select File to Scan.

What the Inbox Repair Tool Does

When you run the Inbox Repair Tool on a .pst file:
  • The Inbox Repair Tool analyzes the .pst file folder structure and item headers, and attempts to recover all folders and items.
  • If the Inbox Repair Tool recovers the .pst file, the Inbox Repair Tool found issues and fixed everything that the Inbox Repair Tool could fix.
  • The Inbox Repair Tool attempts to turn any file into a .pst file. (For example, if you rename an executable file to "Something.pst," the Inbox Repair Tool changes that file into a mountable .pst file.)

What to Do with a Recovered .pst File

After you run the Inbox Repair Tool:
  1. Start Outlook. Use the profile that contains the .pst file that you tried to repair.
  2. On the View menu, click Folder List to turn on the Folder List view. In your Folder List, the following recovered folders should be displayed:

    • Recovered personal folders
    • Calendar
    • Contacts
    • Deleted Items
    • Inbox
    • Journal
    • Notes
    • Outbox
    • Sent Items
    • Tasks

    These folders are usually empty because the folders are part of a rebuilt .pst file. A Lost and Found folder should also be displayed. This folder contains the folders and items that the Inbox Repair Tool recovered. Any items that are absent are beyond repair.

Recovering Repaired Items

Move as many of the items from the Lost and Found folder to a new .pst file in your profile:
  1. Create a new .pst file in your profile:
    1. Start Outlook. Use the profile that contains your recovered personal folders.
    2. On the Tools menu, click Services.
    3. On the Services tab, click Add to open the Add Service to Profile dialog box.
    4. In the Available information services list, click Personal Folders, and then click OK.
    5. In the Create/Open Personal Folders File dialog box, select a folder and type a file name for the new .pst file ("Personal Folders" is the default name), and then click Open.
    6. Click OK to close all dialog boxes.
  2. Drag the recovered items from the Lost and Found folder to the appropriate location in your new .pst file.
  3. When you finish moving all of the items, you can remove the recovered personal folders from your profile, that includes the Lost and Found folder.

Recovering Items from the Backup Personal Folders File

NOTE: If you were unable to open your original .pst file before you ran the Inbox Repair Tool, the following procedure may not work. If you were able to open the original .pst file before you ran the Inbox Repair Tool, there is a small chance that you may be able to recover additional items from your damaged .pst file by using the following procedure.

When you run the Inbox Repair Tool, the option to create a backup of the original .pst file is enabled by default. This option creates a file_name.bak file on your hard disk that is a backup copy of the original file_name.pst file with a different file extension. This .bak file is located in the same folder that the original .pst file is located in.

To attempt to recover items from the .bak file that the Inbox Repair Tool could not recover:
  1. Make a copy of the .bak file, and give the file a new name with a .pst extension. For this example, name the file "Newname.pst".
  2. Start Outlook. Use the profile that contains the .pst file that you created in the "Recovering Repaired Items" section of this article.
  3. Try to import the backup .pst file (in this example, the Newname.pst file) by using the Outlook Import and Export Wizard:
    1. On the File menu, click Import and Export. In the wizard, click Import from a personal folders file (*.pst), and then click Next.
    2. Under File to import, click the backup .pst file (in this example, click Newname.pst). Under Options, click Do not import duplicates, and then click Next.
    3. Under Select the folder to import from, click the name of the backup .pst file, and then click Include subfolders. Click Import folders into the same folder in, and then click the new .pst file that you created in the "Recovering Repaired Items" section of this article.
    4. Click Finish.
Keep in mind that the backup file is the original corrupted .pst file, and you may not be able to recover anything more than the Inbox Repair Tool recovered in the Lost and Found folder. If you cannot import the backup .pst file (in this example, the Newname.pst file) into Outlook, any information that is not in the Lost and Found folder is lost.

Applies to
  • Microsoft Outlook 97 Standard Edition
Keywords: 
kbnosurvey kbarchive kbinfo KB171371
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support