DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 179556 - Last Review: July 27, 2001 - Revision: 1.0

 
This article was previously published under Q179556

On This Page

SUMMARY

This article describes how you can use the Microsoft Outlook 98 Import and Export Wizard to import text data into Outlook and export Outlook data to a text file.

Using a text file is helpful when the converters provided with Outlook do not directly match the format of the other program. Most programs can export and import text files, so you can often use a text file as a common file format for exporting and importing data with Outlook.

MORE INFORMATION

The Outlook Import and Export Wizard can import and export the following types of text data:

  • Comma Separated Values (MS-DOS)
  • Comma Separated Values (Windows)
  • Tab Separated Values (MS-DOS)
  • Tab Separated Values (Windows)

MS-DOS vs Windows

You should make the decision to use the MS-DOS or Windows converter based on the text character set used in your data. ASCII is a character set used by many MS-DOS programs, and ANSI is a character set used by many Windows programs. The largest difference between ASCII and ANSI are the upper 128 characters; the lower 128 characters are the same. The upper 128 characters are often referred to as extended characters. ASCII extended characters include line draw characters while ANSI extended characters include international characters and publishing symbols.

Comma vs Tab Delimiter

The character used to separate (delimit) each field in your data determines if you use the comma or tab separated converter. If you open your data in Microsoft Word 97 and see commas between each field, then your data is comma separated (CSV). If rather than commas you see space between the fields, then your data is either tab-separated or uses a fixed width field. The Outlook tab-separated converter looks for a tab character between fields. In Word 97 you can select the Show/Hide option; tabs appear as arrows that point to the right, and space characters appear as small dots.

NOTE: Do not save your file as a Word document, since Word uses a different file format.

Before attempting to import data from a text file format it is necessary to inspect the header record to assure that the items stored in the text file match Outlook internal names. The header record is the first record in the text file. It defines the way that the data is to be organized. If these fields do not match, data will not be imported.

To find out what the standard Outlook field names are you can generate a sample of these fields in Outlook.

Generating a Sample of Outlook Fields

Before editing your data source, it may be helpful to generate a sample of the fields used in Outlook. To generate the sample fields, follow these steps:

  1. If present, remove the current binary mapping file named, "Comma Separated Values (Windows).ADR" located in the Windows folder. This procedure will rebuild this file.
  2. On the View menu, click Folder List if it is not already displayed.
  3. In the Folder List, right-click the Outlook folder for which you wish to generate a sample and on the shortcut menu, click New Folder.

    NOTE: Each Outlook folder has a distinctly different required set of fields. For example, the required set of fields for Outlook Contacts will include fields that are not used with the Calendar.
  4. Give this temporary folder a name and click OK. You may delete this folder once the sample fields file is created.
  5. On the File menu, click Import And Export. Click "Export to a File" and then Next.
  6. In "Create a file of Type" click to select "Comma Separated Values (Windows)" and then click Next.
  7. In "Select folder to export from" click to select the folder you created in Step 2 and then click Next.
  8. In the "Save exported file as" type a name for the file and click Browse to select the folder in which you wish to save the file. Click OK to save the exported file and then Next and Finish.
The resulting comma separated values file contains the fields that Outlook uses for the folder you selected. Repeat this step as necessary for each type of data you want to import. While familiarizing yourself with the Outlook field labels, note that precise spelling is necessary. For example, when defining electronic mail addresses, Outlook uses the spelling, "e- mail."

Importing Text Data

To import data from a text file, follow these steps:

  1. On the File menu, click Import And Export to open the Import and Export Wizard.
  2. In "Choose an action to perform," click "Import from Schedule+ or another program or file" and click Next.
  3. In "Select file type to import from," click to select the file type that matches your data and click Next.
  4. In File To Import, type the path and file name of the file you want to import, or click Browse to navigate to the file and then Click Next.
  5. In Select Destination Folder, click the folder you want to import into and click Next.
  6. Confirm that the destination folder is correct and then click Finish.

Exporting Text Data

  1. On the File menu, click Import And Export to open the Import and Export Wizard.
  2. In "Choose an action to perform," click "Export to a file" and click Next.
  3. In "Create a file of type," click to select a format for the file you want export and click Next.
  4. In "Select folder to export from," click the folder you want to export and click Next.
  5. In "Save exported file as", type the path and file name for the file you want export and click Next.
  6. Confirm the action and then click Finish.

REFERENCES

For more information on mapping fields in Outlook, please see the following articles in the Microsoft Knowledge Base:
189181  (http://support.microsoft.com/kb/189181/EN-US/ ) OL98: How to Map Imported Files into Outlook Using Excel

182728  (http://support.microsoft.com/kb/182728/EN-US/ ) OL98: Field Mapping for Importing Not Available
For more information about types of files you can import and export, type "import export" in the Office Assistant, click Search, and then click to view "File types you can import or export from Outlook."

APPLIES TO
  • Microsoft Outlook 98 Standard Edition
Keywords: 
kbexport kbhowto kbimport kbmigrate KB179556
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support