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Article ID: 2028193 - Last Review: September 3, 2013 - Revision: 11.0

Symptoms

When you create a new Microsoft Outlook 2010 profile, you receive the following error:

An unknown error occurred, error code: 0x80070057

This error occurs when Outlook tries to connect with your Microsoft Exchange server. For example, see the following screen shot:

The screen shot for this error.

Cause

This problem occurs when both of the following conditions are true:

  • Your mailbox is located on an Exchange 2003 mailbox server.
  • You are using the Auto Account Setup process to create your Outlook 2010 profile.

Resolution

To resolve this problem, use either of the following solutions.

  • Install the August 31, 2010 hotfix package for Outlook 2010

You can download this hotfix package from the following article in the Microsoft Knowledge Base:

2281463 Description of the Outlook 2010 hotfix package (outlook-x-none.msp): August 31, 2010
http://support.microsoft.com/default.aspx?scid=kb;en-US;2281463

  • Create your profile manually.

To do this, follow these steps:

    1. Open the Mail control panel.
    2. Click Show Profiles.
    3. In the Mail dialog box, click Add.
    4. In the New Profile dialog box, enter a name for your profile, and then click OK.
    5. After you see your display name and email address populated in the Add New E-mail Account dialog box, click to select the Manually configure server settings or additional server types check box, and then click Next. (The screen shot for this step is listed below).

      The screen shot for this step.

    6. In the Choose E-mail Service dialog box, select Microsoft Exchange, and then click Next.
    7. In the Microsoft Exchange Settings dialog box, enter the name of your Exchange server, verify your username is correct, and then click Next.
    8. Click Finish after your profile is successfully created.
    9. In the Mail dialog box, click OK.
    10. Start Outlook.

More Information

When you create an Outlook profile by using the Auto Account Setup process, a Lightweight Directory Access Protocol (LDAP) query is first performed to look up the user who is currently logged on. Then, this user's e-mail address and Exchange server information is returned from Active Directory Domain Services. This LDAP query is successful in Outlook 2010, and the query is not the cause of the error message that is mentioned in the "Symptoms" section.

When you click Next in the Auto Account Setup process to connect with your server and finish creating the profile, Outlook 2010 has some new additional code (This code is not found in Outlook 2007) to make sure that you do not add the same Exchange account two times. This new code assumes that Autodiscover succeeds. And, it pessimistically assumes that if Autodiscover fails, you might be trying to add a duplicate Exchange account. Because Autodiscover is expected to fail in almost all configurations that involve an Exchange 2003 mailbox, this new code generates the 0x80070057 error.

In this scenario, you can force a successful Autodiscover connection by using a local Autodiscover.xml file and some registry data. This registry data forces Outlook to use a local Autodiscover.xml file for Autodiscover queries.

The following is an example Autodiscover.xml file:

<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
  <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <Account>
      <AccountType>email</AccountType>
      <Action>settings</Action>
      <Protocol>
        <Type>EXCH</Type>
        <Server>E2K3.wingtiptoys.com</Server>
      </Protocol>
    </Account>
  </Response>
</Autodiscover>

Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756  How to back up and restore the registry in Windows

To use this workaround, follow these steps:

  1. Create the Autodiscover.xml file by using the example in the More information section of this article as a template. Make sure that you enter your Exchange Server 2003 server name in the <Server> tag.
  2. Save the file to either a local folder on the hard disk or to a network share that everyone can access.
  3. On the Outlook client, deploy the following registry data:

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\AutoDiscover

    DWORD: PreferLocalXML
    Value: 1

    String: the name of your domain

    Value: the path of the Autodiscover.xml file that includes the file name

  4. Create your Outlook profile by using the Auto Account Setup process. 

Applies to
  • Microsoft Outlook 2010
Keywords: 
KB2028193
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