DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 212346 - Last Review: January 24, 2007 - Revision: 3.1

This article was previously published under Q212346
For a Microsoft Word 98 Macintosh Edition version of this article, see 190610  (http://support.microsoft.com/kb/190610/ ) .
For a Microsoft Word 97 version of this article, see 125937  (http://support.microsoft.com/kb/125937/ ) .

On This Page

SUMMARY

This article explains how to create table-of-contents entry fields (TC fields) and build a table of contents. It also explains how to create index entry fields (XE fields) and build an index.

How to create table of contents entry (TC) fields

There are two ways to mark table of contents items: Create a custom menu command or use the keyboard.

Method 1: How to create a custom menu command

Part A: To add the MarkTableofContentsEntry menu command to the Insert menu, follow these steps:
  1. On the Tools menu, click Customize, and then click the Toolbars tab.
  2. Click to select the Menu Bar check box.

    Note This option is selected by default.
  3. In the Customize dialog box, click the Commands tab.
  4. In the Categories list, click All Commands.
  5. In the Commands list, click MarkTableOfContentsEntry, and then drag the command to the Insert menu. Point to the location where you want the command to appear on the menu, and then release the mouse button.
  6. In the Customize dialog box, click Close.
Part B: To mark the text for inclusion in the table of contents, follow these steps:
  1. Select the text that you want to include.
  2. On the Insert menu, click Mark Table Of Contents Entry.
  3. In the Entry box, modify the text if you want it to be different from the selected text.
  4. In the Table identifier list, click C for table of contents.
  5. In the Level list, select a level for the table of contents entry.
  6. Click Mark.
  7. Click Close.
  8. Repeat steps 1 through 7 of this procedure for each table of contents entry in your document.

Method 2: How to use the keyboard

  1. Select the word or words that you want to include as a table of contents entry.
  2. Press ALT+SHIFT+O.

    The Mark Table of Contents Entry dialog box appears.
  3. In the Entry box, modify the text if you want it to be different from the selected text.
  4. In the Table identifier list, click C for table of contents.
  5. In the Level list, select a level for the table of contents entry.
  6. Click Mark.
  7. Click Close.
  8. Repeat steps 1 through 7 for each table of contents entry that you want to create.

How to build the table of contents

To build the table of contents, follow these steps:
  1. Position the insertion point where you want your table of contents to appear.
  2. Word 2003
    On the Insert menu, point to References, and then click Index and Tables.

    Word 2002
    On the Insert menu, click References, and then click Index and Tables.

    Word 2000
    On the Insert menu, click Index and Tables.
  3. Click the Table of Contents tab, and then click the Options button.
  4. Click to select the Table entry fields check box.
  5. Click OK twice.
The table of contents is inserted at the location of the insertion point.

How to create index entry (XE) fields

To mark an index entry, you can use any of the following methods:
  • Use a custom menu command.
  • Use a standard menu command.
  • Use the keyboard.
  • Use a concordance file.

Method 1: How to use a custom menu command

Part A: To add the MarkIndexEntry command to the Insert menu, follow these steps:
  1. On the Tools menu, click Customize, and then click the Toolbars tab.
  2. Click to select the Menu Bar check box.

    Note This option is selected by default.
  3. In the Customize dialog box, click the Commands tab.
  4. In the Categories list, click All Commands.
  5. In the Commands list, click MarkIndexEntry, and then drag the command to the Insert menu. Point to the location where you want the command to appear on the menu, and then release the mouse button.
  6. In the Customize dialog box, click Close.
Part B: To mark the text for inclusion in the index, follow these steps:
  1. Select (highlight) the text that you want to include.
  2. On the Insert menu, click Mark Index Entry.
  3. In the Main entry box, modify the text if you want it to be different from the selected text. Type the Subentry text, and then select the options and page number format that you want.
  4. Click Mark to mark the selected text, or click the Mark All button to mark all occurrences of the selected text.
  5. Click Close.
  6. Repeat steps 1 through 5 for each index entry that you want to create.

Method 2: How to use standard menu commands

To mark the text for inclusion in the index, follow these steps:
  1. Word 2003
    On the Insert menu, point to References, and then click Index and Tables.

    Word 2002
    On the Insert menu, click References, and then click Index and Tables.

    Word 2000
    On the Insert menu, click Index and Tables.
  2. On the Index tab, click the Mark Entry button.
  3. Type the Main entry and Subentry text, and then select the options and page number format that you want.
  4. Click Mark.
  5. Repeat steps 3 and 4 of this procedure for each index entry field that you want to create.
  6. Click Close.

Method 3: How to use the keyboard

To mark the text for inclusion in the index, follow these steps:

  1. Select the word or words that you want to include as an index entry.
  2. Press ALT+SHIFT+X. The Mark Index Entry dialog box appears.
  3. In the Main entry box, modify the text if you want it to be different from the selected text. Type the Subentry text, and select the options and page number format that you want.
  4. Click Mark to mark the selected text, or click Mark All to mark all occurrences of the selected text.
  5. Click Close.
  6. Repeat steps 1 through 5 of this procedure for each index entry field.

Method 4: How to use a concordance file

Use this method when you know which words that you want to index and when you want to index all of those words in the document at once.

To create an index by using a concordance file, follow these steps:
  1. In a new document, insert a two-column table.
  2. In the left column, type the words in your document that you want to mark for indexing.

    Note that these entries are case-sensitive.
  3. In the right column, type the corresponding text that you want to appear in the index.
  4. Save and close this document.
  5. Open the document in which you want to create your index.
  6. Word 2003
    On the Insert menu, point to References, and then click Index and Tables.

    Word 2002
    On the Insert menu, click References, and then click Index and Tables.

    Word 2000
    On the Insert menu, click Index and Tables.
  7. Click the Index tab.
  8. Click AutoMark.
  9. Select the file that you created in steps 1 through 4, and then click Open.
Word automatically marks the words in your document.

How to build the index

To build the index, follow these steps:
  1. Open the document in which you have inserted your index entries, and then position the insertion point where you want your index to appear.
  2. Word 2003
    On the Insert menu, point to References, and then click Index and Tables.

    Word 2002
    On the Insert menu, click References, and then click Index and Tables.

    Word 2000
    On the Insert menu, click Index and Tables.
  3. Click the Index tab, and then click OK.
The index is inserted at the location of the insertion point.

APPLIES TO
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbhowtomaster kbhowto KB212346
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support