DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 223789 - Last Review: January 24, 2007 - Revision: 5.1

This article was previously published under Q223789

On This Page

SUMMARY

This article explains the various methods that you can use to minimize the amount of metadata in your workbooks.

When you create, open, or save a workbook in Microsoft Excel, the workbook may contain content that you do not want to share with others when you distribute the workbook electronically. This information is known as metadata. Metadata is used for a variety of purposes to enhance the editing, viewing, filing, and retrieval of Office documents.

Some metadata is readily accessible through the Excel user interface. Other metadata is only accessible through extraordinary means, such as by opening a workbook in a low-level binary file editor.

The following are some examples of metadata that may be stored in your workbooks:
  • Your name
  • Your initials
  • Your company or organization name
  • The name of your computer
  • The name of the network server or hard disk where you saved the workbook
  • Other file properties and summary information
  • Non-visible portions of embedded OLE objects
  • Document revisions
  • Hidden text or cells
  • Personalized views
  • Comments

MORE INFORMATION

Metadata is created in a variety of ways in Excel workbooks. As a result, there is no single method to remove all such content from your workbooks. The following sections describe areas where metadata may be saved in Excel workbooks.

Install the Latest Update

The following updates are available. For additional information about these updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:
305095  (http://support.microsoft.com/kb/305095/ ) History of Office XP updates
269356  (http://support.microsoft.com/kb/269356/ ) Overview and history of Excel 2000 updates
232652  (http://support.microsoft.com/kb/232652/ ) Overview and history of Excel patches

How to Delete Your User Name from Your Programs

To view or change your user name, follow these steps:
  1. On the Tools menu, click Options. Click the General tab. You see the User name edit box.
  2. If you do not want any of this information to appear in your workbooks, type non-identifying information or spaces in the edit box, and then click OK to accept the changes.
Any new workbooks that you create will contain this information, rather than the default values that you typed when you first installed Office. However, existing workbooks may already contain this information.

How to Remove Personal Summary Information

When you create or save a workbook in Microsoft Excel, summary information may be saved within the workbook. There are several methods that you can use to gain access to this information:
  • Open the workbook. On the File menu, click Properties. The Summary, Statistics, Contents, and Custom tabs may all contain various properties, such as your name, your manager's name, and your company name.
  • In the Windows Explorer, right-click the workbook, and then click Properties on the shortcut menu. The tabs within the Properties dialog box may contain information that you want to remove.
  • You can use a Microsoft Visual Basic for Applications macro or other program code to read the properties shown in the Properties dialog box.
To remove summary information from an existing workbook or template, follow these steps:
  1. Open the workbook or template.
  2. On the File menu, click Properties.
  3. On the Summary tab, delete any text in the Author, Manager, Company, and other edit boxes that you do not want to distribute.
  4. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  5. When you are finished, click OK. On the File menu, click Save.
  6. On the File menu, click Close.
After you complete these steps, the workbook will not contain summary properties.

Removing Personal Summary Information When You Are Connected to a Network

If you are logged on to a network, your network user name may appear in the Author edit box on the Summary tab and in the Last saved by field on the Statistics tab, when you save a workbook. This can occur even if you have removed all other personal information from your computer.

To remove summary information from a workbook when you are on a network, follow these steps:
  1. If the workbook is stored on a network server, copy the workbook to your local hard disk.
  2. Start your computer, but do not log on to your network. When you see the network logon dialog box, click Cancel or press ESC.

    Note If you cannot start Windows by pressing ESC (for example, your computer is running Microsoft Windows NT), you cannot continue these steps.
  3. Open the workbook.
  4. On the File menu, click Properties.
  5. On the Summary tab, delete any text in the Author, Manager, Company, and other edit boxes that contain information that you do not want to distribute.
  6. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  7. When you finish, click OK. On the File menu, click Save.
  8. On the File menu, click Close.
When you log on to the network, do not open the file. If you do, your network user name may be written into the file. However, you can use Windows Explorer to copy the file to either a network server or a floppy disk.

How to Remove Comments in Workbooks

Microsoft Excel offers the ability to add comments to workbooks. Typically, comments contain the name of the person who created them.

In Microsoft Excel, comments appear as a small red triangle in the upper-right corner of a cell. To view comments, right-click the cell, and then click Delete Comment on the shortcut menu.

Any new comments that you create should not contain your user name, because you deleted it from your Options dialog box, as described in the "How to Delete Your User Name from Your Programs" section earlier in this article.

How to Delete Information from Headers and Footers

Headers and footers in workbooks may contain identifying information. To delete information from headers and footers, follow these steps:
  1. Open the workbook.
  2. On the File menu, click Page Setup. Click the Header/Footer tab, and then change the header and footer so that they contain no identifying information.
  3. When you are done, click OK.
Note that each worksheet in a workbook contains its own header and footer, so you must repeat this process on each worksheet.

How to Remove Hyperlinks from Workbooks

Workbooks may contain hyperlinks to other documents or Web pages on either an intranet or the Internet. Hyperlinks usually appear as blue underlined text strings.

To manually delete a single hyperlink from a workbook, right-click the hyperlink, point to Hyperlink on the shortcut menu, and then click Remove Hyperlink.

To delete all hyperlinks in a workbook, you can use a Visual Basic for Applications macro. For additional information about how to write such a macro, click the following article numbers to view the articles in the Microsoft Knowledge Base:
213790  (http://support.microsoft.com/kb/213790/ ) No menu command to select all hyperlinks within a worksheet
156353  (http://support.microsoft.com/kb/156353/ ) No menu choice to select all hyperlinks

How to Remove Styles from Workbooks

Workbooks in Microsoft Excel may include styles that contain metadata. You can remove these styles, or rename them. To do this, follow these steps:
  1. Open the workbook that contains the styles.
  2. On the Format menu, click Style.
  3. Select the style that you want to delete or rename. Click Delete to delete the style, or click in the Style name box and type a new style name to rename the style.

How to Display Hidden Cells, Rows, and Columns in Microsoft Excel Workbooks

In Microsoft Excel, it is possible to hide entire rows and columns of cells within a worksheet.

To unhide all of the cells in a worksheet, follow these steps:
  1. Click the Select All button, in the upper-left corner of the worksheet. Or, press CTRL+SHIFT+SPACE.
  2. On the Format menu, point to Row, and then click Unhide.
  3. On the Format menu, point to Column, and then click Unhide.
All cells are now visible.

Note that a cell may still have its height or width set to a very small value, making the cell hard to see. If this is the case, follow these steps:
  1. Click the Select All button, in the upper-left corner of the worksheet. Or, press CTRL+SHIFT+SPACE.
  2. On the Format menu, point to Row, and then click AutoFit.
  3. On the Format menu, point to Column, and then click AutoFit Selection.
This forces all cells to resize to display their contents.

Note that it is still possible for cell contents to be difficult to see; for example, if cell contents are formatted to use a white font in a cell with a background color that is also white. To change the font properties of selected cells, click Cells on the Format menu, and then click the Font tab.

How to Unhide Hidden Worksheets in Microsoft Excel Workbooks

Workbooks in Microsoft Excel may contain hidden sheets that contain information. To unhide sheets, point to Sheet on the Format menu, and then click Unhide. If a sheet is hidden, you can select the sheet and click OK.

Note If the Unhide command is unavailable, there are either no hidden sheets, or your workbook is protected. On the Tools menu, point to Protection, and then click Unprotect Workbook. If you are prompted for a password, type it to unprotect the workbook.

How to Remove Links from Microsoft Excel Workbooks

Microsoft Excel workbooks may contain formulas that link to cells in other workbooks. If you send a workbook that contains links to another user, they will be able to determine the names of the other workbooks by using the Links dialog box.

To remove links from a workbook, you must remove all references to other workbooks from formulas in your workbook. One way to do this is to follow these steps:
  1. On the Edit menu, click Links.
  2. Select the name of the workbook to which you no longer want to link, and click Change Source.
  3. Select the workbook that you are currently editing; for example, if you are editing C:\Data\Test.xls, select C:\Data\Test.xls. Then, click OK.
  4. Repeat steps 2-3 for any other workbook to which this workbook is linked.
  5. When you are done, click OK.
Note that by performing these steps, you may affect the results of formulas in your workbook; you may even cause some formulas to return incorrect results.

Another method for removing links to other workbooks is to convert formulas into their results. To do this, follow these steps:
  1. Select a cell that contains a formula that links to another workbook.
  2. On the Edit menu, click Copy.
  3. On the Edit menu, click Paste Special. Click Values, and then click OK.
The formula is now gone, but the result of the formula remains.

How to Remove Tracked Changes from Shared Microsoft Excel Workbooks

Microsoft Excel includes a Track Changes feature that allows you to track changes made to a shared workbook by a user. To remove tracked changes from a workbook, follow these steps:
  1. Open the workbook.
  2. On the Tools menu, point to Track Changes, and then click Highlight Changes.
  3. Click to clear (uncheck) the Track changes while editing check box. Click OK.
  4. Click Yes to return the workbook to exclusive use mode (the workbook is no longer shared).

How to Delete Views from Microsoft Excel Workbooks

Custom views in Microsoft Excel workbooks may contain your name, particularly if you are using shared workbooks.

To delete views from a workbook, follow these steps:
  1. On the View menu, click Custom Views.
  2. Select any view that contains your name or other identifying information, and click Delete.
Please note that deleting views may affect how your workbook prints when you use the Report Manager to print reports.

How to Delete Routing Slip Information from a Workbook

If you send a workbook through e-mail by using a routing slip, routing information may be attached to the workbook. To remove this information from the workbook, you must save the workbook in a format that does not retain routing slip information.

In Microsoft Excel, save your workbook in an older file format, such as SYLK, Excel 4.0, or Lotus 1-2-3 format. Close the workbook, and then reopen the new file. Because the routing slip information is no longer present, you can now save your file as a Microsoft Excel workbook.

You can also follow these steps:
  1. On the File menu, point to Send To, and then click Other Routing Recipient.
  2. Click Clear to delete the routing slip. Then, click OK.
  3. On the File menu, click Save.
The workbook is now saved without any routing slip information.

How to Delete E-mail Address Information from a Workbook

Mail Recipient information is retained in the Office document when you send mail by using the File Send option in Microsoft Office XP. Excel 2002 retains the TO, CC, and BCC e-mail addresses when you use the File Send Recipient option and the e-mail header is activated in place for the document.

To remove this information, follow these steps:
  1. With the file open, select Options on the Tools menu.
  2. Select the Security tab, and click to select the Remove personal information from file properties on save check box.
  3. Click the OK button to dismiss the Options dialiog box, and then save your file.
The file is saved without retaining the e-mail addresses.

How to Delete Your Name from Visual Basic Code

When you record a Visual Basic macro in Microsoft Excel, the recorded macro starts with a header that is similar to the following:
   ' Macro1 Macro
   ' Macro recorded 3/11/1999 by J. Doe
				
To remove your name from any macros that you have recorded, follow these steps:
  1. Open the workbook that contains the macros.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor. Or, press ALT+F11.
  3. In the project window, double-click the module that contains the macros.
  4. Delete your name from the recorded macro code.
When you finish, press ALT+Q to return to the program. Then, click Save on the File menu.

How to Delete Visual Basic References to Other Files

In the Visual Basic Editor, you can create a reference to another file. If a user opens a workbook that contains references to other files, the user can see the names of the referenced files.

To delete these references, follow these steps:
  1. Open the workbook that contains the references.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor. Or, press ALT+F11.
  3. On the Tools menu, click References.
  4. Click to clear the check box next to the referenced file. When you finish, click OK to close the References - VBAProject dialog box.
  5. Press ALT+Q.
  6. On the File menu, click Save.
Note Deleting references to other files may impair the ability of macros in your workbook to function correctly.

How to Delete Network or Hard Disk Information from a Workbook

When you save a workbook to your local hard disk or to a network server, information that identifies the local hard disk or network server may be written into the workbook.

To delete this information from the workbook, follow these steps:
  1. Open the workbook.
  2. On the File menu, click Save As. Save the workbook to your floppy disk drive (usually, A:).
  3. On the File menu, click Close.
  4. Remove the floppy disk from your floppy disk drive.
You can now use the Windows Explorer to copy the workbook from the floppy disk to any hard disk or network server.

Note Because of the space limitation of a floppy disk (usually 1.44 MB), this method cannot be used if the workbook file size exceeds the amount of free space on the floppy disk.

Embedded Objects in Workbooks May Contain Metadata

If you embed an object in a workbook, the object still retains its own properties, regardless of what you do to the workbook. For example, if you embed a Microsoft Word document in a Microsoft Excel workbook, the document and the workbook each have their own properties.

You can delete metadata from an embedded object by opening the object, removing any metadata, reactivating the container document (in the previous example, this is the Excel workbook), and then saving the container document.

Note When you open an embedded object in a workbook, only part of the embedded object is displayed in the workbook. The object may contain additional information that does not appear. If you want a workbook to contain only a rendering of the embedded object, and not the actual contents, follow these steps:
  1. Select the object. On the File menu, click Cut.
  2. On the Edit menu, click Paste Special to paste the object into the workbook by using a Metafile format.
After you do this, you cannot edit the embedded object; however, the object will not contain any metadata.

How to Remove Unique Identifiers from Office 97 Documents

Because of the design of the programs that are included in Microsoft Office 97, documents that are created or saved in Office 97 programs may contain a unique identifier. For additional information about these identifiers and how to remove them, click the following article number to view the article in the Microsoft Knowledge Base:
222180  (http://support.microsoft.com/kb/222180/ ) How and why unique identifiers are created in Office documents
Note This unique identifier does not exist in the later versions of Microsoft Office programs.

General Suggestions About Security

The following are some general suggestions that you can use to increase the level of security in your computing environment:
  • When you are not working at your computer, secure the computer with a password-protected screen saver, a power-on password, or the Windows NT lock feature.
  • If your computer has any shared folders, make sure that you apply passwords to the shared folders, so that only authorized users can access your shares. For even better security, use user-level access control, so that you can control exactly who can access your computer's shares.
  • When you delete a file, empty the Recycle Bin immediately. You may want to consider a utility that completely erases or overwrites files when they are deleted.
  • When you back up your data, store the backup files in a secure location, such as a safe, a security deposit box, or a locked cabinet. Store one copy of your backup files at a secure off-site location in case your primary location becomes unusable.
  • Important documents should be password-protected, to ensure that only authorized users can open them. Your passwords should be stored in a secure, separate location. Note that if you cannot recall a password, there is no way to recover the contents of a password-protected document.
  • Do not distribute documents in electronic form. Instead, print them. Do not use identifying elements such as distinctive fonts, watermarks, logos, or special paper, unless necessary (for example, for a presentation).
  • E-mail is not anonymous. Do not e-mail a document if you are concerned about your identity being attached in any way to the document.
  • Do not send a document over the Internet by using either HTTP or FTP protocols. Information that is sent across these protocols is sent in "clear text", which means that it is technically possible (however unlikely) for the information to be intercepted.

For More Information

For additional information about the topics that are discussed in this article, click the following article numbers to view the articles in the Microsoft Knowledge Base:
223396  (http://support.microsoft.com/kb/223396/ ) How to minimize metadata in Office documents
222180  (http://support.microsoft.com/kb/222180/ ) How and why unique identifiers are created in Office documents
314800  (http://support.microsoft.com/kb/314800/ ) How to minimize the amount of metadata in PowerPoint 2002 presentations
314797  (http://support.microsoft.com/kb/314797/ ) How to minimize metadata in Microsoft PowerPoint presentations
223793  (http://support.microsoft.com/kb/223793/ ) How to minimize metadata in Microsoft PowerPoint presentations
290945  (http://support.microsoft.com/kb/290945/ ) How to minimize metadata in Microsoft Word 2002
237361  (http://support.microsoft.com/kb/237361/ ) How to minimize metadata in Microsoft Word 2000 documents
223790  (http://support.microsoft.com/kb/223790/ ) How to minimize metadata in Microsoft Word documents

APPLIES TO
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Keywords: 
kbhowto kbofficeupdate KB223789
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support