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Article ID: 228811 - Last Review: November 1, 2006 - Revision: 1.2

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This article was previously published under Q228811

SYMPTOMS

After you install Windows NT 4.0 Service Pack 4 on your computer running Windows NT, socket-based programs may stop responding (hang). A network trace may show that the TCP/IP packets may not be ordered in the proper sequence.

CAUSE

This behavior is caused by a change in the calculations for random Initial Sequence Numbers (ISN) used in TCP/IP packets. As a result, an ISN may be generated that is less than the current ISN and, as a result, TCP/IP packets may be out of sequential order.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734  (http://support.microsoft.com/kb/152734/EN-US/ ) How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT version 4.0 Service Pack 5.

MORE INFORMATION

For additional information about random Initial Sequence Numbers, please see the following article in the Microsoft Knowledge Base:
192292  (http://support.microsoft.com/kb/192292/EN-US/ ) Unpredictable TCP Sequence Numbers in SP4

APPLIES TO
  • Microsoft Windows NT 4.0 Service Pack 4
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbnetwork kbqfe KB228811
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