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Article ID: 2290390 - Last Review: August 31, 2010 - Revision: 2.1

SYMPTOMS

The SBS 2003 console's performance report or a server status report that has been sent via email may indicate that the Microsoft .NET Framework NGEN v4.0.30319_X86 service is not started despite having an Automatic startup type.

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NGEN Service



CAUSE

This can happen if the Microsoft .NET Framework v4.0 package has been installed on the SBS 2003 server.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Then, click Run in the File Download dialog box and follow the steps in this wizard.


Fix this problem
Microsoft Fix it 50509


Note
this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Let me fix it myself

To resolve this problem yourself, follow these steps:
  1. Locate the C:\inetpub\monitoring\web.config file and make a backup copy of it.
  2. Open the C:\inetpub\monitoring\web.config file with Notepad to edit it.
  3. Locate the SERVICES_TO_IGNORE line in the file. It will look like this:
    <add key="SERVICES_TO_IGNORE" value="SysmonLog" />
  4. Edit this line to add the text ;clr_optimization_v4.0.30319_32 which is the reference to the Microsoft .NET Framework NGEN v4.0.30319_X86 service as shown below.
    <add key="SERVICES_TO_IGNORE" value="SysmonLog;clr_optimization_v4.0.30319_32" />
  5. Save the C:\inetpub\monitoring\web.config file and refresh the performance report in the SBS Console.

MORE INFORMATION

The behavior of the Microsoft .NET Framework NGEN v4.0.30319_X86 service not running even though it has an automatic startup type is normal for this service. If there is nothing for it to do it stops itself automatically.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

APPLIES TO
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Service Pack 1
  • Microsoft Windows Small Business Server 2003 R2 Standard Edition
  • Microsoft Windows Small Business Server 2003 R2 Premium Edition
Keywords: 
kbfixme kbmsifixme KB2290390
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