DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 237361 - Last Review: June 17, 2005 - Revision: 3.0

This article was previously published under Q237361

On This Page

SUMMARY

This step-by-step article explains various methods that you can use to minimize the amount of metadata in your Word documents.

Whenever you create, open, or save a document in Microsoft Word 2000, the document may contain content that you may not want to share with others when you distribute the document electronically. This information is known as "metadata". Metadata is used for a variety of purposes to enhance the editing, viewing, filing, and retrieval of Office documents.

Some metadata is easily accessible through the Microsoft Word user interface; other metadata is only accessible through extraordinary means, such as opening a document in a low-level binary file editor. Here are some examples of metadata that may be stored in your documents:
  • Your name
  • Your initials
  • Your company or organization name
  • The name of your computer
  • The name of the network server or hard disk where you saved the document
  • Other file properties and summary information
  • Non-visible portions of embedded OLE objects
  • The names of previous document authors
  • Document revisions
  • Document versions
  • Template information
  • Hidden text
  • Comments
Metadata is created in a variety of ways in Word documents. As a result, there is no single method to remove all such content from your documents. The following sections describe areas where metadata may be saved in Word documents.

How to Remove Your User Name from Your Documents

To view or change your user name, follow these steps:
  1. Click Options on the Tools menu. Select the User Information tab.

    The following edit boxes appear:
    Name
    Initials
    Mailing Address
  2. If you do not want any of this information to appear in your documents, enter non-identifying strings or spaces in the appropriate edit boxes, and then click OK to accept the changes.
NOTE: Any new documents that you create will contain this information, rather than the default values entered when you installed Office. However, existing documents may already contain this information.

How to Remove Personal Summary Information

When you create or save a document in Word, summary information may be saved in the document. There are several methods you can use to access this information:

  • Open the document. On the File menu, click Properties. The Summary, Statistics, Contents, and Custom tabs may all contain various properties such as your name, your manager's name, and your company name.
  • In the Windows Explorer, right-click the document, and then click Properties on the shortcut menu. The tabs in the Properties dialog box may contain information.
  • It is possible to use a Visual Basic for Applications macro or other program code to read the properties shown in the Properties dialog box.
To clear summary information from an existing document or template, follow these steps:
  1. Open the document or template.
  2. On the File menu, click Properties.
  3. On the Summary tab, clear the Author, Manager, Company, and any other edit boxes that you do not want to distribute.
  4. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  5. When you are finished, click OK. Click Save on the File menu, and then click Close on the File menu.
After you have completed these steps, the document should not contain summary properties.

How to Remove Personal Summary Information When Connected to a Network

If you are logged on to a network, your network user name may appear in the Author edit box on the Summary tab and in the Last saved by field on the Statistics tab, when you save a document. This can occur even if you have removed all other personal information from your computer.

To remove summary information from a document when you are on a network:
  1. If the document is stored on a network server, copy it to your local hard disk.
  2. Start your computer, but do NOT log on to your network. When you see the network logon dialog box, click Cancel or press ESCAPE.

    NOTE: If you cannot start Windows by pressing ESCAPE (for example, your computer is running Windows NT), you cannot continue these steps.
  3. Open the document.
  4. On the File menu, click Properties.
  5. On the Summary tab, clear the Author, Manager, Company, and any other edit boxes that contain information you do not want to distribute.
  6. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  7. When you are finished, click OK. Click Save on the File menu. Then click Close on the File menu.
When you log on to the network, do not open the file. If you do, your network user name may be written into the file. However, you can use the Windows Explorer to copy the file to either a network server or a floppy disk.

How to Remove Comments in Documents

Microsoft Word offers the ability to add comments to documents. Typically, comments contain the name of the person who created them, so that you can tell who wrote them.

Comments typically appear as a highlighted section of text; you can right-click inside the comment, and then click Delete Comment on the shortcut menu.

Any new comments that you create should not contain your user name, because you have removed it from your Options dialog box, as shown earlier.

How to Remove Headers and Footers from Documents

Headers and footers in documents may contain identifying information. To remove information from headers and footers:
  1. On the View menu, click Header and Footer.
  2. The header and footer appear at the top and bottom of each page in your document; change them as you want.
  3. When you are finished, click Close on the Header and Footer toolbar.

How to Remove Revision Marks

Documents can contain revision marks, which allow you to determine who makes specific changes to a document. When you accept or reject revision marks, the revised text is saved in the document, and the revision marks are removed.

To accept or reject revisions:
  1. On the Tools menu, point to Track Changes and then click Accept or Reject Changes.
  2. In the Accept or Reject Changes dialog box, use the two Find buttons to locate specific revisions to individually accept or reject, or click Accept All or Reject All.
  3. When you are finished, click Close.

How to Turn Off Fast Saves

The Fast Saves feature speeds up the process of saving a document by saving only the changes that are made to a document.

Because of the design of the Fast Saves feature, text that you delete from a document may remain in the document, even after you save the document. If you are concerned about deleted text remaining in your documents, you should perform the following steps:

  1. On the Tools menu, click Options.
  2. Select the Save tab.
  3. Click to clear the Allow fast saves check box. Click OK.
For additional information about Fast Saves, please see the following articles in the Microsoft Knowledge Base:
211209  (http://support.microsoft.com/kb/211209/EN-US/ ) WD2000: Opening Word Document in Text Editor Displays Deleted Text
197978  (http://support.microsoft.com/kb/197978/EN-US/ ) WD2000: Frequently Asked Questions About 'Allow Fast Saves'

How to Search for and Remove Text Formatted As Hidden

In Word documents, it is possible to format text as hidden. Because hidden text can contain information you may not want to distribute, you may want to unhide and remove it. To remove all of the text in a document that is formatted as hidden, perform the following steps:

  1. On the Tools menu, click Options. Select the View tab.
  2. Click to select the Hidden text check box, and then click OK.
  3. On the Edit menu, click Replace.
  4. Click the More button to expand the dialog box.
  5. Click in the edit box next to Find what.
  6. Click the Format button, and then click Font. Click to select the Hidden check box, and then click OK.
  7. Click Replace All.
All hidden text is removed from the document. To turn off the display of hidden text, perform the following steps:
  1. On the Tools menu, click Options. Select the View tab.
  2. Click to clear the Hidden text check box. Click OK.

How to Remove Hyperlinks from Documents

Documents may contain hyperlinks to other documents or Web pages on an intranet or the Internet. Hyperlinks typically appear as blue underlined text strings.

To manually delete a single hyperlink from a document, right-click the hyperlink, point to Hyperlink on the shortcut menu, and then click Remove Hyperlink.

If you want to delete all hyperlinks in a document, you can use a Visual Basic for Applications macro to do this. The following sample Visual Basic for Applications macro removes all hyperlinks in a document.

NOTE: In the following sample macro, only the link is removed. The text of the hyperlink remains in the document.

Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
    For Each oHlink In oStory.Hyperlinks
        oHlink.Delete
    Next
Next

End Sub
				
To remove all traces of both the hyperlink and the text of the hyperlink from the document, you can use the following sample macro instead.
Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
    For Each oHlink In oStory.Hyperlinks
        oHlink.Range.Delete
    Next
Next

End Sub
				
For more information about how to use the sample code in this article, click the article number below to view the article in the Microsoft Knowledge Base:
212536  (http://support.microsoft.com/kb/212536/EN-US/ ) OFF2000: How to Run Sample Code from Knowledge Base Articles

How to Remove Styles from Documents

Documents may include styles that contain metadata. You can remove these styles or rename them. To do this:
  1. Open the document that contains the styles.
  2. On the Format menu, click Style.
  3. Select the style that you want to delete or rename. Click Delete to delete the style, or click Modify to rename it.

How to Remove Old File Versions from Documents

Word includes a file version feature that allows you to save multiple versions of the same document in the same file. You may want to delete older versions of the document before you share it with others.

To delete one or more versions of a document, perform the following steps:
  1. On the File menu, click Versions.
  2. Select the version of the document that you want to delete. You can select more than one version by pressing the CTRL key while you select the versions.
  3. Click Delete.
  4. When you are finished deleting old versions of the document, click Save on the File menu.

How to Remove Links from Field Codes

Linked images and other objects in Word documents may contain linking information, such as the path to the linked image or object. You can remove linking information from your document by editing the field codes.

To display field codes:

  1. On the Tools menu, click Options. Select the View tab.
  2. Click to select the Field codes check box. Click OK.
After field codes are visible, you can see whether any of them contain identifying information.

To remove the linking information from a linked image or other object:
  1. Select the linked image or object. Or select the field code for the image or object, if field codes are visible.
  2. Press CTRL+SHIFT+F9.
The image or object is now unlinked. Note that unlinking an image or object may cause it to be uneditable.

How to Remove the Template Name and Location

All documents created in Word are based on a template. By default, this is the Normal.dot template file, located in the Templates folder. However, you can create a document that is based on a different template in another location. The path and name of this template are stored in the document's properties.

To view the template name and location, click Properties on the File menu and select the Summary tab.

Even if you do not send the template with the document, the document retains the name and location of the template. To change the template name and location to non-identifying values, do the following:
  1. On the Tools menu, click Templates and Add-Ins.
  2. Click Attach.
  3. Select a template that has a name and location that are not sensitive or unique. For example, because every computer that has Microsoft Word installed includes Normal.dot, you may want to select Normal.dot.
  4. Click Open. Then click OK.
NOTE: The template may contain macros, autotext entries, custom styles, and custom toolbars. Changing templates may make some of these items unavailable to your document.

How to Remove Routing Slip Information

If you send a document through e-mail using a routing slip, routing information may be attached to the document. To remove this information from the document, you must save the document in a format that does not retain routing slip information.

In Microsoft Word, save your document in either RTF (Rich Text Format) or HTML format. Close the document, and then reopen the new file. Because the routing slip information is no longer present, you can now save your document in the Microsoft Word format.

You can also use the following steps:
  1. Turn off Allow fast saves using the instructions earlier in this article.
  2. On the File menu, point to Send to, and then click Other Routing Recipient.
  3. Click Clear to remove the routing slip. Then click OK.
  4. On the File menu, click Save.
The document is now saved without any routing slip information.

How to Remove the Names of Previous Authors

Word stores the names of the last 10 people who worked on a document in the document. This is an automatic feature that cannot be turned off.

However, you can remove the names of the last 10 authors from a document by saving the document in a format that does not retain such information. For example, if you save the document in either RTF (Rich Text Format) or HTML format, the authoring information is lost. You can then close and reopen the RTF/HTML document and save it in Microsoft Word format.

How to Remove Your Name from Visual Basic Code

When you record a Visual Basic macro in Word, the recorded macro begins with a header similar to the following:

   ' Macro1 Macro
   ' Macro recorded 3/11/1999 by <User Name>
				
To remove your name from any macros that you have recorded:
  1. Open the document that contains the macros.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor. Or press ALT+F11.
  3. In the project window, double-click the module that contains the macros.
  4. Remove your name from the recorded macro code.
When you are finished removing your name, press ALT+Q to return to the program. Then click Save on the File menu.

How to Remove Visual Basic References to Other Files

In the Visual Basic Editor, it is possible to create a reference to another file. If a user opens a document that contains references to other files, the user can see the names of the referenced files.

To remove these references, do the following:
  1. Open the document that contains references.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor. Or press ALT+F11.
  3. On the Tools menu, click References.
  4. Click to clear the check box next to the referenced file or files. When you are finished, click OK.
  5. Press ALT+Q.
  6. On the File menu, click Save.
NOTE: Removing references to other files may reduce the ability of macros in your document to function correctly.

How to Remove Network or Hard Disk Information

When you save a document to your local hard disk or to a network server, information that identifies the local hard disk or network server may be written into the document.

To remove this information from the document, follow these steps:
  1. Open the document.
  2. On the File menu, click Save As. Save the document to your floppy disk drive (typically, A:).
  3. On the File menu, click Close.
  4. Remove the floppy disk from your floppy disk drive.
You can now use the Windows Explorer to copy the document from the floppy disk to any hard disk or network server.

NOTE: Due to the space limitation of a floppy disk (typically 1.44 MB), this method cannot be used if the document file size exceeds the amount of free space on the floppy disk.

Embedded Objects in Documents May Contain Metadata

If you embed an object in a document, the object still retains its own properties, regardless of what you do to the document. For example, if you embed a Microsoft Excel workbook in a Word document, the document and the workbook each has its own properties.

You can remove metadata from an embedded object by activating the object, removing any metadata as described earlier, reactivating the container document (using the earlier example, this is the Word document), and then saving the container document.

NOTE: When you activate an embedded object in a document, only part of the embedded object is displayed in the document; the object may contain additional information that does not appear. If you want a document to contain only a rendering of the embedded object and not the actual contents, cut the object and then use the Paste Special command on the Edit menu to paste the object into the document using a Metafile format. After you do this, you can no longer edit the embedded object; however, it will not contain any metadata.

Document Variables May Contain Metadata

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements.
For more information about how to use the sample code in this article, click the article number below to view the article in the Microsoft Knowledge Base:
212536  (http://support.microsoft.com/kb/212536/EN-US/ ) OFF2000: How to Run Sample Code from Knowledge Base Articles
To delete the document variables contained in your Word document, use the following example macro:
Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

   For Each myVar In ActiveDocument.Variables
      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
         "Value: " & myVar.Value & vbCr & vbCr & _
         "Do you want to delete the variable from this document?", vbYesNo)
            
      If Response = "6" Then
         ' Delete the variable.
         myVar.Delete
      Else
         End
      End If
   Next myVar
            
   MsgBox "There are no variables in the document."
   
End Sub
				
For more information about variables, in the Visual Basic Editor, click Microsoft Visual Basic Help on the Help menu, type Variables Property in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

General Suggestions About Security

Here are some general suggestions that you can use to increase the level of security in your computing environment:
  • Whenever you are not at your computer, secure it with a password-protected screen saver, power-on password, or the Windows NT lock feature.
  • If your computer has any shared folders, make sure you apply passwords to them so that only authorized users can access your shares. For even better security, use user-level access control, so that you can control exactly who can access your computer's shares.
  • When you delete a file, empty the Recycle Bin immediately. You may want to consider a utility that completely erases or overwrites files when they are deleted.
  • When you back up your data, store the backup files in a secure location, such as a safe, a security deposit box, or a locked cabinet. Store one copy of your backups at a secure off-site location in case your primary location is unusable.
  • Important documents should be password-protected, to make sure that only authorized users can open them. Your passwords should be stored in a secure, separate location. Note that if you cannot recall a password, there is no way to recover the contents of a password-protected document.
  • Do not distribute documents in electronic form. Instead, print them out. Do not use identifying elements such as distinctive fonts, watermarks, logos, or special paper, unless you need to (for example, for a presentation).
  • E-mail is NOT anonymous. Do not e-mail a document if you are concerned about your identity being attached in any way to the document.
  • Do not send a document over the Internet using either the HTTP or FTP protocol. Information sent across these protocols is sent in "clear text", which means that it's technically possible (however unlikely) for it to be intercepted.

REFERENCES

For More Information

For more information related to the topics discussed earlier in this article, please see the following articles in the Microsoft Knowledge Base:
195007  (http://support.microsoft.com/kb/195007/ ) WD2000: Some Document Properties Are Populated Automatically
194606  (http://support.microsoft.com/kb/194606/EN-US/ ) WD2000: Summary Information Under Properties Is Not Encrypted
209638  (http://support.microsoft.com/kb/209638/ ) WD: No Password Prompt for "Modify" in Mail Client

APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbhowto kbopenfile kbsavefile KB237361
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support