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Article ID: 240362 - Last Review: March 1, 2007 - Revision: 2.4

This article was previously published under Q240362
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .

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SYMPTOMS

When you start a Windows 2000-based domain controller, you may receive the following Lsass.exe error message:
Directory Services could not start because of the following error: The system cannot find the file specified. Error Status: 0xc000000f. Please click OK to shutdown the system and reboot into the Directory Services Restore Mode, check the event log for more detailed information.

CAUSE

This behavior can occur if the Ntds.dit file is missing from the location you specified during the promotion process. By default, the location is the %SystemRoot%\NTDS folder. If the Ntds.dit file is missing, it cannot be re-created or refreshed by other domain controllers, and you cannot log on to Windows 2000 normally. The Ntds.dit file contains your Active Directory, including user accounts.

RESOLUTION

To resolve this issue, restore the Ntds.dit file to the appropriate location, using either of the following methods:

Method 1: Restoring the Ntds.dit File from Windows 2000 Backup

  1. Click OK to reboot the domain controller, choose the appropriate installation from the Boot menu, and then press F8 to display the Windows 2000 Advanced Options menu.
  2. Choose Directory Services Restore Mode, and then press ENTER. Choose the correct installation, and then press ENTER to start the boot process.
  3. At the logon screen, log on using the Administrator account and password you specified during the promotion process. When you run Dcpromo.exe to install Active Directory, there is a screen to set the Administrator password for Active Directory Restore Mode. This is the password that should be used for this logon attempt.
  4. Click OK to acknowledge the warning message indicating you are using Safe mode.
  5. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Backup.

    NOTE: If you are using third-party backup software, use that program's method of restoring files.
  6. Click the Restore tab.
  7. Click the plus sign (+) next to the following items to expand them: File, Media Created, System Drive (C:), Winnt, and NTDS.
  8. Click the NTDS folder to display all of the files.
  9. Click to select the Ntds.dit check box.
  10. Leave the Restore files to box set to Original Location. This box provides the option to restore to an alternative location if you want to restore and then copy to the original location described in the next method.
  11. Click Start Restore.

Method 2: Copying the Ntds.dit File to the Correct Location

  1. Click OK to reboot the domain controller, choose the appropriate installation from the Boot menu, and then press F8 to display the Windows 2000 Advanced Options menu.
  2. Choose Directory Services Restore Mode, and then press ENTER. Choose the correct installation, and then press ENTER to start the boot process.
  3. At the logon screen, log on using the Administrator account with the password you defined during the promotion process for Active Directory Restore mode.
  4. Locate a good copy of the Ntds.dit file from a backup location.
  5. Copy the file into the %SystemRoot%\NTDS folder.

    NOTE: If the default location was changed during the promotion process, place the Ntds.dit file in that location.

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kberrmsg kbprb KB240362
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