DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2435284 - Last Review: August 9, 2012 - Revision: 8.0

Symptoms

You have a running User Profile synchronization Service, configured with an Active Directory connection and in addition a Business Data Catalog (BDC or also known as Business Connectivity Service - BCS). You have the User profiles from the Active Dirtectory connection mapped to the Business Data Catalog by using the "Work Email" property to fill in additonal properties from the BDC into the Profile Import. After the first Full Import the Synchronization Service get stuck and in Application Event log you will find the following Error:

Event Log: Application
Event Type: Error 
Event Source: FIMSynchronizationService
Event Category: Server 
Event ID: 6301 
Date: [ Date ] 
Time: [ Timestamp ] 
User: UserName
Computer: HostName 
Description: 

BAIL: MMS(7824): eafam.cpp(1295): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): eafam.cpp(943): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): eafam.cpp(1010): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): amexec.cpp(1630): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): amexec.cpp(2018): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): eaf.cpp(1373): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): eaf.cpp(653): 0x80230304 (The image or dimage already has an attribute with that name.)
ERR: MMS(7824): synccoreimp.cpp(5211): 0x80230304 - export-flow failed 0x80230304
BAIL: MMS(7824): synccoreimp.cpp(5212): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(4816): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(10567): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(10313): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(2524): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(4333): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(8485): 0x80230304 (The image or dimage already has an attribute with that name.)
BAIL: MMS(7824): synccoreimp.cpp(3802): 0x80230304 (The image or dimage already has an attribute with that name.)
ERR: MMS(7824): synccoreimp.cpp(3818): 0x80230304 - CS to MV to CS synchronization failed 0x80230304: [CN=Doe\\\, John\,OU\=Contractors\,OU\=DE\,DC\=MYDOM\,DC\=com]
BAIL: MMS(7824): synccoreimp.cpp(3623): 0x80230304 (The image or dimage already has an attribute with that name.)
ERR: MMS(7824): syncmonitor.cpp(2512): SE: Rollback SQL transaction for: 0x80230304
MMS(7824): SE: CS image begin
MMS(7824): <cs-object cs-dn="CN=Doe\\\, John\,OU\=Contractors\,OU\=DE\,DC\=MYDOM\,DC\=com" id="{E0D54E69-ACB2-4A66-9C7F-E37813CC3A09}" object-type="BDC User">
 <unapplied-export>
  <delta operation="none" dn="CN=Doe\\\, John\,OU\=Contractors\,OU\=DE\,DC\=MYDOM\,DC\=com">
   <anchor encoding="base64">iAAAAEMATgA9AFAAaQBlAHAAZQByAFwALAAgAEwAdQB0AHoALABPAFUAPQBDAG8AbgB0AHIAYQBjAHQAbwByAHMAXwBCAGUAZgByAGkAcwB0AGUAdABlACwATwBVAD0ARABFACwARABDAD0AbgBkAHMAYQB0AGMAbwBtACwARABDAD0AYwBvAG0AAAA=</anchor>
  </delta>
 </unapplied-export>  
[....]

This Error will be logged for each User from Import.

Cause

This is expected behavior at the time of creation of this article. Here it is related to the "Title" field in User profile property in SharePoint. 
This error occurs when you try to flow 2 metaverse attributes to the same attribute in the connected directory. Since The 'Title' and 'SPS_title fields' are indeed mapped in FIM Internally, another mapping to the 'Title' field via BCS is not allowed. Usually the ForeFront User Interface does not allow this but the SharePoint UI does and hence the issue. If you need to Import the 'Title' field from a BCS source create a New custom Property and map it accordingly . 

Resolution

To workaround this issue, please follow the steps below to remove the Mapping for 'Title' property with a BCS field :
  1. In SharePoint Server 2010, click Central Administration in the navigation pane, and then click Manage service applications on the Application Management menu.
  2. Select User Profile Service Application, and in the Ribbon bar, click Manage to reach the Manage Profile Service page
  3. In the People section, click Manage User Properties
  4. Under Basic Information section find the title property and click on Edit
  5. On the Edit User Profile Property page, scroll down to the section Policy Mapping for Syncronization  and remove all mappings which are present  
  6. Click on Ok to Save. 
  7. lease start a new Full Import via Central Administration - Manage service applications -  User Profile Service Application - Manage Profile Service page.


More information

For more information about how to configure the User Profile Synchronization service, visit the following TechNet articles: 

General information about how to configure profile synchronization (http://technet.microsoft.com/en-us/library/ff182925.aspx)
Configure profile synchronization (SharePoint Server 2010) (http://technet.microsoft.com/en-us/library/ee721049.aspx)


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Microsoft SharePoint Server 2010
Keywords: 
KB2435284
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support