DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2471430 - Last Review: February 9, 2011 - Revision: 1.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

SYMPTOMS

Consider the following scenario:
  • You restore large data files in an NTFS file system on a computer that is running Windows Server 2008 or Windows Vista.
  • All the sparse data streams of the files are removed.
  • The sparse attribute of the files are not removed.
  • The left sparse attribute information is large enough to exceed the restoring limitation of the NTFS file system.
In this scenario, the restore operation fails, and the data in the data files is lost. Additionally, the following events are logged in the System log:


Event Type: Warning
Event Source: Ntfs
Event Category: None
Event ID: 50
Computer: <Computer name>
Description: {Delayed Write Failed} Windows was unable to save all the data for the file. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

Additionally, the following event is logged in the Application log:


Event ID: 26
Category: None
Source: Application Popup
Type: Information
Machine : <Computer name>
Message: Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file <file name> The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.


CAUSE

This issue occurs because the sparse attribute of a file remains on an NTFS file system after you delete all data streams that have a sparse attribute from the file.

NTFS supports additional named data streams. When an additional named data stream that has a sparse attribute is added to a file, the sparse attribute is also set for the file. However, the sparse attribute for the file remains if you remove all the data streams that have a sparse attribute from the file. Therefore, the restored file is displayed as a sparse file when you perform a backup and restore operation on the file. This issue occurs even if the file does not have data streams that have sparse attributes.

When you restore the sparse file, NTFS handles the file as a fragmented file. If the sparse file size is too large, the system resources are insufficient to complete the restore operation. This issue occurs because the sparse attribute of a file remains on the NTFS file system after you delete all data streams that have a sparse attribute from the file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849  (http://support.microsoft.com/kb/968849/ ) How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

To use the hotfix in this package, you do not have to make any changes to the registry.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.0.6001.228081,079,69610-Dec-201008:21x86
Ntfs.sys6.0.6002.225441,082,25610-Dec-201008:21x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.0.6001.228081,524,62410-Dec-201008:17x64
Ntfs.sys6.0.6002.225441,505,16810-Dec-201008:17x64
For all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys6.0.6001.228083,281,29610-Dec-201008:09IA-64
Ntfs.sys6.0.6002.225443,283,34410-Dec-201008:09IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This issue does not occur in Windows Server 2008 R2.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
973886  (http://support.microsoft.com/kb/973886/ ) You cannot restore large files in the NTFS file system when all the data streams that have sparse attributes are deleted in the 64-bit version of Windows XP SP2 or in Windows Server 2003 SP2
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameX86_30d38e6eeb83a7ea8cb3c002f05cdaed_31bf3856ad364e35_6.0.6001.22808_none_d7bdc7aba8084b57.manifest
File versionNot applicable
File size692
Date (UTC)10-Dec-2010
Time (UTC)08:25
PlatformNot applicable
File nameX86_ba684f6eea5dd6215e8aa3ab782199b7_31bf3856ad364e35_6.0.6002.22544_none_14597067d8dd7407.manifest
File versionNot applicable
File size692
Date (UTC)10-Dec-2010
Time (UTC)08:25
PlatformNot applicable
File nameX86_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6001.22808_none_a702d6223601f026.manifest
File versionNot applicable
File size16,841
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
File nameX86_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6002.22544_none_a8ba0732334c4fb2.manifest
File versionNot applicable
File size16,841
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_0a9f0383a67bab20b10aeba5644b7dd5_31bf3856ad364e35_6.0.6001.22808_none_2493e6ae1526a7fe.manifest
File versionNot applicable
File size696
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
File nameAmd64_5be1486f87bbc939549fea513f4b6c30_31bf3856ad364e35_6.0.6002.22544_none_f0f5486c21a9795d.manifest
File versionNot applicable
File size696
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6001.22808_none_032171a5ee5f615c.manifest
File versionNot applicable
File size17,104
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
File nameAmd64_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6002.22544_none_04d8a2b5eba9c0e8.manifest
File versionNot applicable
File size17,104
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_5eaf29ab2fc5c8b3e9fa3dc4d116b239_31bf3856ad364e35_6.0.6002.22544_none_d610e40827786f00.manifest
File versionNot applicable
File size694
Date (UTC)10-Dec-2010
Time (UTC)08:25
PlatformNot applicable
File nameIa64_f961d4d59d589c82caeb77ec69fcaa99_31bf3856ad364e35_6.0.6001.22808_none_0019ee17af5375be.manifest
File versionNot applicable
File size694
Date (UTC)10-Dec-2010
Time (UTC)08:25
PlatformNot applicable
File nameIa64_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6001.22808_none_a7047a1835fff922.manifest
File versionNot applicable
File size17,096
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable
File nameIa64_microsoft-windows-ntfs_31bf3856ad364e35_6.0.6002.22544_none_a8bbab28334a58ae.manifest
File versionNot applicable
File size17,096
Date (UTC)10-Dec-2010
Time (UTC)08:26
PlatformNot applicable

APPLIES TO
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Foundation
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced KB2471430
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support