DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2522454 - Last Review: September 30, 2013 - Revision: 6.2

Symptoms

The Lync Server Setup or Remove Component installation fails on the prerequisite check for the Media-Format-Package and returns the following information back to the Setup Lync Server components page:

Name of prerequisite: Wmf2008R2 MM/DD/YYYY HH:MM:SS AM
Name of prerequisite: Wmf2008R2 MM/DD/YYYY HH:MM:SS AM
Type of prerequisite: exe MM/DD/YYYY HH:MM:SS AM
Method used to check prerequisite state: WmfNeeded2008R2() MM/DD/YYYY HH:MM:SS AM
Result of state check: True MM/DD/YYYY HH:MM:SS AM
Executing external command: C:\Windows\system32\dism.exe /online /norestart /add-package
/packagepath:C:\Windows\servicing\Packages\Microsoft-Windows-Media-Format-
Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum /ignorecheck MM/DD/YYYY HH:MM:SS AM
Installation result: -2146762496 MM/DD/YYYY HH:MM:SS AM
Error: Prerequisite installation failed: Wmf2008R2
Details
Type: PrereqInstallFailed
Stack Trace
at Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.AddMsiPrereq(String prereqName)
at Microsoft.Rtc.Management.Internal.Utilities.LogWriter.InvokeAndLog[T](Action`1 action, T arg)
Type of prerequisite: exe MM/DD/YYYY HH:MM:SS AM
Method used to check prerequisite state: WmfNeeded2008R2() MM/DD/YYYY HH:MM:SS AM
Result of state check: True MM/DD/YYYY HH:MM:SS AM
Executing external command: C:\Windows\system32\dism.exe /online /norestart /add-package
/packagepath:C:\Windows\servicing\Packages\Microsoft-Windows-Media-Format-
Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum /ignorecheck MM/DD/YYYY HH:MM:SS AM
Installation result: -2146762496 MM/DD/YYYY HH:MM:SS AM
Error: Prerequisite installation failed: Wmf2008R2
Details
Type: PrereqInstallFailed
Stack Trace
at Microsoft.Rtc.Internal.Tools.Bootstrapper.BootstrapperTask.AddMsiPrereq(String prereqName)
at Microsoft.Rtc.Management.Internal.Utilities.LogWriter.InvokeAndLog[T](Action`1 action, T arg)

Cause

The Lync Server Setup or Remove Component installation prerequisite check cannot locate the Server 2008 R2 SP1 version of Microsoft Windows Media Format or the Server 2012 version of the Microsoft Media Foundation.

Note The content of the error information in the Symptoms section of this article may vary based on the combinations of Windows Server and Lync Server installations.

Resolution

To resolve this problem with Server 2012, install Windows Desktop Experience. To do this, follow these steps:

  1. Press the Windows function key to access the Start page
  2. Click on the Server Manager tile
  3. On the Server Manager Local Server dashboard, click on the Manage menu
  4. Click on Add Roles and Features to access the Add Roles and Features Wizard
  5. Click on the Next button
  6. Select the Role-based or feature-based installation, click on the Next button
  7. Select the Fully Qualified Domain Name (FQDN)of the Lync Server role based server that requires the feature update, click on the next button twice
  8. Use the Features pane to locate Media Foundation. If Media Foundation is not installed then check it
  9. Use the Features pane to locate User Interfaces and Infrastructure and click the arrow next to it to expand it
  10. If Desktop Experience is not installed then check it, click on the Next button

    Note The installation of the Desktop Experience requires a re-start of the computer

  11. Review the Confirm installation selections page and check Restart the destination server automatically if require option, if it is a convenient time to restart the Server 2012 server

To resolve this problem with Server 2008 R2 SP1, install Windows Desktop Experience. To do this, follow these steps: 
  1. Click Start, click Administrative Tools, and then double-click Server Manager
  2. In Server Manager, click Add Features under Features Summary
  3. In the Add Features Wizard dialog box, make sure that the Desktop Experience option is selected
  4. Click Next, and then click Install
  5. After the installation process is complete, click Close, and then close Server Manager
Note After you install Windows Desktop Experience, you must restart the computer

More information

All Front End Servers and Standard Edition servers where conferencing will be deployed must have the Windows Media Format Runtime installed, which, except for Windows Server 2012 is installed as part of the Windows desktop experience. The Windows Media Format Runtime is required to run the Windows Media Audio (.wma) files that the Lync Server Call Park, Announcement, and Response Group applications play for announcements and music. In comparison Windows Server 2012 requires the installation of Microsoft Media Foundation. We recommend that you install Windows desktop experience or Microsoft Media Foundation before you install Lync Server 2010 or Lync Server 2013. If Lync Server does not find this software on the server, it will prompt you to install it, and then you must restart the server to complete installation.

Note Issuing the steps listed in the Resolution section of this article requires the equivalent permissions of the Windows server-based computers Local Administrator account.

For more details on the Lync Server 2013 or Lync Server 2010 software requirements for conferencing see the Software Requirements section of the following article:


Technical Requirements for Conferencing (http://technet.microsoft.com/en-us/library/gg425889.aspx)

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Microsoft Lync Server 2010 Enterprise Edition
  • Microsoft Lync Server 2010 Standard Edition
  • Microsoft Lync Server 2013
Keywords: 
kbsurveynew kbsmbportal kbtshoot kbexpertiseinter KB2522454
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support