DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2606504 - Last Review: August 13, 2012 - Revision: 3.0

 
Collapse this imageExpand this image
View all Step by Step technical articles (http://support.microsoft.com/gp/sbs_index/ko)

Symptoms

There is no reaction of language switch key in language bar, or the language bar disappears and unable to switch the input language from Korean to English in Windows 7 and Windows Vista.


Cause

Following issues can cause problems.
  • There is an error in registering the library module relating to language bar.
  • task scheduler service is stopped or MSCtfMonitordid not run.


How do I fix

Method 1: reregister the library module relating to language bar

  1. Click [Start]
    Collapse this imageExpand this image
    and enter cmdIn the search window.

    Collapse this imageExpand this image


  2. Right-click [cmd] in the list of program lists, and click [Run as Administrator].

    Collapse this imageExpand this image

    Collapse this tableExpand this table
    Collapse this imageExpand this image
    When the user account control message appears, type the administrator password, or click [Yes].

  3. Type egsvr32.exe msimtf.dll at the command prompt screen, and then press Enter.

    Collapse this imageExpand this image

    Collapse this tableExpand this table
    Collapse this imageExpand this image
    "When you receive the message "DllRegisterServer in msimtf.dll is successful.", click [OK].

  4. Type regsvr32.exe msctf.dll and then press Enter.

    Collapse this imageExpand this image

    Collapse this tableExpand this table
    Collapse this imageExpand this image
    "When you receive the message "DllRegisterServer in the msctf.dll is successful." click [OK].

  5. Type exitand then press Enter to close the command prompt.

    Collapse this imageExpand this image


  6. Restart your computer and check if the problem is solved.



Method 2: start the task scheduler service, and then run MSCtfMonitor.

Please see the following technical article to solve the problem.




Send us feedback

Collapse this tableExpand this table
Collapse this imageExpand this image

Microsoft Support site is listening carefully to your opinion. Please send your valuable comments by the following send your opinion.

Applies to
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbstepbystep kbtshoot kbvideocontent kbmt KB2606504 KbMten
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support