DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2639505 - Last Review: January 4, 2013 - Revision: 2.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

Symptoms

Assume that you run a service which queries the Win32_StartupCommand Windows Management Instrumentation (WMI) class on a computer that is running Windows Vista, Windows Server 2008, Windows 7, or Windows Server 2008 R2.

In this situation, all loaded user profiles occasionally cannot be unloaded successfully after the WMI query is finished. If the number of unloaded user profiles keeps increasing, the system resources may be exhausted. For example, the virtual address control block (VACB) may be exhausted.

Here is a sample scenario:
  • You run a service on a computer that is running Windows Server 2008.
  • The service queries the Win32_QuickFixEngineering WMI class first.
  • The service then queries the Win32_StartupCommand WMI class.
In this scenario, all loaded user profiles cannot be unloaded. If you open the HKEY_USERS registry subtree by using an administrator account, you find that the user profiles are still loaded.

Note You can obtain more information about the loaded user profiles from the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

Cause

The issue occurs because a cached handle for the HKEY_USERS registry subtree prevents the Wmiprvse.exe process from being able to unload the user profiles.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791  (http://support.microsoft.com/kb/935791/ ) How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849  (http://support.microsoft.com/kb/968849/ ) How to obtain the latest service pack for Windows Server 2008
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932  (http://support.microsoft.com/kb/976932/ ) Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.0.6002.227451,373,69623-Nov-201115:36x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.0.6002.227452,104,83223-Nov-201115:24x64
For all supported IA-64–based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.0.6002.227454,315,64823-Nov-201115:17IA-64
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.210951,341,44022-Nov-201105:36x86
Cimwin32.dll6.1.7601.218641,342,97622-Nov-201105:24x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.210952,055,68022-Nov-201106:42x64
Cimwin32.dll6.1.7601.218642,058,75222-Nov-201106:23x64
For all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll6.1.7600.210954,280,32022-Nov-201105:28IA-64
Cimwin32.dll6.1.7601.218644,280,32022-Nov-201105:13IA-64

Workaround

To work around this issue, run any program by using the credentials of the affected user profiles.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information about predefined keys, visit the following Micrososft website:
General information about predefined keys (http://msdn.microsoft.com/en-us/library/ms724836(v=VS.85).aspx)
For more information about the Win32_StartupCommand class, visit the following Micrososft website:
General information about the Win32_StartupCommand class (http://msdn.microsoft.com/en-us/library/windows/desktop/aa394464(v=vs.85).aspx)
For more information about the Win32_QuickFixEngineering class, visit the following Micrososft website:
General information about the Win32_QuickFixEngineering class (http://msdn.microsoft.com/en-us/library/windows/desktop/aa394391(v=vs.85).aspx)

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size3,078
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable
File nameX86_6604d0c23808c9cc4ca3a3c3f9185767_31bf3856ad364e35_6.0.6002.22745_none_8d926c5c626f9ee1.manifest
File versionNot applicable
File size719
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable
File nameX86_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.0.6002.22745_none_d1f4d2bc1c6f9549.manifest
File versionNot applicable
File size14,346
Date (UTC)23-Nov-2011
Time (UTC)16:01
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
Collapse this tableExpand this table
File nameAmd64_b1d9b444a5d2a45ef161b54219bb557a_31bf3856ad364e35_6.0.6002.22745_none_7ca1467cd34a41f1.manifest
File versionNot applicable
File size723
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable
File nameAmd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.0.6002.22745_none_2e136e3fd4cd067f.manifest
File versionNot applicable
File size14,679
Date (UTC)23-Nov-2011
Time (UTC)15:46
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,102
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_9e5a2babc02d196448ddbb92a4ec9555_31bf3856ad364e35_6.0.6002.22745_none_d05ee0e32f4656ab.manifest
File versionNot applicable
File size721
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable
File nameIa64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.0.6002.22745_none_d1f676b21c6d9e45.manifest
File versionNot applicable
File size14,648
Date (UTC)23-Nov-2011
Time (UTC)15:31
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,255
Date (UTC)24-Nov-2011
Time (UTC)05:52
PlatformNot applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size2,661
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameX86_6e5775210b8a15d604fb0d1fd2697f29_31bf3856ad364e35_6.1.7601.21864_none_523312d7472b4b00.manifest
File versionNot applicable
File size719
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameX86_a8cba47d488da6ae18386d97da192c67_31bf3856ad364e35_6.1.7600.21095_none_a37feeb4304d5c8c.manifest
File versionNot applicable
File size719
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameX86_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.21095_none_cffff5d3808941b6.manifest
File versionNot applicable
File size5,224
Date (UTC)22-Nov-2011
Time (UTC)06:18
PlatformNot applicable
File nameX86_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21864_none_d205ec177d980a5d.manifest
File versionNot applicable
File size5,224
Date (UTC)22-Nov-2011
Time (UTC)06:10
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_5e41e5f078758f8e850f70a632c10840_31bf3856ad364e35_6.1.7601.21864_none_115a4ee2e67c75d4.manifest
File versionNot applicable
File size723
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameAmd64_e6058066e24fb6be7b650f7dfdb3cdd5_31bf3856ad364e35_6.1.7600.21095_none_88145d391b6f8a70.manifest
File versionNot applicable
File size723
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameAmd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.21095_none_2c1e915738e6b2ec.manifest
File versionNot applicable
File size5,228
Date (UTC)22-Nov-2011
Time (UTC)07:23
PlatformNot applicable
File nameAmd64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21864_none_2e24879b35f57b93.manifest
File versionNot applicable
File size5,228
Date (UTC)22-Nov-2011
Time (UTC)06:56
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,103
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_172533fb6d386d6af34890b61a59142c_31bf3856ad364e35_6.1.7601.21864_none_8ac8096853e22bba.manifest
File versionNot applicable
File size721
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameIa64_35579153321dd4474987192ef491db74_31bf3856ad364e35_6.1.7600.21095_none_23362dbe993150ff.manifest
File versionNot applicable
File size721
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable
File nameIa64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7600.21095_none_d00199c980874ab2.manifest
File versionNot applicable
File size5,226
Date (UTC)22-Nov-2011
Time (UTC)07:00
PlatformNot applicable
File nameIa64_microsoft-windows-w..ovider-cimwin32-dll_31bf3856ad364e35_6.1.7601.21864_none_d207900d7d961359.manifest
File versionNot applicable
File size5,226
Date (UTC)22-Nov-2011
Time (UTC)06:44
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,947
Date (UTC)23-Nov-2011
Time (UTC)12:03
PlatformNot applicable

Applies to
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2639505
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support