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Article ID: 2647582 - Last Review: January 11, 2012 - Revision: 1.0

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SYMPTOMS

Consider the following scenario:
  • You have a Remote Desktop Session Host (RD Session Host) server that is running Windows Server 2008 R2.
  • You configure and enable the Turn on Remote Desktop IP Virtualization Group Policy setting in a Group Policy Object (GPO) in an Active Directory domain environment.
  • You apply the GPO to the RD Session Host server.
  • You try to update the Group Policy settings on the RD Session Host server.
In this scenario, updating the Group Policy settings fails on the RD Session Host server. When this issue occurs, you cannot manage the RD Session Host server by using Group Policy or by using other management software such as Microsoft System Center Configuration Manager 2007. Additionally, the RD Session Host server cannot communicate with the domain controllers in the same domain.

CAUSE

The issue occurs because the IP Virtualization Client (Tsvipcli.dll) on the RD Session Host server cannot find a certain Winsock provider in the protocol chain in some cases. This behavior causes the socket connection request to fail. Therefore, the RD Session Host server cannot connect to domain controllers to update Group Policy settings.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the Remote Desktop Services server role installed and the Remote Desktop Session Host role service enabled.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932  (http://support.microsoft.com/kb/976932/ ) Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix. To avoid restarting, stop the Remote Desktop Session Host role service.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tsvipcli.dll6.1.7600.2109641,98423-Nov-201106:34x64
Tsvipcli.dll6.1.7601.2186541,98423-Nov-201106:22x64
Tsvipcli.dll6.1.7600.2109633,79223-Nov-201105:29x86
Tsvipcli.dll6.1.7601.2186533,79223-Nov-201105:20x86

WORKAROUND

To work around this issue, configure Remote Desktop IP Virtualization on the RD Session Host server by using the Remote Desktop Session Host Configuration tool.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_630ccfacfacef157617dbb3d34fb302d_31bf3856ad364e35_6.1.7601.21865_none_aa9e03935f318390.manifest
File versionNot Applicable
File size1,094
Date (UTC)25-Nov-2011
Time (UTC)07:11
File nameAmd64_ff97db675ebb89a03c5d2249e381ee02_31bf3856ad364e35_6.1.7600.21096_none_f400488946cf68f3.manifest
File versionNot Applicable
File size1,094
Date (UTC)25-Nov-2011
Time (UTC)07:11
File nameAmd64_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.1.7600.21096_none_cb4910e125558764.manifest
File versionNot Applicable
File size16,167
Date (UTC)25-Nov-2011
Time (UTC)07:11
File nameAmd64_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.1.7601.21865_none_cd4f07252264500b.manifest
File versionNot Applicable
File size16,167
Date (UTC)25-Nov-2011
Time (UTC)07:11
File nameX86_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.1.7600.21096_none_6f2a755d6cf8162e.manifest
File versionNot Applicable
File size16,163
Date (UTC)25-Nov-2011
Time (UTC)07:11
File nameX86_microsoft-windows-t..-tsappsrv-component_31bf3856ad364e35_6.1.7601.21865_none_71306ba16a06ded5.manifest
File versionNot Applicable
File size16,163
Date (UTC)25-Nov-2011
Time (UTC)07:11

APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2647582
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