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Article ID: 2688326 - Last Review: March 13, 2012 - Revision: 2.0

SYMPTOMS

You receive errors, or nothing happens when you start an .EXE file in Windows 7 or Windows Vista. Additionally, you may receive messages saying that you have a virus.

CAUSE

This issue can occur if a virus or other 3rd party application has changed or corrupted some default registry settings.

RESOLUTION

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50850


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To resolve this issue, you can reset the registry settings to their default settings. To do this, follow these steps.
  1. Click the Startbutton and type regedit in the Search box
  2. Right-click Regedit.exe in the returned list and click Run as administrator
  3. Browse to the following registry key:

    HKEY_CLASSES_ROOT\.exe
  4. With .exe selected, right-click (Default) and click Modify…
  5. Change the Value data: to exefile
  6. Browse to and then click on the following registry key:

    HKEY_CLASSES_ROOT\exefile
  7. With exefileselected, right-click (Default) and click Modify…
  8. Change the Value data: to "%1" %*
  9. Browse to and then click on the following registry key:

    KEY_CLASSES_ROOT\exefile\shell\open
  10. With openselected, right-click (Default) and click Modify…
  11. Change the Value data: to "%1" %*
  12. Close the Registry Editor and restart your PC


Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) message.

MORE INFORMATION

If this does not resolve your issue, or clicking .EXE files starts the incorrect application, see this article:



APPLIES TO
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbfixme kbmsifixme KB2688326
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