DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2713128 - Last Review: May 24, 2013 - Revision: 4.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

Symptoms

Assume that you connect to a network printer that is hosted on a print server from a client computer that is running Windows 7 or Windows Server 2008 R2. The print server goes offline and then comes back online. In this situation, the client computer still displays the connection status of the network printer as offline.

Cause

This issue occurs when a restricted client thread detects an offline print server. In this situation, Windows registers a polling loop to check the status of the print server. After the polling loop is registered, Windows queries the print server periodically to check whether it is back online.

In rare cases, a client thread that has a restricted token detects that a print server is offline. In this situation, Windows registers the polling loop in the context of this thread. However, the thread does not have sufficient rights to query the print server. Therefore, the polling request fails.

Resolution

This hotfix is also available at Microsoft Update Catalog (http://catalog.update.microsoft.com/v7/site/Search.aspx?q=2713128) .

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932  (http://support.microsoft.com/kb/976932/ ) Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 0.21xxxWindows 7 and Windows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Win32spl.dll6.1.7600.21213492,03212-May-201204:35
Win32spl.dll6.1.7601.21993492,54412-May-201204:26
Win32spl.dll6.1.7600.21213492,03212-May-201204:35
Win32spl.dll6.1.7601.21993492,54412-May-201204:26
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32spl.dll6.1.7600.21213750,59212-May-201205:38x64
Win32spl.dll6.1.7601.21993750,59212-May-201205:24x64
Win32spl.dll6.1.7600.21213750,59212-May-201205:38x64
Win32spl.dll6.1.7601.21993750,59212-May-201205:24x64
Win32spl.dll6.1.7600.21213492,03212-May-201204:35x86
Win32spl.dll6.1.7601.21993492,54412-May-201204:26x86
Win32spl.dll6.1.7600.21213492,03212-May-201204:35x86
Win32spl.dll6.1.7601.21993492,54412-May-201204:26x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32spl.dll6.1.7600.212131,511,93612-May-201204:30IA-64
Win32spl.dll6.1.7601.219931,512,44812-May-201204:26IA-64
Win32spl.dll6.1.7600.21213492,03212-May-201204:35x86
Win32spl.dll6.1.7601.21993492,54412-May-201204:26x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameX86_1049d215149bc3658cb540e3ea92e4f4_31bf3856ad364e35_7.1.7600.21213_none_4a33868e79899740.manifest
File versionNot applicable
File size718
Date (UTC)14-May-2012
Time (UTC)11:27
File nameX86_3995a16f9d9b4c4258285ecdacfb3ffb_31bf3856ad364e35_6.1.7601.21993_none_528b0ff5f9c6a146.manifest
File versionNot applicable
File size718
Date (UTC)14-May-2012
Time (UTC)11:27
File nameX86_9be2e92a26d246ae55a05762e3fda5ee_31bf3856ad364e35_6.1.7600.21213_none_e71071d4d420b9cc.manifest
File versionNot applicable
File size718
Date (UTC)14-May-2012
Time (UTC)11:27
File nameX86_f558ff4224e2d74101094c62a33408b8_31bf3856ad364e35_7.1.7601.21993_none_579dc08734d0759e.manifest
File versionNot applicable
File size718
Date (UTC)14-May-2012
Time (UTC)11:27
File nameX86_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7600.21213_none_3a1cc1f3eb24623b.manifest
File versionNot applicable
File size10,424
Date (UTC)12-May-2012
Time (UTC)05:04
File nameX86_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.21993_none_3bacc777e88b7a6d.manifest
File versionNot applicable
File size10,424
Date (UTC)12-May-2012
Time (UTC)04:54
File nameX86_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7600.21213_none_2b8d3e39760b0b0a.manifest
File versionNot applicable
File size6,369
Date (UTC)12-May-2012
Time (UTC)05:02
File nameX86_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7601.21993_none_2d1d43bd7372233c.manifest
File versionNot applicable
File size6,369
Date (UTC)12-May-2012
Time (UTC)04:59
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_1e49ccb78e72b50b3f8f5386413dccd8_31bf3856ad364e35_6.1.7600.21213_none_7e3834a2ef00298c.manifest
File versionNot applicable
File size722
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_2012324ee106e3ca5c678fd6ca4f586c_31bf3856ad364e35_7.1.7601.21993_none_e271131531a169d7.manifest
File versionNot applicable
File size1,086
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_266831367b4efcec06814e17b9d22478_31bf3856ad364e35_6.1.7601.21993_none_f78206da8ae94ecc.manifest
File versionNot applicable
File size722
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_2eb87864457c829a52c1bb2609c3588a_31bf3856ad364e35_6.1.7601.21993_none_ebf41bda909a1adb.manifest
File versionNot applicable
File size722
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_42a9df3700e29cf4a4878240a8eb5958_31bf3856ad364e35_7.1.7600.21213_none_0f4242c0c3f73343.manifest
File versionNot applicable
File size1,086
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_51af1a3fed04914ee2a841192f940dec_31bf3856ad364e35_6.1.7600.21213_none_637f346c68599a7e.manifest
File versionNot applicable
File size722
Date (UTC)14-May-2012
Time (UTC)11:27
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7600.21213_none_963b5d77a381d371.manifest
File versionNot applicable
File size10,428
Date (UTC)12-May-2012
Time (UTC)06:05
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.21993_none_97cb62fba0e8eba3.manifest
File versionNot applicable
File size10,428
Date (UTC)12-May-2012
Time (UTC)05:53
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7600.21213_none_87abd9bd2e687c40.manifest
File versionNot applicable
File size6,373
Date (UTC)12-May-2012
Time (UTC)06:10
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7601.21993_none_893bdf412bcf9472.manifest
File versionNot applicable
File size6,373
Date (UTC)12-May-2012
Time (UTC)05:59
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7600.21213_none_a09007c9d7e2956c.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)04:52
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.21993_none_a2200d4dd549ad9e.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)04:43
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7600.21213_none_9200840f62c93e3b.manifest
File versionNot applicable
File size6,371
Date (UTC)12-May-2012
Time (UTC)04:53
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7601.21993_none_939089936030566d.manifest
File versionNot applicable
File size6,371
Date (UTC)12-May-2012
Time (UTC)04:44
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_40c4725de239978e8b80abfafa262111_31bf3856ad364e35_6.1.7600.21213_none_5d3b222c36e5211f.manifest
File versionNot applicable
File size1,084
Date (UTC)14-May-2012
Time (UTC)11:27
File nameIa64_550d8c079c792f1f4be5959ffc364bb5_31bf3856ad364e35_6.1.7601.21993_none_e16288fb61fbe7d9.manifest
File versionNot applicable
File size1,084
Date (UTC)14-May-2012
Time (UTC)11:27
File nameIa64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7600.21213_none_3a1e65e9eb226b37.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)05:51
File nameIa64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.21993_none_3bae6b6de8898369.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)05:45
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7600.21213_none_a09007c9d7e2956c.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)04:52
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.21993_none_a2200d4dd549ad9e.manifest
File versionNot applicable
File size10,426
Date (UTC)12-May-2012
Time (UTC)04:43

Applies to
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2713128
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support