DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 274403 - Last Review: October 21, 2013 - Revision: 4.1

Hotfix Download Available
View and request hotfix downloads
 
 
This article was previously published under Q274403
This article has been archived. It is offered "as is" and will no longer be updated.

SYMPTOMS

Exchange Server computers may encounter backlogs of items that are awaiting inbound conversion on the Internet Mail Service after you apply the fix from the following Microsoft Knowledge Base article:
268357  (http://support.microsoft.com/kb/268357/ ) Exchange Server 5.5 clients appear to hang when the information store queries the directory
The inbound conversion queue may not clear until the services are stopped and restarted. The services, particularly the information store, may take an abnormally long time to shut down or may stop responding (hang) while they are shutting down, whether or not the server has an Internet Mail Service configured.

CAUSE

The deadlock is caused by two threads that are waiting for two critical sections to complete. Thread 1 enters critsec A. Thread 2 enters critsec B. Before either thread releases the critical sections, thread 1 asks for critsec B and thread 2 asks for critsec A. This behavior was not a problem before the fix because the work being done before was all on the same thread, and locking order did not matter.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
191014  (http://support.microsoft.com/kb/191014/EN-US/ ) XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server Store.exe builds 5.5.2653.7 through 5.5.2653.18. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

MORE INFORMATION

To test this, import a lot of directory changes at the same time that you are modifying objects such as protocols, site addressing, or the Gateway Address Resolution Table (GWART). You must have many small changes being imported to catch this.

APPLIES TO
  • Microsoft Exchange Server 5.5 Service Pack 3
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbexchange550sp4fix kbfix kbqfe KB274403
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support