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Article ID: 2781106 - Last Review: November 6, 2012 - Revision: 3.0

Symptoms

Consider the following scenario:
  • You are unable to connect remotely to Windows Server 2012 Device Manager from a Windows 8-based computer
  • You are unable to connect remotely to Windows Server 2012 Device Manager from a Windows 7-based computer
  • You are unable to connect remotely to Windows Server 2008 R2 Device Manager from a Windows 8-based computer
  • You are unable to connect remotely to Windows 8 Device Manager from a Windows 7-based computer
Additionally, you may receive an error message that is similar to the following:

Unable to access the computer <computername>
Make sure that this computer is on the network, has remote administration enabled, and is running the "Plug and Play" and "Remote Registry" services

The error was: Access is denied


Note: Other various errors may occur depending on if you are connecting from Windows 8 or Windows 7 client computer.

Cause

This problem occurs because Remote access to the Plug and Play (PNP) RPC interface has been removed in Windows 8 and Windows Server 2012.

Resolution

You must login to the computer locally to utilize Device Manager.

More information

Previously, a Windows 7-based computer could connect to a Windows Server 2008 R2 computer. Access to Device Manager on a remote computer is "read-only." You cannot make any changes to devices or their settings.

To open Device Manager on a remote computer
  1. Open Computer Management (compmgmt.msc)
  2. On the Action menu, click Connect to another computer.
  3. In the Select Computer dialog box, do one of the following:
    • In the Another computer text box, type the name of the computer to access, and then click OK.
    • Click Browse, and then click Advanced to find the computer you want. Click OK when you have selected the correct computer.
If the connection is successful, the name of the computer appears in parentheses next to the Computer Management label in the upper left.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Standard without Hyper-V
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Enterprise without Hyper-V
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Datacenter without Hyper-V
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2012 Standard
  • Windows Server 2012 Datacenter
  • Windows 8 Enterprise
  • Windows 8 Pro
Keywords: 
KB2781106
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