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Article ID: 2786067 - Last Review: February 20, 2014 - Revision: 5.0

Symptoms

When you search for email messages or other Microsoft Outlook items that have been deleted but not permanently removed from a Microsoft Exchange Server mailbox, you discover that the items are unavailable.

Cause

This issue occurs because deleted items are stored in several mailbox locations before they are completely removed.

Resolution

Note This article describes a range of resolutions. This range includes tasks that most users are familiar with and also tasks that must be completed by a support engineer. To help determine which folders might not be empty, or to gain a sense of how many items might be present, run the following cmdlet:
Get-MailboxFolderStatistics xxxxSMTPxxxx | fl Identity,FolderPath,FolderSize,ItemsInFolder > output.txt
For information about recoverable items in Exchange Server 2010, go to the following TechNet website:
Recoverable Items folder (http://technet.microsoft.com/en-us/library/ee364755.aspx)
An Exchange mailbox contains three folders that store deleted items:
  • Deleted Items
  • Deletions
  • Purges


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A screen shot of the Deleted Items, Deletions and Purges folders page


Two of these folders exist in the mailbox dumpster and are not in the mailbox folder list. All three folders are described in detail in the following sections.

Note Email folders, subfolders, and structures are not recoverable. Only the contents of email folders that are missing or deleted can be restored.

Deleted Items folder

The Deleted Items folder is a default folder that is available in the folder list of an Exchange mailbox.

When you take one of the following actions, an item is moved to the Deleted Items folder in Outlook:
  • You press the Delete button on the keyboard when an item is highlighted.
  • You right-click an item when the item is highlighted and then click Delete.
  • You accept or delete meeting invitations from the Inbox folder. (Meeting invitations are automatically moved to the Deleted Items folder after they are accepted or deleted.)

Deletions folder

The Deletions folder is in the mailbox dumpster. You can access the Deletions folder from Outlook. For more information about how to access the Deletions folder in different versions of Outlook, go to one of the following Microsoft websites.
  • For Outlook 2013
    Recover deleted items (http://office.microsoft.com/en-us/outlook-help/recover-deleted-items-HA102749439.aspx)
  • For Outlook 2010
    Recover deleted items (http://office.microsoft.com/en-us/outlook-help/recover-deleted-items-HA010355039.aspx)
  • For Outlook 2007
    Recover deleted items (http://office.microsoft.com/en-us/outlook-help/recover-deleted-items-HA010183568.aspx)
When you take one of the following actions, an item is moved to the Deletions folder:
  • You hold down the Shift key when an item is highlighted and then press the Delete key. This action bypasses the Deleted Items folder. You are prompted to continue and permanently delete the item.
  • You remove items from the Deleted Items folder by deleting the items or emptying the folder. You are prompted to continue and permanently delete the item.
  • You configure retention policies to move older items from the Deleted Items folder to the dumpster. For more information about retention policies, go to the following Microsoft website:
    Assign retention policy to email messages (http://office.microsoft.com/en-us/outlook-help/assign-retention-policy-to-email-messages-HA101861782.aspx)
  • You configure the AutoArchivefeature in Outlook to remove items automatically. For more information about AutoArchivesettings and how to configure the AutoArchivefeature, go to one of the following Microsoft websites, as appropriate for your version of Outlook.

Purges folder

If an item is manually removed from the Deletions folder, the item is moved to the Purges folder. The item remains in the Purges folder until the 30-day dumpster-retention period is completed.

You cannot access the Purges folder through Outlook. You can access the Purges folder by using Microsoft Exchange Server MAPI Editor (MFCMAPI). To do this, follow these steps:

Note By default, MAPI access is blocked for deskless-worker (Exchange Online Kiosk) mailboxes. To follow the steps in the following list, the MAPI block must be temporarily removed. Members of the Protocol Control self-service group can use Windows Remote PowerShell to temporarily enable MAPI for deskless-worker mailboxes.


To remove the MAPI block, run the following cmdlet in Windows Remote PowerShell:
Set-CASMailbox <UserIdentity> -MAPIBlockOutlookVersions $NULL
To restore the MAPI block, run the following cmdlet in Windows Remote PowerShell:
Set-CASMailbox <UserIdentity> -MAPIBlockOutlookVersions 0.0.0-100.0.0

Note The following procedure requires the user to have full access to the mailbox and to a profile that is configured in online mode.
  1. Download MFCMAPI from the following CodePlex website:
    MFCMAPI (http://mfcmapi.codeplex.com/releases/view/93078)
    Note You will have the option of downloading the 32-bit or 64-bit executable file. You should download the version that corresponds to the version of Outlook that is installed on your computer.
  2. Double-click the executable file to start MFCMAPI.
  3. When you are prompted with the information screen, click OK.
  4. On the Session menu, click Logon.

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    A screen shot of the MFCMAPI page, showing the Session menu highlighted
  5. Select the appropriate online profile for the mailbox that is to be accessed, or click New.

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    A screen shot of the Choose Profile page, selecting the appropriate profile and clicking the New button

  6. Double-click the first entry in the top section of the screen. The user's mailbox will open.

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    A screen shot of the MFCMAPI Build page, showing the first entry in the top section highlighted

  7. Expand Root Container, and then expand Recoverable Items. You will see three subfolders: Deletions, Purges, and Versions.

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    A screen shot of the Recoverable Items page, showing three subfolders: Deletions, Purges, and Versions


    Notes
    • The Versions folder contains the original copies of items that were changed. Recovering items from this folder will help if a user wants access to an earlier copy of a changed appointment or contact. You should never restore all contents from the Versions folder to a user's active calendar. These items are usually referenced for troubleshooting only.
    • The Audit folder exists if mailbox auditing is enabled for the mailbox.
  8. Double-click the Purges folder. A new window opens. In this window, the top section lists all the items in the folder. The bottom section contains the properties that are associated with the message.

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    A screen shot of the Purges folder page, the top section listing all the items in the folder and the bottom section containing the properties that are associated with the message

  9. Click any of the columns to sort in ascending or descending order. If you find the message that you want to recover, you can take one of the following actions for one or multiple messages:
    • Export the message to a file. To do this, right-click the item, and then select Export message.

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      A screen shot of the Purges page, right-clicking an item and selecting Export message

    • Copy and paste the item. To do this, , follow these steps:
      1. Right-click the item and then select Copy Message.
      2. Right-click the folder into which you want to paste the item, and then select Paste. You are given the option to move the message instead.

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      A screen shot of the Copy Message page


    If you want just one version of the item in the destination folder, click to select the MESSAGE_MOVE check box, and then click OK.

    Note The mailbox folder list is under Top of Information Store.

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    A screen shot of the MFCMAPI page, selecting the MESSAGE_MOVE check box





Applies to
  • Microsoft Business Productivity Online Dedicated
  • Microsoft Business Productivity Online Suite Federal
  • Microsoft Exchange Online Dedicated
  • Microsoft Business Productivity Online Standard Suite
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Outlook 2010
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
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