DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2790831 - Last Review: February 13, 2013 - Revision: 1.0

Hotfix Download Available
View and request hotfix downloads
 

On This Page

Symptoms

Assume that you use the WmiPrvSE.exe process for performance data collection on a Windows 8-based or Windows Server 2012-based computer. In this situation, a handle leak may occur in one of the WmiPrvSE.exe instances. Additionally, Microsoft System Center 2012 features that rely on performance data (for example, System Center Virtual Machine Manager (SCVMM), Data Protection Manager (DPM), and System Center Operations Manager (SCOM) may fail.

Cause

This issue occurs because, when Performance Data Helper log files are opened, Pdh.dll creates a new thread by using the CreateThread() API to process the log files. The CreateThread() API then returns a handle to the newly created thread. The handle remains open after these log files are closed, causing a handle leak.

Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

Collapse this imageExpand this image
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8 and Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows 8 and Windows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
Collapse this imageExpand this image
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pdh.dll6.2.9200.20582245,76012-Dec-201204:29x86
Pla.dll6.2.9200.163841,421,82426-Jul-201203:19x86
Plamig.dll6.2.9200.1638498,81626-Jul-201203:19x86
Collapse this imageExpand this image
For all supported x64-based versions of Windows 8 and of Windows Server 2012
Collapse this imageExpand this image
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pdh.dll6.2.9200.20582297,98412-Dec-201204:31x64
Pla.dll6.2.9200.163841,379,84026-Jul-201203:06x64
Plamig.dll6.2.9200.16384104,96026-Jul-201203:07x64
Collapse this imageExpand this image

Collapse this imageExpand this image

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Collapse this imageExpand this image

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
Collapse this imageExpand this image
Collapse this tableExpand this table
File nameX86_microsoft-windows-p..rastructureconsumer_31bf3856ad364e35_6.2.9200.20582_none_b10f389d1af83be1.manifest
File versionNot applicable
File size111,752
Date (UTC)12-Dec-2012
Time (UTC)23:53
PlatformNot applicable
Collapse this imageExpand this image
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
Collapse this imageExpand this image
Collapse this tableExpand this table
File nameAmd64_microsoft-windows-p..rastructureconsumer_31bf3856ad364e35_6.2.9200.20582_none_0d2dd420d355ad17.manifest
File versionNot applicable
File size111,758
Date (UTC)12-Dec-2012
Time (UTC)23:55
PlatformNot applicable
File nameWow64_microsoft-windows-p..rastructureconsumer_31bf3856ad364e35_6.2.9200.20582_none_17827e7307b66f12.manifest
File versionNot applicable
File size92,668
Date (UTC)12-Dec-2012
Time (UTC)23:55
PlatformNot applicable
Collapse this imageExpand this image

Collapse this imageExpand this image

Applies to
  • Windows 8
  • Windows 8 Pro
  • Windows 8 Enterprise
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2790831
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support