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Article ID: 2801423 - Last Review: March 13, 2013 - Revision: 1.0

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Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You access a Distributed File System (DFS) share by using a nested DFS link from the computer. For example, example, assume that the following are domain-based DFS namespaces:
    • DFSRoot1: \\Domain name\DFSRoot1
    • DFSRoot2: \\Domain name\DFSRoot2
    Also, assume that the \\Domain name\DFSRoot1\LinkA DFS link maps to DFSRoot2. Additionally, assume that the \\Domain name\DFSRoot2\LinkB DFS link maps to the following shared folder:
    \\Server name\share name
    You access the shared folder through the following DFS path:
    \\Domain name\DFSRoot1\LinkA\LinkB
  • You open the Properties dialog box to check the NTFS permissions for the DFS share.
In this scenario, the computer takes longer than expected to display the permissions information. Specifically, the computer takes about 6-10 seconds to display the NTFS permissions information.

Notes
  • This issue does not occur if you access the DFS share through one of the following paths:
    \\Server name\share name
    \\Domain name\DFSRoot2\LinkB
  • This issue typically occurs when the domain controllers in the domain are in different remote sites and resolve the Fully Qualified Domain Name (FQDN) of the domain from a site. This behavior causes a workstation to contact a domain controller in another site. For example, the query time is longer than expected for the following domain controllers: 
    • Domain controller DC1: (site 1) 10.10.1.1
    • Domain controller DC2: (site 2) 192.168.2.1
    • Work station WS: (site 1) 192.168.1.1
    This occurs because one of the domain controllers is in a remote site and Windows 7 and Windows Server 2008 R2 implement Internet Engineering Task Force (IETF) RFC 3484. Therefore, WS contacts DC2 to resolve the FQDN of the domain.
  • For more information about IETF RFC 3484, click the following article number to view the article in the Microsoft Knowledge Base:
    969029  (http://support.microsoft.com/kb/969029/ )   The functionality for source IP address selection in Windows Server 2008 and in Windows Vista differs from the corresponding functionality in earlier versions of Windows

Cause

This issue occurs because the system returns the FQDN of the domain instead of the host name of a nested DFS path. Additionally, when you check the NTFS permissions, the system queries the Domain Name System (DNS) records, and these may point to any domain controller in the domain.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932  (http://support.microsoft.com/kb/976932/ ) Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

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The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
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    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
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File nameFile versionFile sizeDateTimePlatform
Rshx32.dll6.1.7601.2224344,03206-Feb-201304:24x86
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For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
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File nameFile versionFile sizeDateTimePlatform
Rshx32.dll6.1.7601.2224354,78406-Feb-201305:21x64
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For all supported IA-64-based versions of Windows Server 2008 R2
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File nameFile versionFile sizeDateTimePlatform
Rshx32.dll6.1.7601.22243117,24806-Feb-201304:25IA-64
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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

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Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
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File nameX86_microsoft-windows-acluifilefoldertool_31bf3856ad364e35_6.1.7601.22243_none_f03315cf269d7ac6.manifest
File versionNot applicable
File size10,735
Date (UTC)06-Feb-2013
Time (UTC)06:09
PlatformNot applicable
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Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
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File nameAmd64_microsoft-windows-acluifilefoldertool_31bf3856ad364e35_6.1.7601.22243_none_4c51b152defaebfc.manifest
File versionNot applicable
File size10,739
Date (UTC)06-Feb-2013
Time (UTC)06:08
PlatformNot applicable
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Additional files for all supported IA-64-based versions of Windows Server 2008 R2
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File nameIa64_microsoft-windows-acluifilefoldertool_31bf3856ad364e35_6.1.7601.22243_none_f034b9c5269b83c2.manifest
File versionNot applicable
File size10,737
Date (UTC)06-Feb-2013
Time (UTC)05:33
PlatformNot applicable
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Applies to
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2801423
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