DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2811266 - Last Review: January 30, 2013 - Revision: 1.0

Symptoms

On a computer that is running Windows Vista or Windows Server 2008, a user may experience graphics corruption and artefacts after printing many times. Using Task Manager to view the GDI Objects may show that the value has reached 10,000 objects.

Cause

This issue occurs because of a GDI object leak in the print notification DLL (prnntfy.dll) for the Explorer. Each print job causes a print notification icon to be displayed in explorer’s notification bar. When prnntfy.dll creates this icon it leaks a GDI icon object. Eventually, the maximum number of GDI objects are created, and the explorer is not able to perform normal graphics operations.

Workaround

To work around this issue, disable the print notification icon by editing the Windows registry.

Important This section contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

To disable the print notification icon, follow the below mentioned steps:

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Print
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the New Value #1 box, type DisableTrayNotification, and then press ENTER.
  5. Right-click DisableTrayNotification, and then click Modify.
  6. In the Value data box, type 1 to disable the print notification, and then click OK.
  7. Quit Registry Editor.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

Applies to
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Service Pack 2
  • Windows Server 2008 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Service Pack 2
Keywords: 
KB2811266
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support