DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 2823483 - Last Review: May 28, 2013 - Revision: 9.0

Symptoms

Internet Explorer 10 for Windows 7 does not install correctly, and you receive error code 9C57 together with the following error message:
Internet Explorer needs an update before installing

Cause

This issue occurs because some computers have hybrid video cards that are not yet compatible with Internet Explorer 10 for Windows 7. Internet Explorer 10 will not install on these computers until updated hardware drivers are available for these video cards.

More information

The following tables list the known computer models that are affected and include download links to compatible drivers if such links are available. If a link is not available for your computer model, you should check your video card manufacture's website for more details, and then download and install the updated driver.
Dell systems
Collapse this tableExpand this table
SystemGraphics hardwareLatest compatible drivers
Inspiron 14R N4110 and N4120AMD Radeon HD 6470M
AMD Radeon HD 6630M
AMD Radeon HD 7450M
AMD Radeon HD 7650M
None
Vostro 3350 & 3550AMD Radeon HD 6630M
AMD Radeon HD 7650M
8.901.1.1, A10 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=G22HG) (Released 4/2012)
Inspiron 15R N5110AMD Radeon HD 6470M8.901.1.1, A10 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=G22HG) (Released 4/2012)
Vostro 3450AMD Radeon HD 6630M
AMD Radeon HD 7650M
None
Inspiron 14 N4050AMD Radeon HD 6470M8.930.0.0000, A03 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=KK4KW) (Released 4/2012)
8.860.0.0, A01 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=CFJ09) (Released 8/2011)
Vostro 1450AMD Radeon HD 6470M
AMD Radeon HD 7450M
8.88+2342, A02 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=2M9XT) , A03 (Released 3/2012)
8.860.0.0, A01 (http://www.dell.com/support/drivers/us/en/19/DriverDetails?driverId=CFJ09) (Released 8/2011)
HP systems
Collapse this tableExpand this table
SystemGraphics hardwareLatest compatible drivers
Pavilion dv6 (dv6-6007tx, dv6-6b06eg, dv6-6b07sz, dv6-6b56ex)
Pavilion dv7 (dv7-6135dx, dv7-6197ca, dv7-6b40ew)
AMD Radeon HD 6490M

AMD Radeon HD 6770M
8.882.2.3000 (http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=ob-105178-1&lang=en&cc=us&idx=0&mode=4&) (Released 11/2011)
Pavilion g4 (1212tx)
Pavilion g6 (1160ee, 1320ee)
Pavilion g7 (1226em)
AMD Radeon HD 6470M8.882.2.0 (http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=ob-99756-1&lang=en&cc=us&mode=3&) (Released 10/2011)
ProBook 4330s, 4331s, 4431s 4530s, 4730sAMD Radeon HD 6490M8.91-111013A-128465C (http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?swItem=ob-101195-1&lang=en&cc=us&mode=3&) (Released 11/2011)
Pavilion dv4 (3029tx)AMD Radeon HD 6750MNone
Envy 14 (2070ez)AMD Radeon HD 6630MNone
Lenovo systems
Collapse this tableExpand this table
SystemGraphics hardwareLatest compatible drivers
G570AMD Radeon HD 6370M
AMD Radeon HD 7370M
None
G470AMD Radeon HD 6370M
AMD Radeon HD 7370M
None
ThinkPad Edge E420AMD Radeon HD 6470M
AMD Radeon HD 6630M
8.951.0.0000 (http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS014099) (Released 7/2012)
G770AMD Radeon HD 6650MNone
IdeaPad Y470AMD Radeon HD 6730MNone
ThinkPad Edge E420s
ThinkPad Edge S420
AMD Radeon HD 6630MNone
IdeaPad U400AMD Radeon HD 6470M 8.851.0.0 (http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS027309) (Released 11/2011)
Sony systems
Collapse this tableExpand this table
SystemGraphics hardwareLatest compatible drivers
Sony VPCCA1x
Sony VPCCA2x
Sony VPCCA3x
Sony VPCCA4x
Sony VPCCB1x
Sony VPCCB2x
Sony VPCCB3x
Sony VPCCB4x
AMD Radeon HD 6630MNone
Sony VPCJ2xAMD Radeon HD 6470MNone
Note For computers for which "None" is listed in the "Latest compatible drivers" column, Microsoft is currently working with AMD to find the cause of the problem and determine the appropriate fix. If you have platform update KB 2670838 for Windows 7 installed on this computer, we recommend that you uninstall the update. 

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2670838  (http://support.microsoft.com/kb/2670838/ ) A platform update is available for Windows 7 SP1 and Windows Server 2008 R2 SP1

Status

Microsoft is working with device manufacturers to provide updated software to resolve this issue. New information about updated driver software will be added to Knowledge Base article 2670838  (http://support.microsoft.com/kb/2670838/ )  when that information becomes available.

Applies to
  • Internet Explorer 10
  • Windows 7 Service Pack 1
Keywords: 
kbtshoot kbsurveynew KB2823483
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support