DetailPage-MSS-KB

Microsoft small business knowledge base

Article ID: 285393 - Last Review: October 6, 2011 - Revision: 3.0

This article was previously published under Q285393

On This Page

SUMMARY

This article provides troubleshooting procedures that you can use to identify damaged files in Microsoft Word for Mac and, in some cases, recover such files.

Damaged document files can cause any program to exhibit unusual behavior. Such behavior occurs because the program is receiving incorrect information from the damaged file.

MORE INFORMATION

How to Identify a Damaged File

Damaged files often cause behavior that is not part of the program design--for example, infinite repagination, incorrect document layout and formatting, unreadable characters on the screen, error messages during processing, system hangs or crashes when you load or view the file, or any other unusual behavior that cannot be attributed to the normal operation of the program. These behaviors also can be caused by factors other than document damage. To rule out other factors, follow these troubleshooting tips:
  • Check for similar behavior in other documents.
  • Check for similar behavior in other programs.
  • Take the file in question to another computer, and attempt to duplicate the behavior.
  • Use a different printer driver, and attempt to duplicate the behavior. To use a different printer driver, follow these steps:

    1. Select Chooser on the Apple menu.
    2. In the Chooser, select a different printer driver, and then close the Chooser.
    3. In Word for Mac, select Page Setup on the File menu, to verify that the printer driver that you selected in the Chooser is selected in Word for Mac.
  • Rename any templates that are attached to the document, and then attempt to duplicate the behavior.
  • Start the computer again, with extensions turned off to disable any third-party programs that are running (such as terminate-and-stay-resident programs [TSRs], font managers, and screen savers). Then attempt to duplicate the behavior. For additional information about how to start the computer with extensions off, click the article number below to view the article in the Microsoft Knowledge Base:
    263159  (http://support.microsoft.com/kb/263159/EN-US/ ) How to Troubleshoot Extension Conflicts on the Macintosh
If the problem occurs only with a single document after you perform the preceding steps, your document is probably damaged. If the program quit unexpectedly before the file was closed, and the AutoRecover option was enabled, an AutoRecover file may have been created. You can use this AutoRecover file to recover the file in question.

The AutoRecover feature in Word for Mac attempts to automatically recover text from a document that was open when Word for Mac stopped responding. When you restart Word for Mac after it stops responding (hangs), a dialog box will be displayed with the following message:
Word encountered file damage while opening File Name. Part of this document may be recoverable. Attempt Recovery Now?
NOTE: This recovery may take some time, depending on the size of the document and the amount of damage in the document.

After the document is recovered, immediately use the Save As command on the File menu to save the document with a new file name. This ensures that the original document will be available for other recovery attempts. This automatic recovery method strips all formatting, graphics, and objects from the document.

Other methods listed later in this article may allow you to recover more of your original formatting from the damaged document.

For more information about the AutoRecover feature, see the "Prevent Loss of Word and Recover Lost Documents" topic in Word for Mac Help.

How to Correct a Damaged Document

There are several techniques you can use to try to correct a damaged document. The method that you use depends on the type and severity of the damage and the type of behavior that is exhibited. Although many of these methods succeed regularly, not every damaged document can be recovered. Keeping a backup copy of a document is the best way to ensure its recovery.

The following troubleshooting procedures are divided into two sections: "If the File Can Be Opened in Word for Mac" and "If the File Cannot Be Opened in Word for Mac." Use the appropriate section for your situation.

If the File Can Be Opened in Word for Mac

If you can open the file in Word for Mac, use one of the following methods.

Method 1: Convert the File to Another Format

Convert the file to another format, and then convert it back to its native format.

This is the easiest and most complete document recovery method; always try it first. Save the file in Rich Text Format (RTF). This format preserves the formatting in your Word for Mac document. After you save the file in RTF, reopen the file in Word for Mac, and then convert it from RTF. If this method succeeds, the file damage is removed during conversion.

To save the file as RTF, follow these steps:
  1. On the File menu, click Save As.
  2. Click the Format list, and then select Rich Text Format.
  3. Change the name of the document. (This is recommended so that you can continue with the other steps by using the original unmodified document.)
  4. Click Save.
If the damage persists after you save the file as RTF, try to save the file in one of the following file formats:
  • Other word processing formats
  • Text-Only
NOTE: Saving a file in Text-Only format frequently corrects the damage problem; however, all formatting is lost, including graphics and field codes in Word for Mac. This method requires more reformatting; therefore, use it only after other file formats fail to correct the problem.

For additional information about loss of Visual Basic for Applications code in Word for Mac documents that are converted to other file formats, click the following article number to view the article in the Microsoft Knowledge Base:
184153  (http://support.microsoft.com/kb/184153/ ) WD98: VBA Code Lost After Converting to Another Document Format

Method 2: Copy Everything Except the Last Paragraph Mark to a New Document

Word for Mac associates a wide variety of formatting with the last paragraph mark, especially section and style formatting. If you copy everything in the file, except the last paragraph mark, to a new file, the damage may be left behind in the original document.

To copy everything except the last paragraph mark in the document, follow these steps:
  1. Open the document that exhibits the odd behavior.
  2. On the Edit menu, click Select All.
  3. With the document selected, press COMMMAND+SHIFT+Left directional key. (This removes only the last paragraph mark from the selection.)
  4. On the Edit menu, select Copy.
  5. On the File menu, select New Document.
  6. In the new document, select Paste on the Edit menu.

    NOTE: In the new document, you may need to reapply the section formatting or style formatting.

Method 3: Copy the Undamaged Portions of the File to a New File

Sometimes you can determine the location of damage in your file by looking at the file or testing the file to determine when the behavior occurs. Another way to determine what area of the file is damaged is to copy either one page at a time or a series of pages into a new file. Save the new file, and then test for the original behavior. If the behavior does not occur, continue copying pages, saving, and testing until the original behavior occurs.

If you can find what area of the file is damaged, you can copy everything except the damaged portion to a new file, and then follow these steps to reconstruct your document:
  1. Copy the undamaged portions of your document and paste them into a new file (you may not want to select the final paragraph mark of this selection, because that paragraph mark may contain some incorrect information).
  2. Save a copy of the damaged document in Text-Only format.
  3. Open the Text-Only file.
  4. Copy the text from this file, and then paste it into the file that contains the undamaged portion of your file.
  5. Reformat the sections of the document that you pasted in step 4, and then save the recovered document.

If the File Cannot Be Opened in Word for Mac

If you cannot open the file in Word for Mac, use one of the following methods as appropriate.

Method 1: Insert the File into a Blank Document

If you cannot open a file to copy all the text (except the final paragraph mark), you may be able to insert the file into a new document. This inserts a new final paragraph mark onto the file that you are correcting. To do this, follow these steps:
  1. Create a new document based on the Normal template.
  2. On the Insert menu, click File. Select the damaged document, and then click OK.

Method 2: Use the Paste Link Command to Open the Document with a Link

This method uses a "dummy" document to create a link and then switches the link between the "dummy" document and the damaged document.

Follow these steps to use a paste-link operation to open a damaged document:
  1. Close all open documents in Word for Mac, and then open a new blank document.
  2. Type Test.
  3. Select the word Test. On the Edit menu, click Copy.
  4. On the File menu, click New and then open a new blank document.
  5. On the Edit menu, click Paste Special. In the Paste Special dialog box, click Paste Link. In the As box, click Formatted Text (RTF), and then click OK.
  6. On the Edit menu, click Links.
  7. In the Links dialog box, click Change Source. In the Open dialog box, locate and select the document that you want to recover. Click Open and then click OK.
  8. When the document opens, click Save As on the File menu. Type a new name for the document, and then click Save.
  9. With the document open, click Links on the Edit menu.
  10. In the Links dialog box, click Break Links. In the dialog box that appears, click Yes to break the link.
NOTE: After the link is broken, you should save the document before you close it or modify it.

Method 3: Open the File by Using "Recover Text from Any File"

As a last resort, you can use the special "Recover Text from Any File" converter to manually open damaged documents. This converter removes all formatting, graphics, and embedded objects from the file and leaves only readable text (ASCII characters). Because of the way that Word for Mac document files are organized and saved, the text may be disjointed or duplicated.

With even the simplest files, considerable reformatting is required. With smaller files, you may want to open a new second document and copy and paste text from the recovered document into the new document, because there is so much unwanted text recovered.

To use the "Recover Text from Any File" converter to open a document, follow these steps:
  1. On the File menu, click Open.
  2. Click the Show list, and then click Recover Text from Any File.
  3. Locate the folder that contains the damaged file, and then select the file.
  4. Click Open.
NOTE: The recovery process can take some time, depending on the size of the document and the type of damage. As soon as the recovery is complete, click Open on the File menu, and then change List Files of Type back to Word Documents or Readable Files.

TIP: Save the recovered file with a new name at this point. This prevents you from accidentally overwriting the original document and ensures that the original document remains available for other recovery attempts.

Method 4: Open As Copy

To open a copy of a damaged document, follow these steps:
  1. Close all open documents.
  2. Click Open on the File menu.
  3. Select Copy from the Open list.
  4. Select the damaged file.
  5. Click Open.

APPLIES TO
  • Microsoft Word 2004 for Mac
  • Microsoft Word X for Mac
  • Microsoft Word 2001 for Mac
Keywords: 
dftsdahomeportal kbinfo KB285393
Share
Additional support options
Ask The Microsoft Small Business Support Community
Contact Microsoft Small Business Support
Find Microsoft Small Business Support Certified Partner
Find a Microsoft Store For In-Person Small Business Support