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Article ID: 2871372 - Last Review: October 16, 2013 - Revision: 6.0

Symptoms

Consider the following scenario:
  • You install Windows 8 or Windows Server 2012.
  • You open Device Manager after the installation is complete.
In this scenario, Device Manager displays a yellow exclamation mark next to the WAN Miniport (Network monitor) device. Additionally, the Details tab of the device properties window displays the following message:

The device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Cause

This issue occurs because Windows cannot load the drivers that are required for the WAN (Network monitor) device. Because there is no driver associated with the device, it cannot be removed from Device Manager.

Resolution

To prevent this issue during future installs, you must integrate update 2822241 (http://support.microsoft.com/kb/2822241) into the installation media that you use during setup.

For information about how to use Deployment Image Servicing and Management (DISM) to integrate a hotfix package into installation media, see Add or remove packages offline (http://technet.microsoft.com/en-us/library/hh824838.aspx) .

Workaround

To work around the problem, go to the "Fix it for me" section. If you prefer to work around the problem yourself, go to the "Let me fix it myself" section.

Fix it for me

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To work around the problem, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
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Fix this problem (http://go.microsoft.com/?linkid=9838607)
Microsoft Fix it 20114
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Notes
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  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) message.
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Let me fix it myself

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If you have already installed the operating system and are currently receiving a "code 31" error on the WAN Miniport (Network Monitor) device, follow these steps:
  1. Open Device Manager.
  2. Right-click the WAN miniport (Network monitor) device, and then click Update Driver Software.
  3. Click Browse my computer for driver software.
  4. Click Let me pick from a list of device drivers on my computer.
  5. Clear the Show compatible hardware check box.
  6. In the column on the left side, select Microsoft, and in the column on the right side, select Microsoft KM-TEST Loopback Adapter.
  7. In the Update Driver Warning dialog box, click Yes to continue installing this driver.
  8. After the driver is installed, right-click the device, and then click Uninstall.
  9. After the device is uninstalled, right-click the computer name in Device Manager, and then click Scan for hardware changes.
  10. On the View menu, click Show hidden devices.
The WAN Miniport (Network monitor) device should now be started and no longer have a yellow exclamation mark next to it.
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Applies to
  • Windows 8
  • Windows Server 2012 Standard
  • Windows Server 2012 Datacenter
Keywords: 
kbfixme kbmsifixme KB2871372
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